aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3splt/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-06-14 08:16:16 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-06-14 08:16:16 +0000
commitdd97aea9542b7ae1a80a95a53a503fbd2c06ada0 (patch)
tree382338f51a7c3029a6b46600dadcef1fa1a7e953 /audio/mp3splt/Makefile
parent8f46be35caeab74bbc75aee5cdeef5876d7b7962 (diff)
downloadports-dd97aea9542b7ae1a80a95a53a503fbd2c06ada0.tar.gz
ports-dd97aea9542b7ae1a80a95a53a503fbd2c06ada0.zip
Notes
Diffstat (limited to 'audio/mp3splt/Makefile')
-rw-r--r--audio/mp3splt/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
new file mode 100644
index 000000000000..233cb0120f6e
--- /dev/null
+++ b/audio/mp3splt/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: audio/mp3splt
+# Date created: 30.05.2003
+# Whom: Ulrich Spoerlein <q@uni.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3splt
+PORTVERSION= 1.8
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= q@uni.de
+COMMENT= Utility to split mp3 and ogg files (via CUE sheets)
+
+LIB_DEPENDS= mad.1:${PORTSDIR}/audio/mad \
+ vorbis.2:${PORTSDIR}/audio/libvorbis \
+ ogg.4:${PORTSDIR}/audio/libogg
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAN1= mp3splt.1
+
+.include <bsd.port.mk>