aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3splt
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-30 18:23:58 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-30 18:23:58 +0000
commitc4c9fa56754e87b687f3a8cd53ac37bdedf451c8 (patch)
treebba4b67f59de5cf193e1f0e36e1ece598c78f161 /audio/mp3splt
parente1f6a6e1a8adf14ab4c1739cef617b657adb4bd9 (diff)
downloadports-c4c9fa56754e87b687f3a8cd53ac37bdedf451c8.tar.gz
ports-c4c9fa56754e87b687f3a8cd53ac37bdedf451c8.zip
Notes
Diffstat (limited to 'audio/mp3splt')
-rw-r--r--audio/mp3splt/Makefile32
-rw-r--r--audio/mp3splt/distinfo6
-rw-r--r--audio/mp3splt/files/patch-mp3splt.c16
-rw-r--r--audio/mp3splt/files/patch-splt.h11
4 files changed, 13 insertions, 52 deletions
diff --git a/audio/mp3splt/Makefile b/audio/mp3splt/Makefile
index cb6e8a830ff5..2a972edb0aa5 100644
--- a/audio/mp3splt/Makefile
+++ b/audio/mp3splt/Makefile
@@ -6,36 +6,24 @@
#
PORTNAME= mp3splt
-PORTVERSION= 2.1c
-PORTREVISION= 3
+PORTVERSION= 2.2.3
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+MASTER_SITES= SF
-MAINTAINER= fk@fabiankeil.de
+MAINTAINER= citrin@citrin.ru
COMMENT= Utility to split mp3 and ogg files (via CUE sheets)
-OPTIONS= VORBIS "Ogg Vorbis support" On
-
-.include <bsd.port.pre.mk>
-
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
-
-.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis \
- ogg.5:${PORTSDIR}/audio/libogg
-.else
-CONFIGURE_ARGS+=--disable-ogg
-.endif
+LIB_DEPENDS= mp3splt:${PORTSDIR}/audio/libmp3splt
+USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
MAN1= mp3splt.1
PLIST_FILES= bin/mp3splt bin/oggsplt
-.include <bsd.port.post.mk>
+post-install:
+ @${LN} -fsv ${PREFIX}/bin/mp3splt ${PREFIX}/bin/oggsplt
+
+.include <bsd.port.mk>
diff --git a/audio/mp3splt/distinfo b/audio/mp3splt/distinfo
index 901b410c2093..43bc298daa7c 100644
--- a/audio/mp3splt/distinfo
+++ b/audio/mp3splt/distinfo
@@ -1,3 +1,3 @@
-MD5 (mp3splt-2.1c-src.tar.gz) = b355835e4d57b8b921a14a6485244c87
-SHA256 (mp3splt-2.1c-src.tar.gz) = 6f325194345b64ef132defa9ab821352ddae197459357560b2cc1a459c22a9ec
-SIZE (mp3splt-2.1c-src.tar.gz) = 131810
+MD5 (mp3splt-2.2.3.tar.gz) = aa67e24931c62d2f09be13303fbf410e
+SHA256 (mp3splt-2.2.3.tar.gz) = aae0abb51f537224135204de2dea516a2293a9385f58c7167c483df28a717b04
+SIZE (mp3splt-2.2.3.tar.gz) = 135298
diff --git a/audio/mp3splt/files/patch-mp3splt.c b/audio/mp3splt/files/patch-mp3splt.c
deleted file mode 100644
index 323aee6be945..000000000000
--- a/audio/mp3splt/files/patch-mp3splt.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- mp3splt.c.orig 2008-06-25 00:19:32.000000000 -0400
-+++ mp3splt.c 2008-06-25 00:20:37.000000000 -0400
-@@ -114,6 +114,13 @@
- if (state->mstate) {
- fclose(state->mstate->file_input);
- mp3_state_free(state->mstate);
-+ /*
-+ * Explicitly setting mstate to NULL
-+ * prevents encoding misdetection (resulting
-+ * in a crash) if an mp3 file is followed by
-+ * a vorbis file.
-+ */
-+ state->mstate = NULL;
- }
- #ifndef NO_OGG
- else if (state->ostate) { // If file has been opened with ov_open we should close it using ov_clear()
diff --git a/audio/mp3splt/files/patch-splt.h b/audio/mp3splt/files/patch-splt.h
deleted file mode 100644
index 839a74b2cc0d..000000000000
--- a/audio/mp3splt/files/patch-splt.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- splt.h.orig Fri Dec 15 19:27:18 2006
-+++ splt.h Fri Dec 15 19:27:40 2006
-@@ -93,7 +93,7 @@
-
- char *zero_pad_float (float f, char *out);
-
--int parse_outformat(char *s, char format[][], int cddboption);
-+int parse_outformat(char *s, char format[OUTNUM][MAXOLEN], int cddboption);
-
- unsigned char *cleanstring (unsigned char *s);
-