aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3stat/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-21 14:59:48 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-21 14:59:48 +0000
commit6d50e1c211306bbb467282780477b95eb35e4501 (patch)
treedf567ab75c8a4589a76425a324fbedb0281a6d04 /audio/mp3stat/Makefile
parent50303bec47795d3ab3922d4366b3a934f2156b6b (diff)
downloadports-6d50e1c211306bbb467282780477b95eb35e4501.tar.gz
ports-6d50e1c211306bbb467282780477b95eb35e4501.zip
Notes
Diffstat (limited to 'audio/mp3stat/Makefile')
-rw-r--r--audio/mp3stat/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
new file mode 100644
index 000000000000..41f00b7deab2
--- /dev/null
+++ b/audio/mp3stat/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: mp3stat
+# Date created: Mar 20, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3stat
+PORTVERSION= 2.5.2
+CATEGORIES= audio
+MASTER_SITES= http://safemode.homeip.net/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GTK= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,glib-config,${GLIB_CONFIG},g ; \
+ s,gtk-config,${GTK_CONFIG},g ; \
+ s,^CXXFLAGS *=,CXXFLAGS+=,g" ${WRKSRC}/Makefile
+# current vorbis support is broken, dont know how to fix
+ @${PERL} -pi -e "s,^VORBIS,#VORBIS,g" ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>