aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3stat/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 11:44:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-25 11:44:20 +0000
commitaa507797043485de15c086094e6b6024fa1c4951 (patch)
tree638de532b91e31a283fa0aa5cbf608ca9a6b3627 /audio/mp3stat/Makefile
parent16527b277e90c9a79ed29d20856f61f87e3fd079 (diff)
downloadports-aa507797043485de15c086094e6b6024fa1c4951.tar.gz
ports-aa507797043485de15c086094e6b6024fa1c4951.zip
Notes
Diffstat (limited to 'audio/mp3stat/Makefile')
-rw-r--r--audio/mp3stat/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
index 5d97054dee18..aa8e1d3350c4 100644
--- a/audio/mp3stat/Makefile
+++ b/audio/mp3stat/Makefile
@@ -14,16 +14,22 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-USE_GTK= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-CFLAGS+= -I${LOCALBASE}/include
+
+USE_GTK= yes
USE_GMAKE= yes
+MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
+
+.if defined(WITH_VORBIS)
+LIB_DEPENDS= vorbis.1:${PORTSDIR}/audio/libvorbis
+MAKE_ENV+= WITH_VORBIS="${WITH_VORBIS}"
+.endif
-post-patch:
- @${PERL} -pi -e "s,glib-config,${GLIB_CONFIG},g ; \
- s,gtk-config,${GTK_CONFIG},g ; \
- s,^CXXFLAGS *=,CXXFLAGS+=,g" ${WRKSRC}/Makefile
-# current vorbis support is broken, dont know how to fix
- @${PERL} -pi -e "s,^VORBIS,#VORBIS,g" ${WRKSRC}/Makefile
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} "If you want to compile with Ogg/Vorbis support,"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_VORBIS=yes\""
+ @${ECHO_MSG}
+.endif
.include <bsd.port.mk>