aboutsummaryrefslogtreecommitdiff
path: root/audio/mpc
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-25 19:21:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-25 19:21:20 +0000
commitab59082c5351d52149f46bbe7eead7cc9aecec5c (patch)
tree9ff1a5956f19fa5347e10c03c0d537789f84bac2 /audio/mpc
parent525c756eb45c9aa46719720372840ca2db2f9085 (diff)
downloadports-ab59082c5351d52149f46bbe7eead7cc9aecec5c.tar.gz
ports-ab59082c5351d52149f46bbe7eead7cc9aecec5c.zip
Notes
Diffstat (limited to 'audio/mpc')
-rw-r--r--audio/mpc/Makefile2
-rw-r--r--audio/mpc/distinfo4
-rw-r--r--audio/mpc/files/patch-src-command.c64
3 files changed, 3 insertions, 67 deletions
diff --git a/audio/mpc/Makefile b/audio/mpc/Makefile
index f0f0155f409f..5d7b08519b55 100644
--- a/audio/mpc/Makefile
+++ b/audio/mpc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mpc
-PORTVERSION= 0.10.0
+PORTVERSION= 0.10.2
CATEGORIES= audio ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= musicpd
diff --git a/audio/mpc/distinfo b/audio/mpc/distinfo
index 304881173d59..4682ab483ead 100644
--- a/audio/mpc/distinfo
+++ b/audio/mpc/distinfo
@@ -1,2 +1,2 @@
-MD5 (mpc-0.10.0.tar.gz) = 59e9d1af5644140857132e6b9ebad57e
-SIZE (mpc-0.10.0.tar.gz) = 212562
+MD5 (mpc-0.10.2.tar.gz) = 3ca8b537d164897a376fd1abcd5514d1
+SIZE (mpc-0.10.2.tar.gz) = 209538
diff --git a/audio/mpc/files/patch-src-command.c b/audio/mpc/files/patch-src-command.c
deleted file mode 100644
index ab747925c623..000000000000
--- a/audio/mpc/files/patch-src-command.c
+++ /dev/null
@@ -1,64 +0,0 @@
---- src/command.c Wed Mar 3 19:05:02 2004
-+++ src/command.c Wed Mar 3 19:05:47 2004
-@@ -243,16 +243,23 @@
- int cmd_seek ( int argc, char ** argv, mpd_Connection * conn )
- {
- mpd_Status * status = mpd_getStatus(conn);
-+ char * arg = argv[0];
-+ int seekmode;
-+ char * test;
-+ int seekchange;
-+ char * last_char;
-+ int sec;
-+ float perc;
-+ int seekto;
-+
- my_finishCommand(conn);
- if(status->state==MPD_STATUS_STATE_STOP)
- DIE("not currently playing\n");
-
-- char * arg = argv[0];
--
- if(!strlen(arg))
- DIE("\"%s\" is not a positive number\n", arg);
-
-- int seekmode = Absolute;
-+ seekmode = Absolute;
-
- if(arg[0] == '+') {
- seekmode = RelForward;
-@@ -262,15 +269,13 @@
- arg++;
- }
-
-- char * test;
-- int seekchange;
-
-- char * last_char = &arg[strlen(arg)-1];
-+ last_char = &arg[strlen(arg)-1];
- if(*last_char == 's') {
- /* absolute seek (in seconds) */
-
- *last_char = '\0'; /* chop off the s */
-- int sec = strtol(arg,&test,10); /* get the # of seconds */
-+ sec = strtol(arg,&test,10); /* get the # of seconds */
-
- if(*test!='\0' || sec<0)
- DIE("\"%s\" is not a positive number\n", arg);
-@@ -280,14 +285,14 @@
- } else {
- /* percent seek */
-
-- float perc = strtod(arg,&test);
-+ perc = strtod(arg,&test);
- if(*test!='\0' || perc<0 || perc>100)
- DIE("\"%s\" is not an number between 0 and 100\n",arg);
-
- seekchange = perc*status->totalTime/100+0.5;
- }
-
-- int seekto = calculate_seek(status->elapsedTime, seekchange, seekmode);
-+ seekto = calculate_seek(status->elapsedTime, seekchange, seekmode);
-
- if(seekto > status->totalTime)
- DIE("seek amount would seek past the end of the song\n");