aboutsummaryrefslogtreecommitdiff
path: root/audio/mpdas
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:37:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-15 21:37:56 +0000
commite44760de7c9dd0e26a62e23701e472178d8417ad (patch)
tree63a04378d88acb3f26f8dafab4cf791c38117ce0 /audio/mpdas
parent28ec452966257369892a20bc3d9485da6393856b (diff)
downloadports-e44760de7c9dd0e26a62e23701e472178d8417ad.tar.gz
ports-e44760de7c9dd0e26a62e23701e472178d8417ad.zip
Notes
Diffstat (limited to 'audio/mpdas')
-rw-r--r--audio/mpdas/Makefile24
-rw-r--r--audio/mpdas/distinfo3
-rw-r--r--audio/mpdas/pkg-descr10
3 files changed, 37 insertions, 0 deletions
diff --git a/audio/mpdas/Makefile b/audio/mpdas/Makefile
new file mode 100644
index 000000000000..3164696c16a1
--- /dev/null
+++ b/audio/mpdas/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: mpdas
+# Date created: Nov 11, 2008
+# Whom: hrkfrd@googlemail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpdas
+PORTVERSION= 0.2.1
+CATEGORIES= audio
+MASTER_SITES= http://50hz.ws/mpdas/
+
+MAINTAINER= hrkfrd@googlemail.com
+COMMENT= MPD AudioScrobbler written in C++ supporting the latest protocol
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ mpd:${PORTSDIR}/audio/libmpd
+
+USE_GNOME= pkgconfig
+USE_BZIP2= yes
+
+PLIST_FILES= bin/mpdas
+
+.include <bsd.port.mk>
diff --git a/audio/mpdas/distinfo b/audio/mpdas/distinfo
new file mode 100644
index 000000000000..bb3330cdfbef
--- /dev/null
+++ b/audio/mpdas/distinfo
@@ -0,0 +1,3 @@
+MD5 (mpdas-0.2.1.tar.bz2) = c8f981b46a22bf44d8e38a339f102d89
+SHA256 (mpdas-0.2.1.tar.bz2) = b95ffd2380eb345b8f263c56d95780091095d5feb47ed7b622275229bb905e1d
+SIZE (mpdas-0.2.1.tar.bz2) = 11253
diff --git a/audio/mpdas/pkg-descr b/audio/mpdas/pkg-descr
new file mode 100644
index 000000000000..7005407ed41c
--- /dev/null
+++ b/audio/mpdas/pkg-descr
@@ -0,0 +1,10 @@
+mpdas is an AudioScrobbler client for MPD written in C++.
+It uses libcurl and libmpd.
+It supports the latest AudioScrobbler protocol (1.21).
+In case of a downtime or connectivity problems,
+mpdas will cache the played songs to ~/.mpdascache.
+
+Please read the README at:
+http://github.com/hrkfrd/mpdas/tree/master/README
+
+WWW: http://50hz.ws/mpdas/