aboutsummaryrefslogtreecommitdiff
path: root/audio/mpdscribble
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-08-19 13:29:59 +0000
commitbb271f0bf7b513a23a31da4ec8819b113ebf4587 (patch)
treeac5a462edc3d85d5f0b20a594802ce4b12f0bf9f /audio/mpdscribble
parent29879aded766da253313579a3503ff5e15026355 (diff)
downloadports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.tar.gz
ports-bb271f0bf7b513a23a31da4ec8819b113ebf4587.zip
Notes
Diffstat (limited to 'audio/mpdscribble')
-rw-r--r--audio/mpdscribble/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/audio/mpdscribble/Makefile b/audio/mpdscribble/Makefile
index 8931e9e5add7..3441c55854fd 100644
--- a/audio/mpdscribble/Makefile
+++ b/audio/mpdscribble/Makefile
@@ -23,25 +23,19 @@ USE_RC_SUBR= mpdscribble
OPTIONS_DEFINE= SOUP DOCS
SOUP_DESC= Use libsoup instead of libcurl
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSOUP}
-LIB_DEPENDS+= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
-CONFIGURE_ARGS+= --with-http-client=soup
-.else
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --with-http-client=curl
-.endif
+SOUP_LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup
+SOUP_CONFIGURE_ON= --with-http-client=soup
+SOUP_LIB_DEPENDS_OFF= libcurl.so:${PORTSDIR}/ftp/curl
+SOUP_CONFIGURE_OFF= --with-http-client=curl
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/mpdscribble ${STAGEDIR}${PREFIX}/bin/mpdscribble
${INSTALL_MAN} ${WRKSRC}/doc/mpdscribble.1 ${STAGEDIR}${MANPREFIX}/man/man1/mpdscribble.1
${INSTALL_DATA} ${WRKSRC}/doc/mpdscribble.conf ${STAGEDIR}${PREFIX}/etc/mpdscribble.conf.sample
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS NEWS README
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>