aboutsummaryrefslogtreecommitdiff
path: root/audio/mpeglib_artsplug
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-08-11 01:27:37 +0000
commit461f3c5adb635525af6de102321df3e6288bfb1c (patch)
tree2025e3327a038c580b6f13bdc201e220e2077bb4 /audio/mpeglib_artsplug
parent5036b1c6d43d4a6652f933702bfcc8b3553fddfd (diff)
Notes
Diffstat (limited to 'audio/mpeglib_artsplug')
-rw-r--r--audio/mpeglib_artsplug/Makefile39
-rw-r--r--audio/mpeglib_artsplug/distinfo2
-rw-r--r--audio/mpeglib_artsplug/files/patch-mpeglib_lib_util_render_dither2YUV_rgb2yuvdefs.h12
-rw-r--r--audio/mpeglib_artsplug/files/patch-mpeglibartsplay.cpp16
-rw-r--r--audio/mpeglib_artsplug/files/patch-mpg_control.cpp24
-rw-r--r--audio/mpeglib_artsplug/files/patch-splay_control.cpp16
-rw-r--r--audio/mpeglib_artsplug/files/patch-tplay_control.cpp16
-rw-r--r--audio/mpeglib_artsplug/files/patch-vorbis_control.cpp16
-rw-r--r--audio/mpeglib_artsplug/files/patch-yuv_control.cpp16
-rw-r--r--audio/mpeglib_artsplug/pkg-descr1
-rw-r--r--audio/mpeglib_artsplug/pkg-plist125
11 files changed, 283 insertions, 0 deletions
diff --git a/audio/mpeglib_artsplug/Makefile b/audio/mpeglib_artsplug/Makefile
new file mode 100644
index 000000000000..68d280142523
--- /dev/null
+++ b/audio/mpeglib_artsplug/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mpeglib_artsplug
+# Date created: July 09 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpeglib_artsplug
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= audio kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
+PKGNAMEPREFIX= kdemultimedia-
+DISTNAME= kdemultimedia-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Default KDE decoders for mp3/ogg
+
+LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+CONFLICTS= kdemultimedia-3.1.* kdemultimedia-3.2.[0-3]
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/kdemultimedia-${PORTVERSION}
+INSTALLS_SHLIB= yes
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ ${ECHO_CMD} "mpeglib mpeglib_artsplug" > ${WRKSRC}/inst-apps
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.mk>
diff --git a/audio/mpeglib_artsplug/distinfo b/audio/mpeglib_artsplug/distinfo
new file mode 100644
index 000000000000..95e28daa1852
--- /dev/null
+++ b/audio/mpeglib_artsplug/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdemultimedia-3.2.3.tar.bz2) = f49a1cf9c5d405aed791808b4bbf035d
+SIZE (KDE/kdemultimedia-3.2.3.tar.bz2) = 4847891
diff --git a/audio/mpeglib_artsplug/files/patch-mpeglib_lib_util_render_dither2YUV_rgb2yuvdefs.h b/audio/mpeglib_artsplug/files/patch-mpeglib_lib_util_render_dither2YUV_rgb2yuvdefs.h
new file mode 100644
index 000000000000..3f7b25f2b643
--- /dev/null
+++ b/audio/mpeglib_artsplug/files/patch-mpeglib_lib_util_render_dither2YUV_rgb2yuvdefs.h
@@ -0,0 +1,12 @@
+--- mpeglib/lib/util/render/dither2YUV/rgb2yuvdefs.h.orig Tue Sep 2 07:04:27 2003
++++ mpeglib/lib/util/render/dither2YUV/rgb2yuvdefs.h Wed Aug 4 12:48:40 2004
+@@ -20,6 +20,9 @@
+
+ /* gcc 3.3.1 and later optimise the "not used" (only in asm code)
+ symbols away. So we need to mark them as used. */
++#if defined(__GNUC_PREREQ__) && !defined(__GNUC_PREREQ)
++#define __GNUC_PREREQ __GNUC_PREREQ__
++#endif
+ #ifdef __GNUC_PREREQ
+ #if __GNUC_PREREQ (3,1)
+ # define __attribute_used__ __attribute__ ((__used__)) \ No newline at end of file
diff --git a/audio/mpeglib_artsplug/files/patch-mpeglibartsplay.cpp b/audio/mpeglib_artsplug/files/patch-mpeglibartsplay.cpp
new file mode 100644
index 000000000000..955c1e52bd1e
--- /dev/null
+++ b/audio/mpeglib_artsplug/files/patch-mpeglibartsplay.cpp
@@ -0,0 +1,16 @@
+Index: mpeglib_artsplug/mpeglibartsplay.cpp
+===================================================================
+RCS file: /home/kde/kdemultimedia/mpeglib_artsplug/mpeglibartsplay.cpp,v
+retrieving revision 1.13
+diff -u -3 -p -r1.13 mpeglibartsplay.cpp
+--- mpeglib_artsplug/mpeglibartsplay.cpp 2002/06/15 00:17:11 1.13
++++ mpeglib_artsplug/mpeglibartsplay.cpp 2002/11/28 10:09:03
+@@ -26,7 +26,7 @@
+
+ using namespace std;
+
+-#if defined(HAVE_GETOPT_H)
++#if defined(HAVE_GETOPT_H) && !defined(__FreeBSD__)
+ #include <getopt.h>
+ #endif
+
diff --git a/audio/mpeglib_artsplug/files/patch-mpg_control.cpp b/audio/mpeglib_artsplug/files/patch-mpg_control.cpp
new file mode 100644
index 000000000000..4e6dd1307a11
--- /dev/null
+++ b/audio/mpeglib_artsplug/files/patch-mpg_control.cpp
@@ -0,0 +1,24 @@
+Index: mpeglib/example/yaf/yafmpgplay/mpg_control.cpp
+===================================================================
+RCS file: /home/kde/kdemultimedia/mpeglib/example/yaf/yafmpgplay/mpg_control.cpp,v
+retrieving revision 1.5
+diff -u -3 -p -r1.5 mpg_control.cpp
+--- mpeglib/example/yaf/yafmpgplay/mpg_control.cpp 2002/11/22 21:52:53 1.5
++++ mpeglib/example/yaf/yafmpgplay/mpg_control.cpp 2002/11/28 08:54:03
+@@ -29,14 +29,14 @@ using namespace std;
+ #include <stdlib.h>
+ #include <math.h>
+
+-#if defined(HAVE_GETOPT_H)
++#if defined(HAVE_GETOPT_H) && !defined(__FreeBSD__)
+ #include <getopt.h>
+ #endif
+
+ // we include our plugin here
+ #include "../../../lib/decoder/mpgPlugin.h"
+
+-#if defined(HAVE_GETOPT_H)
++#if defined(HAVE_GETOPT_H) && !defined(__FreeBSD__)
+ #include <getopt.h>
+ #endif
+
diff --git a/audio/mpeglib_artsplug/files/patch-splay_control.cpp b/audio/mpeglib_artsplug/files/patch-splay_control.cpp
new file mode 100644
index 000000000000..380957b19d3c
--- /dev/null
+++ b/audio/mpeglib_artsplug/files/patch-splay_control.cpp
@@ -0,0 +1,16 @@
+Index: mpeglib/example/yaf/yafsplay/splay_control.cpp
+===================================================================
+RCS file: /home/kde/kdemultimedia/mpeglib/example/yaf/yafsplay/splay_control.cpp,v
+retrieving revision 1.6
+diff -u -3 -p -r1.6 splay_control.cpp
+--- mpeglib/example/yaf/yafsplay/splay_control.cpp 2002/11/22 21:52:54 1.6
++++ mpeglib/example/yaf/yafsplay/splay_control.cpp 2002/11/28 08:51:50
+@@ -28,7 +28,7 @@ using namespace std;
+ // we include our plugin here
+ #include "../../../lib/decoder/splayPlugin.h"
+
+-#if defined(HAVE_GETOPT_H)
++#if defined(HAVE_GETOPT_H) && !defined(__FreeBSD__)
+ #include <getopt.h>
+ #endif
+
diff --git a/audio/mpeglib_artsplug/files/patch-tplay_control.cpp b/audio/mpeglib_artsplug/files/patch-tplay_control.cpp
new file mode 100644
index 000000000000..4ea68a80a8c7
--- /dev/null
+++ b/audio/mpeglib_artsplug/files/patch-tplay_control.cpp
@@ -0,0 +1,16 @@
+Index: mpeglib/example/yaf/yaftplay/tplay_control.cpp
+===================================================================
+RCS file: /home/kde/kdemultimedia/mpeglib/example/yaf/yaftplay/tplay_control.cpp,v
+retrieving revision 1.3
+diff -u -3 -p -r1.3 tplay_control.cpp
+--- mpeglib/example/yaf/yaftplay/tplay_control.cpp 2002/11/22 21:52:54 1.3
++++ mpeglib/example/yaf/yaftplay/tplay_control.cpp 2002/11/28 08:55:41
+@@ -29,7 +29,7 @@ using namespace std;
+ #include "../../../lib/decoder/tplayPlugin.h"
+
+
+-#if defined(HAVE_GETOPT_H)
++#if defined(HAVE_GETOPT_H) && !defined(__FreeBSD__)
+ #include <getopt.h>
+ #endif
+
diff --git a/audio/mpeglib_artsplug/files/patch-vorbis_control.cpp b/audio/mpeglib_artsplug/files/patch-vorbis_control.cpp
new file mode 100644
index 000000000000..e0f00a745105
--- /dev/null
+++ b/audio/mpeglib_artsplug/files/patch-vorbis_control.cpp
@@ -0,0 +1,16 @@
+Index: mpeglib/example/yaf/yafvorbis/vorbis_control.cpp
+===================================================================
+RCS file: /home/kde/kdemultimedia/mpeglib/example/yaf/yafvorbis/vorbis_control.cpp,v
+retrieving revision 1.3
+diff -u -3 -p -r1.3 vorbis_control.cpp
+--- mpeglib/example/yaf/yafvorbis/vorbis_control.cpp 2000/12/03 22:05:05 1.3
++++ mpeglib/example/yaf/yafvorbis/vorbis_control.cpp 2002/11/28 08:56:38
+@@ -29,7 +29,7 @@
+
+ #include "../../../lib/decoder/vorbisPlugin.h"
+
+-#if defined(HAVE_GETOPT_H)
++#if defined(HAVE_GETOPT_H) && !defined(__FreeBSD__)
+ #include <getopt.h>
+ #endif
+
diff --git a/audio/mpeglib_artsplug/files/patch-yuv_control.cpp b/audio/mpeglib_artsplug/files/patch-yuv_control.cpp
new file mode 100644
index 000000000000..e6117c0252d7
--- /dev/null
+++ b/audio/mpeglib_artsplug/files/patch-yuv_control.cpp
@@ -0,0 +1,16 @@
+Index: mpeglib/example/yaf/yafyuv/yuv_control.cpp
+===================================================================
+RCS file: /home/kde/kdemultimedia/mpeglib/example/yaf/yafyuv/yuv_control.cpp,v
+retrieving revision 1.3
+diff -u -3 -p -r1.3 yuv_control.cpp
+--- mpeglib/example/yaf/yafyuv/yuv_control.cpp 2002/11/22 21:52:54 1.3
++++ mpeglib/example/yaf/yafyuv/yuv_control.cpp 2002/11/28 08:58:03
+@@ -28,7 +28,7 @@ using namespace std;
+ // we include our plugin here
+ #include "../../../lib/yuv/yuvPlugin.h"
+
+-#if defined(HAVE_GETOPT_H)
++#if defined(HAVE_GETOPT_H) && !defined(__FreeBSD__)
+ #include <getopt.h>
+ #endif
+
diff --git a/audio/mpeglib_artsplug/pkg-descr b/audio/mpeglib_artsplug/pkg-descr
new file mode 100644
index 000000000000..be1ed9204434
--- /dev/null
+++ b/audio/mpeglib_artsplug/pkg-descr
@@ -0,0 +1 @@
+IO slaves for various types of sound data, with streaming support.
diff --git a/audio/mpeglib_artsplug/pkg-plist b/audio/mpeglib_artsplug/pkg-plist
new file mode 100644
index 000000000000..b327677fdf72
--- /dev/null
+++ b/audio/mpeglib_artsplug/pkg-plist
@@ -0,0 +1,125 @@
+bin/mpeglibartsplay
+bin/yaf-cdda
+bin/yaf-mpgplay
+bin/yaf-splay
+bin/yaf-tplay
+bin/yaf-vorbis
+bin/yaf-yuv
+include/mpeglib/decoder/cddaPlugin.h
+include/mpeglib/decoder/command.h
+include/mpeglib/decoder/commandPipe.h
+include/mpeglib/decoder/decoderPlugin.h
+include/mpeglib/decoder/mpegPlugin.h
+include/mpeglib/decoder/mpgPlugin.h
+include/mpeglib/decoder/nukePlugin.h
+include/mpeglib/decoder/splayPlugin.h
+include/mpeglib/decoder/tplayPlugin.h
+include/mpeglib/decoder/vorbisPlugin.h
+include/mpeglib/decoder/yuvPlugin.h
+include/mpeglib/frame/IOFrameQueue.h
+include/mpeglib/frame/audioFrame.h
+include/mpeglib/frame/audioFrameQueue.h
+include/mpeglib/frame/floatFrame.h
+include/mpeglib/frame/frame.h
+include/mpeglib/frame/frameQueue.h
+include/mpeglib/frame/framer.h
+include/mpeglib/frame/pcmFrame.h
+include/mpeglib/frame/rawDataBuffer.h
+include/mpeglib/frame/rawFrame.h
+include/mpeglib/input/bufferInputStream.h
+include/mpeglib/input/cddaInputStream.h
+include/mpeglib/input/cdromInputStream.h
+include/mpeglib/input/fileInputStream.h
+include/mpeglib/input/httpInputStream.h
+include/mpeglib/input/inputDetector.h
+include/mpeglib/input/inputPlugin.h
+include/mpeglib/input/inputStream.h
+include/mpeglib/input/threadSafeInputStream.h
+include/mpeglib/mpegutil/mpegStreamPlayer.h
+include/mpeglib/mpegutil/mpegSystemHeader.h
+include/mpeglib/mpegutil/mpegSystemStream.h
+include/mpeglib/mpegutil/mpegVideoLength.h
+include/mpeglib/mpegutil/pesSystemStream.h
+include/mpeglib/mpegutil/psSystemStream.h
+include/mpeglib/mpegutil/tsSystemStream.h
+include/mpeglib/oggvorbis/oggFrame.h
+include/mpeglib/oggvorbis/ovFramer.h
+include/mpeglib/oggvorbis/vorbisDecoder.h
+include/mpeglib/oggvorbis/vorbisInfo.h
+include/mpeglib/output/artsOutputStream.h
+include/mpeglib/output/audioTime.h
+include/mpeglib/output/avSyncer.h
+include/mpeglib/output/dspX11OutputStream.h
+include/mpeglib/output/outPlugin.h
+include/mpeglib/output/outputStream.h
+include/mpeglib/output/pluginInfo.h
+include/mpeglib/output/threadSafeOutputStream.h
+include/mpeglib/splay/mpegAudioFrame.h
+include/mpeglib/splay/mpegAudioInfo.h
+include/mpeglib/splay/splayDecoder.h
+include/mpeglib/util/abstract/abs_thread.h
+include/mpeglib/util/abstract/threadQueue.h
+include/mpeglib/util/dynBuffer.h
+include/mpeglib/util/file/fileAccess.h
+include/mpeglib/util/mmx/mm_accel.h
+include/mpeglib/util/mmx/mmx.h
+include/mpeglib/util/mmx/mmx_asm.h
+include/mpeglib/util/render/pictureArray.h
+include/mpeglib/util/render/yuvPicture.h
+include/mpeglib/util/syncClock.h
+include/mpeglib/util/timeStamp.h
+include/mpeglib/util/timeStampArray.h
+include/mpeglib/util/timeWrapper.h
+include/mpeglib/util/yaf/yafcore/buffer.h
+include/mpeglib/util/yaf/yafcore/inputDecoder.h
+include/mpeglib/util/yaf/yafcore/inputInterface.h
+include/mpeglib/util/yaf/yafcore/outputInterface.h
+include/mpeglib/util/yaf/yafcore/yaf_control.h
+include/mpeglib/util/yaf/yafxplayer/inputDecoderXPlayer.h
+include/mpeglib/util/yaf/yafxplayer/inputDecoderYAF.h
+include/mpeglib/util/yaf/yafxplayer/yafOutputStream.h
+include/mpeglib_artsplug/decoderBaseObject.h
+include/mpeglib_artsplug/decoderBaseObject.idl
+include/mpeglib_artsplug/decoderBaseObject_impl.h
+include/mpeglib_artsplug/splayPlayObject.h
+include/mpeglib_artsplug/splayPlayObject.idl
+include/mpeglib_artsplug/splayPlayObject_impl.h
+lib/libarts_mpeglib-0.3.0.so
+lib/libarts_mpeglib-0.3.0.so.0
+lib/libarts_mpeglib.la
+lib/libarts_mpeglib.so
+lib/libarts_splay.la
+lib/libarts_splay.so
+lib/libarts_splay.so.0
+lib/libmpeg-0.3.0.so
+lib/libmpeg.la
+lib/libmpeg.so
+lib/libyafcore.la
+lib/libyafcore.so
+lib/libyafcore.so.0
+lib/libyafxplayer.la
+lib/libyafxplayer.so
+lib/libyafxplayer.so.0
+lib/mcop/CDDAPlayObject.mcopclass
+lib/mcop/MP3PlayObject.mcopclass
+lib/mcop/NULLPlayObject.mcopclass
+lib/mcop/OGGPlayObject.mcopclass
+lib/mcop/SplayPlayObject.mcopclass
+lib/mcop/WAVPlayObject.mcopclass
+@dirrm include/mpeglib_artsplug
+@dirrm include/mpeglib/util/yaf/yafxplayer
+@dirrm include/mpeglib/util/yaf/yafcore
+@dirrm include/mpeglib/util/yaf
+@dirrm include/mpeglib/util/render
+@dirrm include/mpeglib/util/mmx
+@dirrm include/mpeglib/util/file
+@dirrm include/mpeglib/util/abstract
+@dirrm include/mpeglib/util
+@dirrm include/mpeglib/splay
+@dirrm include/mpeglib/output
+@dirrm include/mpeglib/oggvorbis
+@dirrm include/mpeglib/mpegutil
+@dirrm include/mpeglib/input
+@dirrm include/mpeglib/frame
+@dirrm include/mpeglib/decoder
+@dirrm include/mpeglib