aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg321/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2006-02-19 20:46:56 +0000
committerPeter Pentchev <roam@FreeBSD.org>2006-02-19 20:46:56 +0000
commiteca41c3e6b6878a74dd39f0f0041c47e2de65cb0 (patch)
treeae66c515a2762be22320f37e0073050c00529539 /audio/mpg321/Makefile
parentda6c0bba31323218627e6e290a24b1615351fe93 (diff)
Notes
Diffstat (limited to 'audio/mpg321/Makefile')
-rw-r--r--audio/mpg321/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index 656c5324e8ae..c5e1a7bd3e38 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -19,6 +19,18 @@ LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
id3tag.0:${PORTSDIR}/audio/libid3tag \
mad.2:${PORTSDIR}/audio/libmad
+.if defined(WITH_MPG321_SCROBBLER_PATCH)
+RUN_DEPENDS= scrobbler-helper:${PORTSDIR}/audio/p5-Audio-Scrobbler
+
+PATCHFILES+= mpg321-0.2.10-scrobbler-01.patch:scrobbler
+PATCH_SITES+= http://people.FreeBSD.org/~roam/ports/audio/:scrobbler \
+ http://devel.ringlet.net/audio/mpg321-scrobbler/:scrobbler
+
+USE_REINPLACE= true
+
+MPG321_SCROBBLER_PLUGIN_NAME?= 321
+.endif
+
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-mpg123-symlink
@@ -29,4 +41,9 @@ MAN1= mpg321.1
PLIST_FILES= bin/mpg321
+.if defined(WITH_MPG321_SCROBBLER_PATCH)
+post-patch:
+ ${REINPLACE_CMD} "s/\"mpg321\"/\"${MPG321_SCROBBLER_PLUGIN_NAME}\"/" ${WRKSRC}/scrobbler.c
+.endif
+
.include <bsd.port.mk>