aboutsummaryrefslogtreecommitdiff
path: root/audio/mpg321
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2010-06-06 20:39:21 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2010-06-06 20:39:21 +0000
commitf613ac049d40272c3b27a76dbab7f6723f2a2ba2 (patch)
treee62b67c39f729f55f17b68f6438f9f1beeadd10c /audio/mpg321
parent2f2aafd9bf4a01f681da4598e18663001e4a9406 (diff)
Notes
Diffstat (limited to 'audio/mpg321')
-rw-r--r--audio/mpg321/Makefile4
-rw-r--r--audio/mpg321/files/patch-ao.c13
2 files changed, 15 insertions, 2 deletions
diff --git a/audio/mpg321/Makefile b/audio/mpg321/Makefile
index 5af3d7da85ab..f8a1e70f04da 100644
--- a/audio/mpg321/Makefile
+++ b/audio/mpg321/Makefile
@@ -7,14 +7,14 @@
PORTNAME= mpg321
PORTVERSION= 0.2.10
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= SF
MAINTAINER= naddy@FreeBSD.org
COMMENT= A free command-line mp3 player, compatible with mpg123
-LIB_DEPENDS= ao.3:${PORTSDIR}/audio/libao \
+LIB_DEPENDS= ao.4:${PORTSDIR}/audio/libao \
id3tag.0:${PORTSDIR}/audio/libid3tag \
mad.2:${PORTSDIR}/audio/libmad
diff --git a/audio/mpg321/files/patch-ao.c b/audio/mpg321/files/patch-ao.c
new file mode 100644
index 000000000000..9691820d0e17
--- /dev/null
+++ b/audio/mpg321/files/patch-ao.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- ao.c.orig
++++ ao.c
+@@ -229,6 +229,7 @@
+ and restore it afterwards */
+ signal(SIGINT, SIG_DFL);
+
++ memset(&format, 0, sizeof(format));
+ format.bits = 16;
+ format.rate = header->samplerate;
+ format.channels = (options.opt & MPG321_FORCE_STEREO) ? 2 : MAD_NCHANNELS(header);