aboutsummaryrefslogtreecommitdiff
path: root/audio/mpiosh
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-07 14:14:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-07 14:14:21 +0000
commit79487704b891acba2cde2e58f90694d2f6196c38 (patch)
tree8030215737c9a04aaff044435118d4005a7c27d5 /audio/mpiosh
parentb52bb3312bcc594c8031e42692723cbd85239735 (diff)
downloadports-79487704b891acba2cde2e58f90694d2f6196c38.tar.gz
ports-79487704b891acba2cde2e58f90694d2f6196c38.zip
Notes
Diffstat (limited to 'audio/mpiosh')
-rw-r--r--audio/mpiosh/Makefile37
-rw-r--r--audio/mpiosh/distinfo1
-rw-r--r--audio/mpiosh/files/patch-Makefile.in11
-rw-r--r--audio/mpiosh/files/patch-configure37
-rw-r--r--audio/mpiosh/files/patch-libmpio-debug.h11
-rw-r--r--audio/mpiosh/files/patch-libmpio-defs.h11
-rw-r--r--audio/mpiosh/files/patch-mpiosh-Makefile.in11
-rw-r--r--audio/mpiosh/files/patch-mpiosh-callback.c17
-rw-r--r--audio/mpiosh/files/patch-mpiosh-mpiosh.c21
-rw-r--r--audio/mpiosh/files/patch-mpiosh-readline.c11
-rw-r--r--audio/mpiosh/files/patch-tools-Makefile.in11
-rw-r--r--audio/mpiosh/pkg-descr9
-rw-r--r--audio/mpiosh/pkg-plist11
13 files changed, 199 insertions, 0 deletions
diff --git a/audio/mpiosh/Makefile b/audio/mpiosh/Makefile
new file mode 100644
index 000000000000..20726079b5db
--- /dev/null
+++ b/audio/mpiosh/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mpio-driver
+# Date created: 19 Jun 2003
+# Whom: Sergey Akifyev <asa@gascom.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpiosh
+PORTVERSION= 0.7.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mpio
+DISTNAME= mpio-${PORTVERSION}
+
+MAINTAINER= asa@gascom.ru
+COMMENT= Digit@lway MPIO MP3 player tool
+
+RUN_DEPENDS= ${MODULES}/mpio.ko:${PORTSDIR}/audio/mpio-driver
+LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
+
+MODULES?= /modules
+
+USE_LIBTOOL= yes
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_TARGET=
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500000
+IGNORE= This port only works for FreeBSD 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/mpiosh/distinfo b/audio/mpiosh/distinfo
new file mode 100644
index 000000000000..ecb46ecbb647
--- /dev/null
+++ b/audio/mpiosh/distinfo
@@ -0,0 +1 @@
+MD5 (mpio-0.7.0.tar.gz) = 09790dd74be6d9dcfffe7090713a7387
diff --git a/audio/mpiosh/files/patch-Makefile.in b/audio/mpiosh/files/patch-Makefile.in
new file mode 100644
index 000000000000..71948adfe65c
--- /dev/null
+++ b/audio/mpiosh/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Dec 7 14:52:24 2003
++++ Makefile.in Sun Dec 7 14:54:36 2003
+@@ -93,7 +93,7 @@
+ am__include = @am__include@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+-SUBDIRS = kernel libmpio mpiosh etc tools
++SUBDIRS = libmpio mpiosh etc tools
+
+ sbin_SCRIPTS = mkmpiodev
+ EXTRA_DIST = mpio.spec mkmpiodev
diff --git a/audio/mpiosh/files/patch-configure b/audio/mpiosh/files/patch-configure
new file mode 100644
index 000000000000..43289a349eb9
--- /dev/null
+++ b/audio/mpiosh/files/patch-configure
@@ -0,0 +1,37 @@
+--- configure.orig Sun Dec 7 15:00:37 2003
++++ configure Sun Dec 7 15:03:44 2003
+@@ -7797,6 +7797,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -8118,26 +8118,6 @@
+
+
+ KERNEL_INCLUDE=
+-if test -d "/lib/modules/${kernel_version}/build/include"; then
+- KERNEL_INCLUDE="/lib/modules/${kernel_version}/build/include"
+-elif test -d "/usr/src/linux-2.4/include"; then
+- KERNEL_INCLUDE="/usr/src/linux-2.4/include"
+-elif test -d "/usr/include/linux"; then
+- KERNEL_INCLUDE="/usr/include/linux"
+-elif test -d "/usr/src/linux/include"; then
+- KERNEL_INCLUDE="/usr/src/linux/include"
+-fi
+-
+-if test -z ${KERNEL_INCLUDE}; then
+- { { echo "$as_me:$LINENO: error: could not find directory of kernel include files" >&5
+-echo "$as_me: error: could not find directory of kernel include files" >&2;}
+- { (exit 1); exit 1; }; }
+-else
+- echo "$as_me:$LINENO: result: Using kernel includes from ${KERNEL_INCLUDE}" >&5
+-echo "${ECHO_T}Using kernel includes from ${KERNEL_INCLUDE}" >&6
+-fi
+-
+-
+
+ # could not find a way to compile the kernel module correctly
+ # kernel/Makefile
diff --git a/audio/mpiosh/files/patch-libmpio-debug.h b/audio/mpiosh/files/patch-libmpio-debug.h
new file mode 100644
index 000000000000..988685381e36
--- /dev/null
+++ b/audio/mpiosh/files/patch-libmpio-debug.h
@@ -0,0 +1,11 @@
+--- libmpio/debug.h.orig Thu Jun 19 19:47:19 2003
++++ libmpio/debug.h Thu Jun 19 19:47:39 2003
+@@ -27,7 +27,7 @@
+ #ifdef sun
+ #include <sys/int_types.h>
+ #else
+-#include <stdint.h>
++#include <sys/types.h>
+ #endif
+
+ #ifdef __cplusplus
diff --git a/audio/mpiosh/files/patch-libmpio-defs.h b/audio/mpiosh/files/patch-libmpio-defs.h
new file mode 100644
index 000000000000..0ca4688ef183
--- /dev/null
+++ b/audio/mpiosh/files/patch-libmpio-defs.h
@@ -0,0 +1,11 @@
+--- libmpio/defs.h.orig Fri Jun 20 10:41:50 2003
++++ libmpio/defs.h Fri Jun 20 10:42:08 2003
+@@ -99,7 +99,7 @@
+ #define NULL 0
+ #endif
+
+-#define MPIO_DEVICE "/dev/usb/mpio"
++#define MPIO_DEVICE "/dev/urio0"
+ #define MPIO_CHARSET "ISO-8859-15"
+
+ #define SECTOR_SIZE 0x200
diff --git a/audio/mpiosh/files/patch-mpiosh-Makefile.in b/audio/mpiosh/files/patch-mpiosh-Makefile.in
new file mode 100644
index 000000000000..66445733765d
--- /dev/null
+++ b/audio/mpiosh/files/patch-mpiosh-Makefile.in
@@ -0,0 +1,11 @@
+--- mpiosh/Makefile.in.orig Thu Jun 19 19:54:46 2003
++++ mpiosh/Makefile.in Thu Jun 19 19:55:54 2003
+@@ -142,7 +142,7 @@
+
+ AM_CFLAGS = -DSYSCONFDIR=\"@sysconfdir@\"
+
+-mpiosh_LDADD = ../libmpio/libmpio.la -lreadline -lncurses
++mpiosh_LDADD = ../libmpio/libmpio.la -lreadline -lncurses -liconv
+
+ noinst_HEADERS = mpiosh.h \
+ callback.h \
diff --git a/audio/mpiosh/files/patch-mpiosh-callback.c b/audio/mpiosh/files/patch-mpiosh-callback.c
new file mode 100644
index 000000000000..d40deae5fff3
--- /dev/null
+++ b/audio/mpiosh/files/patch-mpiosh-callback.c
@@ -0,0 +1,17 @@
+--- mpiosh/callback.c.orig Thu Jun 19 19:51:43 2003
++++ mpiosh/callback.c Thu Jun 19 19:52:29 2003
+@@ -29,11 +29,14 @@
+ #include <regex.h>
+ #include <time.h>
+ #include <unistd.h>
++#include <limits.h>
+
+ #include "mpiosh.h"
+ #include "command.h"
+
+ #include "libmpio/debug.h"
++
++#define NAME_MAX PATH_MAX
+
+ /* commands */
+ void
diff --git a/audio/mpiosh/files/patch-mpiosh-mpiosh.c b/audio/mpiosh/files/patch-mpiosh-mpiosh.c
new file mode 100644
index 000000000000..5dfeadbc5ee7
--- /dev/null
+++ b/audio/mpiosh/files/patch-mpiosh-mpiosh.c
@@ -0,0 +1,21 @@
+--- mpiosh/mpiosh.c.orig Thu Nov 14 02:05:28 2002
++++ mpiosh/mpiosh.c Thu Jun 19 19:59:10 2003
+@@ -39,6 +39,8 @@
+ #include "readline.h"
+ #include "mpiosh.h"
+
++#define SA_NOMASK 0
++
+ /* mpiosh core functions */
+ void
+ mpiosh_init(void)
+@@ -113,7 +115,9 @@
+
+ while ((line = readline(mpiosh.prompt))) {
+ if ((*line == '\0') || mpiosh_cancel) {
++#if 0
+ rl_clear_pending_input ();
++#endif
+ mpiosh_cancel = 0;
+ mpiosh_cancel_ack = 0;
+ continue;
diff --git a/audio/mpiosh/files/patch-mpiosh-readline.c b/audio/mpiosh/files/patch-mpiosh-readline.c
new file mode 100644
index 000000000000..f77f989c4d35
--- /dev/null
+++ b/audio/mpiosh/files/patch-mpiosh-readline.c
@@ -0,0 +1,11 @@
+--- mpiosh/readline.c.orig Thu Jun 19 19:57:05 2003
++++ mpiosh/readline.c Thu Jun 19 19:57:32 2003
+@@ -26,6 +26,8 @@
+ #include "command.h"
+ #include "mpiosh.h"
+
++#define rl_completion_matches completion_matches
++
+ /* readline extensions */
+ void
+ mpiosh_readline_init(void)
diff --git a/audio/mpiosh/files/patch-tools-Makefile.in b/audio/mpiosh/files/patch-tools-Makefile.in
new file mode 100644
index 000000000000..f88f77120658
--- /dev/null
+++ b/audio/mpiosh/files/patch-tools-Makefile.in
@@ -0,0 +1,11 @@
+--- tools/Makefile.in.orig Thu Jun 19 20:02:33 2003
++++ tools/Makefile.in Thu Jun 19 20:02:46 2003
+@@ -138,7 +138,7 @@
+
+ am_mpiologo_OBJECTS = mpiologo.$(OBJEXT)
+ mpiologo_OBJECTS = $(am_mpiologo_OBJECTS)
+-mpiologo_LDADD = $(LDADD)
++mpiologo_LDADD = $(LDADD) -lgnugetopt
+ mpiologo_DEPENDENCIES =
+ mpiologo_LDFLAGS =
+
diff --git a/audio/mpiosh/pkg-descr b/audio/mpiosh/pkg-descr
new file mode 100644
index 000000000000..5e4cc002b32b
--- /dev/null
+++ b/audio/mpiosh/pkg-descr
@@ -0,0 +1,9 @@
+Digit@lway MPIO MP3 player tools
+
+This is a project for using Digitalway/Adtec
+digital audio player MPIO (DMG, DMK, DME, ...)
+under FreeBSD. It provides a userspace library
+and at the moment one tool to access the MPIO
+player.
+
+WWW: http://mpio.sourceforge.net/
diff --git a/audio/mpiosh/pkg-plist b/audio/mpiosh/pkg-plist
new file mode 100644
index 000000000000..9d7e06e5a9ff
--- /dev/null
+++ b/audio/mpiosh/pkg-plist
@@ -0,0 +1,11 @@
+bin/mpiologo
+bin/mpiosh
+etc/mpio/mpioshrc
+lib/libmpio.a
+lib/libmpio.so
+lib/libmpio.so.1
+include/mpio/defs.h
+include/mpio/mpio.h
+sbin/mkmpiodev
+@dirrm include/mpio
+@dirrm etc/mpio