aboutsummaryrefslogtreecommitdiff
path: root/audio/mpiosh
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-03-09 17:15:43 +0000
commitf5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa (patch)
tree343e91600b9cf81ffb94bf71017b43a88bfcbf45 /audio/mpiosh
parente9e0ba8df0a817712eab81d4a962e79cae35dca1 (diff)
downloadports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.tar.gz
ports-f5d05ea54d1f80ecd08c5809a3ce5e1594e34eaa.zip
Notes
Diffstat (limited to 'audio/mpiosh')
-rw-r--r--audio/mpiosh/Makefile18
-rw-r--r--audio/mpiosh/files/extra-patch-configure.in41
2 files changed, 56 insertions, 3 deletions
diff --git a/audio/mpiosh/Makefile b/audio/mpiosh/Makefile
index 0c51baec17bc..8d62ba3a0585 100644
--- a/audio/mpiosh/Makefile
+++ b/audio/mpiosh/Makefile
@@ -14,8 +14,6 @@ DISTNAME= mpio-${PORTVERSION:S|.p|_pre|}
MAINTAINER= ports@FreeBSD.org
COMMENT= Digit@lway MPIO MP3 player tool
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
-
USE_AUTOTOOLS= libtool:15
USE_ICONV= yes
GNU_CONFIGURE= yes
@@ -23,4 +21,18 @@ USE_LDCONFIG= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure.in
+USE_AUTOTOOLS= autoconf:262
+.endif
+
+post-patch:
+.if ${OSVERSION} >= 800069
+ ${RM} -f ${WRKSRC}/configure
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/mpiosh/files/extra-patch-configure.in b/audio/mpiosh/files/extra-patch-configure.in
new file mode 100644
index 000000000000..22deee13d378
--- /dev/null
+++ b/audio/mpiosh/files/extra-patch-configure.in
@@ -0,0 +1,41 @@
+--- configure.in.orig 2004-05-30 05:45:55.000000000 +0400
++++ configure.in 2009-03-07 01:43:55.000000000 +0300
+@@ -60,34 +60,18 @@
+ dnl -- check for libusb
+ dnl -- this is stolen from libgphoto2
+
+-AC_PATH_PROG(LIBUSB_CONFIG,libusb-config)
+-if test -n "${LIBUSB_CONFIG}"; then
+- CPPFLAGS_save="$CPPFLAGS"
+- CPPFLAGS="$CPPFLAGS `$LIBUSB_CONFIG --cflags`"
++CPPFLAGS_save="$CPPFLAGS"
+ AC_CHECK_HEADER(usb.h,[
+ LDFLAGS_orig="$LDFLAGS"
+- LDFLAGS="`$LIBUSB_CONFIG --libs`"
++ LDFLAGS="-lusb"
+ AC_CHECK_LIB(usb,usb_busses,[
+ usb_msg="yes"
+ IOLIB_SUBDIRS="$IOLIB_SUBDIRS usb"
+- USB_LIBS="`$LIBUSB_CONFIG --libs`"
+- USB_CFLAGS="`$LIBUSB_CONFIG --cflags`"
+- LIBUSB_VER="`$LIBUSB_CONFIG --version`"],[
++ USB_LIBS="-lusb"
++ USB_CFLAGS=""],[
+ usb_msg="no (available version too old)"])
+ LDFLAGS="$LDFLAGS_orig"])
+ CPPFLAGS="$CPPFLAGS_save"
+-fi
+-
+- # This 'test' call uses non-standard syntax and will fail on most
+- # systems, but it's just informational so any warning can be ignored.
+-if test "$LIBUSB_VER" \< "0.1.7"; then
+- AC_MSG_WARN([
+-*** You need at least version 0.1.7 of the libusb library for USB support
+-*** http://sourceforge.net/projects/libusb/
+-*** If you cannot find the appropriate version, try CVS
+- ])
+- exit 1
+-fi
+
+ case "$usb_msg" in
+ yes*) AC_DEFINE(HAVE_USB,1,[Whether you have USB support enabled]);;