aboutsummaryrefslogtreecommitdiff
path: root/audio/mpt
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-09 03:21:51 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-09 03:21:51 +0000
commitc54d38b7cbc018b0b688c0e5397855d10f26b824 (patch)
tree5f8630a0add60ce865ea0bf96887dbc611944c6b /audio/mpt
parent70250efb7bbad226706bfb58a9182297fe91a7a8 (diff)
downloadports-c54d38b7cbc018b0b688c0e5397855d10f26b824.tar.gz
ports-c54d38b7cbc018b0b688c0e5397855d10f26b824.zip
Notes
Diffstat (limited to 'audio/mpt')
-rw-r--r--audio/mpt/Makefile35
-rw-r--r--audio/mpt/distinfo1
-rw-r--r--audio/mpt/pkg-comment1
-rw-r--r--audio/mpt/pkg-descr16
-rw-r--r--audio/mpt/pkg-plist5
5 files changed, 58 insertions, 0 deletions
diff --git a/audio/mpt/Makefile b/audio/mpt/Makefile
new file mode 100644
index 000000000000..ec35d947fb5e
--- /dev/null
+++ b/audio/mpt/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Mike's Playlist Thingie
+# Date created: Sat Dec 8 22:27:55 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpt
+PORTVERSION= 0.0
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freetantrum
+
+MAINTAINER= lioux@FreeBSD.org
+
+LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
+ songprint.1:${PORTSDIR}/audio/songprint
+
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+DOC_FILES= AUTHORS COPYING README
+
+do-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/mpt ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/mpt/distinfo b/audio/mpt/distinfo
new file mode 100644
index 000000000000..79d64f82bd27
--- /dev/null
+++ b/audio/mpt/distinfo
@@ -0,0 +1 @@
+MD5 (mpt-0.0.tar.gz) = 1d8b34e99eacfe9a7de7ecfb7756339b
diff --git a/audio/mpt/pkg-comment b/audio/mpt/pkg-comment
new file mode 100644
index 000000000000..0d3f61bcffd6
--- /dev/null
+++ b/audio/mpt/pkg-comment
@@ -0,0 +1 @@
+Mike's Playlist Thingie is a fingerprinting based playlist generator
diff --git a/audio/mpt/pkg-descr b/audio/mpt/pkg-descr
new file mode 100644
index 000000000000..9cf6b600a872
--- /dev/null
+++ b/audio/mpt/pkg-descr
@@ -0,0 +1,16 @@
+[ adapted from developer's website ]
+
+Mike's Playlist Thingie (working title)
+
+You know what is bad about playlists? You set them all up, and
+everything seems great, but then you go and get a couple hundred
+new mp3s. Now you have to go update all your playlists. If you've
+got 10 playlists and 100 new songs, that's 1000 decisions you have
+to make. Yuck.
+
+With MPT, playlists are no longer just static catalogs, pointing
+to songs on your hard drive. They're more like radio stations, where
+each one has a set of rules that define, in general, what kind of
+music should be played. Like procmail for music.
+
+WWW: http://sourceforge.net/projects/freetantrum/
diff --git a/audio/mpt/pkg-plist b/audio/mpt/pkg-plist
new file mode 100644
index 000000000000..03366c5a361a
--- /dev/null
+++ b/audio/mpt/pkg-plist
@@ -0,0 +1,5 @@
+bin/mpt
+%%PORTDOCS%%share/doc/mpt/AUTHORS
+%%PORTDOCS%%share/doc/mpt/COPYING
+%%PORTDOCS%%share/doc/mpt/README
+%%PORTDOCS%%@dirrm share/doc/mpt