aboutsummaryrefslogtreecommitdiff
path: root/audio/muine/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-05-07 06:45:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-05-07 06:45:39 +0000
commit890f04c002cc83541e8a4050c3f8baec289caa4e (patch)
tree0f5dd8fc023d3dda43cf61eccf2f86d7e2dd7ca4 /audio/muine/Makefile
parent560c00adfb6b10dc4413479f2ecd79ab883a9690 (diff)
Notes
Diffstat (limited to 'audio/muine/Makefile')
-rw-r--r--audio/muine/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index 5cc2c4c8c12f..6645273a1f9c 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: muine
-# Date created: 20040615
-# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
-#
+# Created by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
# $FreeBSD$
# $Id: Makefile,v 1.54 2007/01/26 03:17:25 tmclau02 Exp $
-#
PORTNAME= muine
PORTVERSION= 0.8.11
@@ -24,20 +20,18 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_GMAKE= yes
-USES= gettext
+USES= gettext shebangfix
USE_GNOME= gnomeprefix gnomehack intltool libgnomeui gnomesharp20
USE_GSTREAMER= gconf
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
+SHEBANG_FILES= src/muine.in
+bash_CMD= ${SETENV} bash
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= muine.schemas
-post-patch:
- @${REINPLACE_CMD} -e 's|/bin/bash|/usr/bin/env bash|g' \
- ${WRKSRC}/src/muine.in
-
.include <bsd.port.mk>