aboutsummaryrefslogtreecommitdiff
path: root/audio/muine/Makefile
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:00:17 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:00:17 +0000
commit1cf841e29c618276e49cb0aa219709013fe4c700 (patch)
tree222c57116c0a7d44e44cd6ffc9a40d9322c46892 /audio/muine/Makefile
parent2d07e58c489f22fe1561760fe658aa96cd1eb390 (diff)
downloadports-1cf841e29c618276e49cb0aa219709013fe4c700.tar.gz
ports-1cf841e29c618276e49cb0aa219709013fe4c700.zip
Notes
Diffstat (limited to 'audio/muine/Makefile')
-rw-r--r--audio/muine/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index 86975e92cb94..8c75fa8c432a 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -3,12 +3,11 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.47 2006/08/06 23:48:40 tmclau02 Exp $
+# $Id: Makefile,v 1.54 2007/01/26 03:17:25 tmclau02 Exp $
#
PORTNAME= muine
-PORTVERSION= 0.8.5
-PORTREVISION= 3
+PORTVERSION= 0.8.7
CATEGORIES= audio gnome
MASTER_SITES= http://muine-player.org/releases/
@@ -20,15 +19,12 @@ LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
gdbm:${PORTSDIR}/databases/gdbm \
vorbis.3:${PORTSDIR}/audio/libvorbis \
musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz
-BUILD_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
-RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
+RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
-USE_XLIB= yes
+USE_GNOME= gnomeprefix gnomehack intltool libgnomeui gnomesharp20
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -50,8 +46,8 @@ CONFIGURE_ARGS+= --disable-faad2
CONFIGURE_ARGS+= --enable-xine=yes
LIB_DEPENDS+= xine.16:${PORTSDIR}/multimedia/libxine
.else
-USE_GSTREAMER80+= gconf
-CONFIGURE_ARGS+= --enable-gstreamer=0.8
+USE_GSTREAMER+= gconf
+CONFIGURE_ARGS+= --enable-gstreamer=0.10
.endif
post-patch:
@@ -62,7 +58,7 @@ post-patch:
post-install:
${MKDIR} ${PREFIX}/lib/muine/plugins
-.for _plugin in TrayIcon.dll DashboardPlugin.dll
+.for _plugin in TrayIcon.dll
${INSTALL_DATA} ${WRKSRC}/plugins/${_plugin} ${PREFIX}/lib/muine/plugins
.endfor