aboutsummaryrefslogtreecommitdiff
path: root/audio/muine
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:00:17 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2007-02-04 23:00:17 +0000
commit1cf841e29c618276e49cb0aa219709013fe4c700 (patch)
tree222c57116c0a7d44e44cd6ffc9a40d9322c46892 /audio/muine
parent2d07e58c489f22fe1561760fe658aa96cd1eb390 (diff)
downloadports-1cf841e29c618276e49cb0aa219709013fe4c700.tar.gz
ports-1cf841e29c618276e49cb0aa219709013fe4c700.zip
Notes
Diffstat (limited to 'audio/muine')
-rw-r--r--audio/muine/Makefile20
-rw-r--r--audio/muine/distinfo6
-rw-r--r--audio/muine/pkg-plist28
3 files changed, 26 insertions, 28 deletions
diff --git a/audio/muine/Makefile b/audio/muine/Makefile
index 86975e92cb94..8c75fa8c432a 100644
--- a/audio/muine/Makefile
+++ b/audio/muine/Makefile
@@ -3,12 +3,11 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.47 2006/08/06 23:48:40 tmclau02 Exp $
+# $Id: Makefile,v 1.54 2007/01/26 03:17:25 tmclau02 Exp $
#
PORTNAME= muine
-PORTVERSION= 0.8.5
-PORTREVISION= 3
+PORTVERSION= 0.8.7
CATEGORIES= audio gnome
MASTER_SITES= http://muine-player.org/releases/
@@ -20,15 +19,12 @@ LIB_DEPENDS= FLAC.7:${PORTSDIR}/audio/flac \
gdbm:${PORTSDIR}/databases/gdbm \
vorbis.3:${PORTSDIR}/audio/libvorbis \
musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz
-BUILD_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
-RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
+RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intltool libgnomeui
-USE_XLIB= yes
+USE_GNOME= gnomeprefix gnomehack intltool libgnomeui gnomesharp20
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
@@ -50,8 +46,8 @@ CONFIGURE_ARGS+= --disable-faad2
CONFIGURE_ARGS+= --enable-xine=yes
LIB_DEPENDS+= xine.16:${PORTSDIR}/multimedia/libxine
.else
-USE_GSTREAMER80+= gconf
-CONFIGURE_ARGS+= --enable-gstreamer=0.8
+USE_GSTREAMER+= gconf
+CONFIGURE_ARGS+= --enable-gstreamer=0.10
.endif
post-patch:
@@ -62,7 +58,7 @@ post-patch:
post-install:
${MKDIR} ${PREFIX}/lib/muine/plugins
-.for _plugin in TrayIcon.dll DashboardPlugin.dll
+.for _plugin in TrayIcon.dll
${INSTALL_DATA} ${WRKSRC}/plugins/${_plugin} ${PREFIX}/lib/muine/plugins
.endfor
diff --git a/audio/muine/distinfo b/audio/muine/distinfo
index 5c7e9e801ed9..4d1f4646dd7c 100644
--- a/audio/muine/distinfo
+++ b/audio/muine/distinfo
@@ -1,3 +1,3 @@
-MD5 (muine-0.8.5.tar.gz) = 6960b21da5fd5cbc7a2e5a93a7bcd2a2
-SHA256 (muine-0.8.5.tar.gz) = 998eaf9fcd5859eccc75ba5f0d1d6b8f1d161a3006889528f5a5598ed1ec31f3
-SIZE (muine-0.8.5.tar.gz) = 701852
+MD5 (muine-0.8.7.tar.gz) = 19f5aa148a7bd3c18cf1c3244813aa88
+SHA256 (muine-0.8.7.tar.gz) = c3ce4665c156ec15d952fc18267d9b50c1445fbf8b26953ee9448c7a7db6a1e3
+SIZE (muine-0.8.7.tar.gz) = 765786
diff --git a/audio/muine/pkg-plist b/audio/muine/pkg-plist
index 6bcba5e662e6..985568794ee1 100644
--- a/audio/muine/pkg-plist
+++ b/audio/muine/pkg-plist
@@ -1,30 +1,37 @@
bin/muine
-lib/mono/gac/muine-dbus/1.0.0.0__e6bf890338fa2913/muine-dbus.dll
-lib/mono/gac/muine-plugin/1.0.0.0__e6bf890338fa2913/muine-plugin.dll
-lib/mono/muine/muine-dbus.dll
-lib/mono/muine/muine-plugin.dll
lib/monodoc/sources/muine-docs.source
lib/monodoc/sources/muine-docs.tree
lib/monodoc/sources/muine-docs.zip
+lib/muine/NDesk.DBus.GLib.dll
+lib/muine/NDesk.DBus.GLib.dll.config
+lib/muine/NDesk.DBus.dll
lib/muine/libmuine.a
lib/muine/libmuine.la
lib/muine/libmuine.so
lib/muine/libmuine.so.0
+lib/muine/muine-dbus.dll
+lib/muine/muine-plugin.dll
lib/muine/muine.exe
lib/muine/muine.exe.config
-lib/muine/plugins/DashboardPlugin.dll
lib/muine/plugins/TrayIcon.dll
libdata/pkgconfig/muine-dbus.pc
libdata/pkgconfig/muine-plugin.pc
share/dbus-1/services/org.gnome.Muine.service
share/gnome/applications/muine.desktop
-share/gnome/pixmaps/muine.png
+share/icons/hicolor/16x16/apps/muine.png
+share/icons/hicolor/22x22/apps/muine.png
+share/icons/hicolor/24x24/apps/muine.png
+share/icons/hicolor/32x32/apps/muine.png
+share/icons/hicolor/scalable/apps/muine.svg
+share/locale/ar/LC_MESSAGES/muine.mo
share/locale/az/LC_MESSAGES/muine.mo
share/locale/bg/LC_MESSAGES/muine.mo
share/locale/ca/LC_MESSAGES/muine.mo
share/locale/cs/LC_MESSAGES/muine.mo
share/locale/da/LC_MESSAGES/muine.mo
share/locale/de/LC_MESSAGES/muine.mo
+share/locale/dz/LC_MESSAGES/muine.mo
+share/locale/el/LC_MESSAGES/muine.mo
share/locale/en_CA/LC_MESSAGES/muine.mo
share/locale/en_GB/LC_MESSAGES/muine.mo
share/locale/es/LC_MESSAGES/muine.mo
@@ -38,6 +45,8 @@ share/locale/is/LC_MESSAGES/muine.mo
share/locale/ja/LC_MESSAGES/muine.mo
share/locale/ko/LC_MESSAGES/muine.mo
share/locale/lt/LC_MESSAGES/muine.mo
+share/locale/lv/LC_MESSAGES/muine.mo
+share/locale/mk/LC_MESSAGES/muine.mo
share/locale/ms/LC_MESSAGES/muine.mo
share/locale/nb/LC_MESSAGES/muine.mo
share/locale/ne/LC_MESSAGES/muine.mo
@@ -59,10 +68,3 @@ share/locale/vi/LC_MESSAGES/muine.mo
share/locale/zh_CN/LC_MESSAGES/muine.mo
@dirrmtry lib/muine/plugins
@dirrmtry lib/muine
-@dirrm lib/mono/muine
-@dirrm lib/mono/gac/muine-plugin/1.0.0.0__e6bf890338fa2913
-@dirrm lib/mono/gac/muine-plugin
-@dirrm lib/mono/gac/muine-dbus/1.0.0.0__e6bf890338fa2913
-@dirrm lib/mono/gac/muine-dbus
-@dirrmtry lib/monodoc/sources
-@dirrmtry lib/monodoc