aboutsummaryrefslogtreecommitdiff
path: root/audio/mumble
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2019-03-21 22:18:23 +0000
committerMark Felder <feld@FreeBSD.org>2019-03-21 22:18:23 +0000
commit9d19c88ccb599cdf3ff8b1ebbd7eaea0cfc17e10 (patch)
tree2432153b6f280696cf86c5dd9f2279bbbc2f4033 /audio/mumble
parent8102f2774abff62a0f0b47b600cca600e3a6cddf (diff)
downloadports-9d19c88ccb599cdf3ff8b1ebbd7eaea0cfc17e10.tar.gz
ports-9d19c88ccb599cdf3ff8b1ebbd7eaea0cfc17e10.zip
Notes
Diffstat (limited to 'audio/mumble')
-rw-r--r--audio/mumble/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/audio/mumble/Makefile b/audio/mumble/Makefile
index f10744339cf1..576e3d631af1 100644
--- a/audio/mumble/Makefile
+++ b/audio/mumble/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mumble
DISTVERSION= 1.3.0-rc1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= audio
MAINTAINER= feld@FreeBSD.org
@@ -40,13 +40,12 @@ USE_XORG= ice xi x11
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE=yes
-CONFIG= bundled-celt bundled-rnnoise no-alsa no-bundled-opus no-speechd no-bundled-speex \
- no-bundled-speexdsp no-embed-qt-translations no-g15 no-jackaudio no-pulseaudio \
- no-pulseaudio no-server no-update no-xevie
+CONFIG= bundled-celt bundled-rnnoise no-bundled-opus no-bundled-speex no-bundled-speexdsp \
+ no-embed-qt-translations no-g15 no-alsa no-jackaudio no-pulseaudio no-server no-update
QMAKE_ARGS= "CONFIG+=${CONFIG}"
-OPTIONS_DEFINE= DBUS BONJOUR PORTAUDIO
+OPTIONS_DEFINE= DBUS BONJOUR PORTAUDIO SPEECHD
OPTIONS_DEFAULT= DBUS
DBUS_VARS_OFF= CONFIG+=no-dbus
@@ -60,6 +59,10 @@ BONJOUR_LIB_DEPENDS= libdns_sd.so:net/mDNSResponder
PORTAUDIO_VARS_OFF= CONFIG+=no-portaudio
PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
+SPEECHD_DESC= Support for Speech Dispatcher
+SPEECHD_VARS_OFF= CONFIG+=no-speechd
+SPEECHD_LIB_DEPENDS= libspeechd.so:accessibility/speech-dispatcher
+
.include <bsd.port.pre.mk>
# PCH is broken on GCC