aboutsummaryrefslogtreecommitdiff
path: root/audio/muse
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-29 07:43:38 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-29 07:43:38 +0000
commit2e8fc655bc93890a4b9bb382c4d002b620adb9c5 (patch)
tree803320619e3a432324b952a0f20628ad52b471d0 /audio/muse
parent4dfb02693ae2e6a6c5bd224de66689b9a7cea767 (diff)
downloadports-2e8fc655bc93890a4b9bb382c4d002b620adb9c5.tar.gz
ports-2e8fc655bc93890a4b9bb382c4d002b620adb9c5.zip
Notes
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/Makefile34
-rw-r--r--audio/muse/distinfo4
-rw-r--r--audio/muse/files/patch-configure38
-rw-r--r--audio/muse/files/patch-gtkgui::listpack.cpp11
-rw-r--r--audio/muse/files/patch-jmixer.cpp11
-rw-r--r--audio/muse/files/patch-ncursesgui::about.cpp157
-rw-r--r--audio/muse/files/patch-shout::mp3.c10
-rw-r--r--audio/muse/files/patch-shout::shout_private.h17
-rw-r--r--audio/muse/files/patch-src::Makefile.in10
-rw-r--r--audio/muse/files/patch-src::jmixer.cpp42
-rw-r--r--audio/muse/files/patch-src::libmpeg::mpegtoraw.cc22
-rw-r--r--audio/muse/files/patch-src::outchannels.cpp (renamed from audio/muse/files/patch-outchannels.cpp)6
-rw-r--r--audio/muse/files/patch-src::pipe.cpp12
-rw-r--r--audio/muse/files/patch-src::shout::sock.c14
-rw-r--r--audio/muse/pkg-plist9
15 files changed, 158 insertions, 239 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index c804fc1a1855..700a1f3596c4 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -7,18 +7,16 @@
#
PORTNAME= MuSE
-PORTVERSION= 0.8.1
-PORTREVISION= 3
+PORTVERSION= 0.9
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
- http://muse.dyne.org/releases/
-MASTER_SITE_SUBDIR= muse
-DISTNAME= MuSE-${PORTVERSION}
+MASTER_SITES= ftp://ftp.dyne.org/muse/releases/ \
+ http://www.ljudmila.org/~jaromil/muse/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= Multiple Streaming Engine
LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
vorbis.3:${PORTSDIR}/audio/libvorbis
USE_GETOPT_LONG= yes
@@ -27,33 +25,31 @@ USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-debug
+CONFIGURE_ARGS= --disable-debug --disable-lubrify
MAN1= muse.1
+PORTDOCS= ${DOCSFILES:S,doc/,,g}
+PLIT_FILES= bin/muse
-CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
+CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT -DHAVE_SYS_UIO_H \
+ ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+DOCFILES= AUTHORS ChangeLog KNOWN-BUGS NEWS README TODO doc/USAGE
+
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+= --without-x --with-rubik
.else
-USE_GNOME+= gtk12
+USE_GNOME+= gtk20
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=.*$$|CFLAGS="\$$CFLAGS"|g ; \
- s|[$$]GTK_LIBS -lgthread|\$$GTK_LIBS \$$GLIB_LIBS|g ; \
- s|[$$]GTK_FLAGS|\$$GTK_CFLAGS \$$GLIB_CFLAGS|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lpthread||g' ${WRKSRC}/Makefile.in
-
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/muse ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/muse.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/muse ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/muse.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog KNOWN-BUGS NEWS README TODO USAGE
+.for file in ${DOCFILES}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/audio/muse/distinfo b/audio/muse/distinfo
index a1eec68bb297..b7d6fdc92730 100644
--- a/audio/muse/distinfo
+++ b/audio/muse/distinfo
@@ -1,2 +1,2 @@
-MD5 (MuSE-0.8.1.tar.gz) = 1ca2c62aa2db10f92ee5a864da736e34
-SIZE (MuSE-0.8.1.tar.gz) = 624750
+MD5 (MuSE-0.9.tar.gz) = 0c2075c9f62ba1d08459f669498b6bcf
+SIZE (MuSE-0.9.tar.gz) = 1363091
diff --git a/audio/muse/files/patch-configure b/audio/muse/files/patch-configure
new file mode 100644
index 000000000000..32f2729ded91
--- /dev/null
+++ b/audio/muse/files/patch-configure
@@ -0,0 +1,38 @@
+--- configure.orig Sun Apr 18 00:33:26 2004
++++ configure Mon Apr 19 22:34:18 2004
+@@ -3427,7 +3427,7 @@
+ #AM_DEFINE_UNQUOTED(HOST_CPU, "${host_cpu}")
+
+ #CFLAGS="-O4 -D_REENTRANT -fomit-frame-pointer -march=${host_cpu} -ffast-math -malign-double -funroll-loops -pipe"
+-CFLAGS="-pipe -D_REENTRANT"
++CFLAGS="$CFLAGS -D_REENTRANT"
+
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+@@ -11182,7 +11182,7 @@
+ else
+
+ lrint_save_CFLAGS=$CFLAGS
+-CFLAGS="-O2 -lm"
++CFLAGS="$CFLAGS -lm"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -11249,7 +11249,7 @@
+ else
+
+ lrintf_save_CFLAGS=$CFLAGS
+-CFLAGS="-O2 -lm"
++CFLAGS="$CFLAGS -lm"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -11836,8 +11836,6 @@
+ else
+ CFLAGS="$CFLAGS -O3 -fomit-frame-pointer -march=${host_cpu} -ffast-math"
+ fi
+-else
+- CFLAGS="$CFLAGS -O2 -ffast-math"
+ fi
+
+
diff --git a/audio/muse/files/patch-gtkgui::listpack.cpp b/audio/muse/files/patch-gtkgui::listpack.cpp
deleted file mode 100644
index 3b21a7254af5..000000000000
--- a/audio/muse/files/patch-gtkgui::listpack.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- gtkgui/listpack.cpp.orig Mon Jul 28 20:31:24 2003
-+++ gtkgui/listpack.cpp Mon Jul 28 20:32:17 2003
-@@ -49,7 +49,7 @@
- item->container = container;
- item->data = data;
-
-- func("list_add:: item %p item->pos = %u
-+ func("list_add:: item %p item->pos = %u\
- item->container= %p item->data=%p", item, item->pos,
- item->container, item->data);
- /**list = g_list_append(*list, (void *) item);*/
diff --git a/audio/muse/files/patch-jmixer.cpp b/audio/muse/files/patch-jmixer.cpp
deleted file mode 100644
index e5190231d46e..000000000000
--- a/audio/muse/files/patch-jmixer.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- jmixer.cpp.orig Tue Jul 23 04:48:56 2002
-+++ jmixer.cpp Sat Dec 28 09:41:10 2002
-@@ -808,7 +808,7 @@
- }
-
- /* this is the function selecting files for the scandir */
--int selector(const struct dirent *dir) {
-+int selector(struct dirent *dir) {
- if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
- #ifdef HAVE_VORBIS
- || strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0
diff --git a/audio/muse/files/patch-ncursesgui::about.cpp b/audio/muse/files/patch-ncursesgui::about.cpp
deleted file mode 100644
index 762175af0e11..000000000000
--- a/audio/muse/files/patch-ncursesgui::about.cpp
+++ /dev/null
@@ -1,157 +0,0 @@
---- ncursesgui/about.cpp.orig Thu May 30 22:56:45 2002
-+++ ncursesgui/about.cpp Mon Dec 22 00:47:55 2003
-@@ -58,80 +58,80 @@
- warning ("aboutbox::setitem()");
- char src[8192];
- snprintf (src, sizeof(src),
--"MuSE is a [ d y n e . o r g ] production! :)
--
--MuSE <-------------------------------> Multiple Streaming Engine
--MuSE is an application for the mixing, encoding, and streaming of sound:
--is an engine that can simultaniously mix up to 6 separate MP3 or OggVorbis
--audio files from the hard drive or the network, where each channel of
--audio can be dynamicly adjusted for speed and volume plus a soundcard
--line-in channel. The resulting stream can be played locally on the sound
--card and/or encoded as an mp3 network stream to an icecast or shoutcast
--server (ready to be mixed and played again by other muses... ;)
--
--MuSE has been created and is mantained by
--Denis Rojo aka jaromil <jaromil@dyne.org>
--The GTK+ graphical user interface is developed by
--nightolo <night@autistici.org>
--The ncurses user interface is developed by
--Luca Profico aka rubik <rubik@olografix.org>
--
--MuSE as it is now would have never existed without the contributions of:
--= Markus Seidl ( funda.ment.org ) for the idea of mixing and streaming
-- multiple files
--= August Black ( aug.ment.org ) for the original graphical user interface
--= SERVUS.AT for trusting this project since the beginning and supporting it
--= PUBLIC VOICE Lab ( pvl.at ) for recently giving MuSE support and new
-- horizons of use
--= Asbesto Molesto ( freaknet.org ) for the extensive testing and
-- documentation
--= Alex, Rasty and Martinez ( ! ) for the good karma
--
--also BIG THANKS to:
--lobo, voyager, void, blicero, saiborg, the freaknet medialab, the ASCII
--squat, henk, the imc-audio collective, jeff, the LOA hacklab, the TPO,
--bundes & didi, indymedia italy, neural.it, the autistici.org collective,
--mag-one, radio onda rossa and all the others i'm forgetting here!
--
--MuSE redistributes, linking statically, the following libraries:
--= libmpeg by Woo-jae Jung (now mantained by Mikael Hedin)
--= libshout by Jack Moffit, Chad Armstrong and Scott Manley
--= libcdk by Mike Glover
--
--(refer to documentation included into subdirectories for more informations)
--
--MuSE can link dinamically to the following libraries:
--= libogg, libvorbis, libvorbisfile - www.xiph.org
--= glib, libgdk, libgtk - www.gtk.org
--= liblame - www.mp3dev.org/mp3
--= libX11, libXext - www.xfree86.org
--= other common GNU libraries
--
--MuSE sourcecode also got inspirations from:
--= stream mixer code by Scott Manley
--= buffered FIFO pipe code by Charles Samuels.
--
--
--MuSE is copyright (c) 2000, 2001, 2002 by Denis Rojo aka jaromil
--MuSE's GTK+ G.U.I. is (c) 2002 by nightolo
--MuSE's ncurses console U.I is (c) 2002 by Luca Profico aka rubik
--
--
--
-----------------------------------------------------------------
--This source code is free software; you can redistribute it and/or
--modify it under the terms of the GNU Public License as published
--by the Free Software Foundation; either version 2 of the License,
--or (at your option) any later version.
--
--This source code is distributed in the hope that it will be useful,
--but WITHOUT ANY WARRANTY; without even the implied warranty of
--MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
--Please refer to the GNU Public License for more details.
--
--You should have received a copy of the GNU Public License along with
--this source code; if not, write to:
--Free Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-+"MuSE is a [ d y n e . o r g ] production! :)\n\
-+ \n\
-+MuSE <-------------------------------> Multiple Streaming Engine \n\
-+MuSE is an application for the mixing, encoding, and streaming of sound:\n\
-+is an engine that can simultaniously mix up to 6 separate MP3 or OggVorbis\n\
-+audio files from the hard drive or the network, where each channel of \n\
-+audio can be dynamicly adjusted for speed and volume plus a soundcard \n\
-+line-in channel. The resulting stream can be played locally on the sound \n\
-+card and/or encoded as an mp3 network stream to an icecast or shoutcast \n\
-+server (ready to be mixed and played again by other muses... ;)\n\
-+\n\
-+MuSE has been created and is mantained by \n\
-+Denis Rojo aka jaromil <jaromil@dyne.org>\n\
-+The GTK+ graphical user interface is developed by \n\
-+nightolo <night@autistici.org>\n\
-+The ncurses user interface is developed by\n\
-+Luca Profico aka rubik <rubik@olografix.org>\n\
-+\n\
-+MuSE as it is now would have never existed without the contributions of:\n\
-+= Markus Seidl ( funda.ment.org ) for the idea of mixing and streaming \n\
-+ multiple files\n\
-+= August Black ( aug.ment.org ) for the original graphical user interface\n\
-+= SERVUS.AT for trusting this project since the beginning and supporting it\n\
-+= PUBLIC VOICE Lab ( pvl.at ) for recently giving MuSE support and new \n\
-+ horizons of use\n\
-+= Asbesto Molesto ( freaknet.org ) for the extensive testing and \n\
-+ documentation\n\
-+= Alex, Rasty and Martinez ( ! ) for the good karma\n\
-+\n\
-+also BIG THANKS to:\n\
-+lobo, voyager, void, blicero, saiborg, the freaknet medialab, the ASCII \n\
-+squat, henk, the imc-audio collective, jeff, the LOA hacklab, the TPO, \n\
-+bundes & didi, indymedia italy, neural.it, the autistici.org collective, \n\
-+mag-one, radio onda rossa and all the others i'm forgetting here!\n\
-+ \n\
-+MuSE redistributes, linking statically, the following libraries:\n\
-+= libmpeg by Woo-jae Jung (now mantained by Mikael Hedin)\n\
-+= libshout by Jack Moffit, Chad Armstrong and Scott Manley\n\
-+= libcdk by Mike Glover\n\
-+\n\
-+(refer to documentation included into subdirectories for more informations)\n\
-+\n\
-+MuSE can link dinamically to the following libraries:\n\
-+= libogg, libvorbis, libvorbisfile - www.xiph.org\n\
-+= glib, libgdk, libgtk - www.gtk.org\n\
-+= liblame - www.mp3dev.org/mp3\n\
-+= libX11, libXext - www.xfree86.org\n\
-+= other common GNU libraries\n\
-+\n\
-+MuSE sourcecode also got inspirations from:\n\
-+= stream mixer code by Scott Manley\n\
-+= buffered FIFO pipe code by Charles Samuels.\n\
-+\n\
-+\n\
-+MuSE is copyright (c) 2000, 2001, 2002 by Denis Rojo aka jaromil\n\
-+MuSE's GTK+ G.U.I. is (c) 2002 by nightolo\n\
-+MuSE's ncurses console U.I is (c) 2002 by Luca Profico aka rubik\n\
-+\n\
-+\n\
-+\n\
-+---------------------------------------------------------------\n\
-+This source code is free software; you can redistribute it and/or\n\
-+modify it under the terms of the GNU Public License as published \n\
-+by the Free Software Foundation; either version 2 of the License,\n\
-+or (at your option) any later version.\n\
-+\n\
-+This source code is distributed in the hope that it will be useful,\n\
-+but WITHOUT ANY WARRANTY; without even the implied warranty of\n\
-+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n\
-+Please refer to the GNU Public License for more details.\n\
-+\n\
-+You should have received a copy of the GNU Public License along with\n\
-+this source code; if not, write to:\n\
-+Free Software Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.\n\
- ");
-
- item = splitstring(src);
diff --git a/audio/muse/files/patch-shout::mp3.c b/audio/muse/files/patch-shout::mp3.c
deleted file mode 100644
index 8570a8224d54..000000000000
--- a/audio/muse/files/patch-shout::mp3.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- shout/mp3.c.orig Tue Mar 25 05:30:10 2003
-+++ shout/mp3.c Thu Apr 24 02:44:09 2003
-@@ -1,7 +1,6 @@
- /* mp3.c: libshout MP3 format handler */
-
- #include <stdio.h>
--#include <stdint.h>
- #include <stdlib.h>
- #include <string.h>
- #include <config.h>
diff --git a/audio/muse/files/patch-shout::shout_private.h b/audio/muse/files/patch-shout::shout_private.h
deleted file mode 100644
index 9f8dc2c7cd1d..000000000000
--- a/audio/muse/files/patch-shout::shout_private.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- shout/shout_private.h.orig Fri Nov 29 20:51:56 2002
-+++ shout/shout_private.h Wed May 14 14:26:24 2003
-@@ -14,14 +14,6 @@
- # include <inttypes.h>
- #endif
-
--# if SIZEOF_INT == 8
--typedef unsigned int uint64_t;
--# elif SIZEOF_LONG == 8
--typedef unsigned long uint64_t;
--# elif SIZEOF_LONG_LONG == 8
--typedef unsigned long long uint64_t;
--# endif
--
- #define LIBSHOUT_DEFAULT_HOST "localhost"
- #define LIBSHOUT_DEFAULT_PORT 8000
- #define LIBSHOUT_DEFAULT_FORMAT SHOUT_FORMAT_VORBIS
diff --git a/audio/muse/files/patch-src::Makefile.in b/audio/muse/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..d51c82fb6830
--- /dev/null
+++ b/audio/muse/files/patch-src::Makefile.in
@@ -0,0 +1,10 @@
+--- src/Makefile.in.orig Sun Apr 18 00:33:24 2004
++++ src/Makefile.in Mon Apr 19 22:28:56 2004
+@@ -207,7 +207,6 @@
+ muse_LDADD = \
+ $(top_srcdir)/src/resample/libresample.a \
+ $(top_srcdir)/src/libmpeg/libmpeg.a \
+- -lpthread \
+ @LIBSHOUT_LIB@ \
+ @M_LIBS@ \
+ @LAME_LIBS@ \
diff --git a/audio/muse/files/patch-src::jmixer.cpp b/audio/muse/files/patch-src::jmixer.cpp
new file mode 100644
index 000000000000..17e95ed2b42d
--- /dev/null
+++ b/audio/muse/files/patch-src::jmixer.cpp
@@ -0,0 +1,42 @@
+--- src/jmixer.cpp.orig Sat Apr 10 02:50:43 2004
++++ src/jmixer.cpp Mon Apr 19 22:49:59 2004
+@@ -20,18 +20,18 @@
+ */
+
+ #include <iostream>
+-#include <math.h>
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cmath>
++#include <cstdio>
++#include <cstdlib>
+ #include <unistd.h>
+ #include <dirent.h>
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+-#include <errno.h>
++#include <cerrno>
+ #include <fcntl.h>
+ #include <sys/soundcard.h>
+-#include <string.h>
+-#include <signal.h>
++#include <cstring>
++#include <csignal>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+ #include <termios.h>
+@@ -624,10 +624,11 @@
+ return true;
+ }
+
+-/* this is the function selecting files for the scandir
+- on freebsd systems you should change the following line to:
+- int selector(struct dirent *dir) { */
++#if defined(__FreeBSD__)
++int selector(struct dirent *dir) {
++#else
+ int selector(const struct dirent *dir) {
++#endif
+ if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
+ #ifdef HAVE_VORBIS
+ || strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0
diff --git a/audio/muse/files/patch-src::libmpeg::mpegtoraw.cc b/audio/muse/files/patch-src::libmpeg::mpegtoraw.cc
new file mode 100644
index 000000000000..6032cdc86627
--- /dev/null
+++ b/audio/muse/files/patch-src::libmpeg::mpegtoraw.cc
@@ -0,0 +1,22 @@
+--- src/libmpeg/mpegtoraw.cc.orig Mon Dec 8 21:20:37 2003
++++ src/libmpeg/mpegtoraw.cc Mon Apr 19 23:00:18 2004
+@@ -9,8 +9,8 @@
+ #include <pthread.h>
+ #endif
+
+-#include <math.h>
+-#include <stdlib.h>
++#include <cmath>
++#include <cstdlib>
+ #include <unistd.h>
+
+ #include "mpegsound.h"
+@@ -419,7 +419,7 @@
+ return true;
+ }
+
+-#include <iostream.h>
++#include <iostream>
+ // Convert mpeg to raw
+ bool Mpegtoraw::run(int frames) {
+ clearrawdata();
diff --git a/audio/muse/files/patch-outchannels.cpp b/audio/muse/files/patch-src::outchannels.cpp
index 55fd3f4fb561..b35b3ac2c444 100644
--- a/audio/muse/files/patch-outchannels.cpp
+++ b/audio/muse/files/patch-src::outchannels.cpp
@@ -1,6 +1,6 @@
---- outchannels.cpp.orig Fri Jun 7 02:44:42 2002
-+++ outchannels.cpp Fri Jun 7 02:44:48 2002
-@@ -20,11 +20,11 @@
+--- src/outchannels.cpp.orig Thu Apr 15 22:12:15 2004
++++ src/outchannels.cpp Mon Apr 19 22:37:58 2004
+@@ -24,11 +24,11 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
diff --git a/audio/muse/files/patch-src::pipe.cpp b/audio/muse/files/patch-src::pipe.cpp
new file mode 100644
index 000000000000..bc2e8a220f78
--- /dev/null
+++ b/audio/muse/files/patch-src::pipe.cpp
@@ -0,0 +1,12 @@
+--- src/pipe.cpp.orig Mon Dec 8 21:20:33 2003
++++ src/pipe.cpp Mon Apr 19 22:39:37 2004
+@@ -25,7 +25,8 @@
+ */
+
+ #include <iostream>
+-#include <stdlib.h>
++#include <cstdlib>
++#include <cerrno>
+ #include <audioproc.h>
+ #include <pipe.h>
+ #include <jutils.h>
diff --git a/audio/muse/files/patch-src::shout::sock.c b/audio/muse/files/patch-src::shout::sock.c
new file mode 100644
index 000000000000..19956755987e
--- /dev/null
+++ b/audio/muse/files/patch-src::shout::sock.c
@@ -0,0 +1,14 @@
+--- src/shout/sock.c.orig Tue Mar 30 01:04:27 2004
++++ src/shout/sock.c Mon Apr 19 23:32:09 2004
+@@ -336,7 +336,11 @@
+ int rc = SOCK_ERROR;
+ va_list ap_retry;
+
++#if (defined(__FreeBSD__) && __FreeBSD__ < 5)
++ ap_retry = ap;
++#else
+ va_copy (ap_retry, ap);
++#endif
+
+ len = vsnprintf (buff, sizeof (buffer), fmt, ap);
+
diff --git a/audio/muse/pkg-plist b/audio/muse/pkg-plist
deleted file mode 100644
index ccccfaba42ec..000000000000
--- a/audio/muse/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/muse
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/KNOWN-BUGS
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/USAGE
-%%PORTDOCS%%@dirrm %%DOCSDIR%%