aboutsummaryrefslogtreecommitdiff
path: root/audio/muse
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-06 18:47:52 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-06 18:47:52 +0000
commitc6f7e8466b8ef77b0aadafc0f5982b8feba35ac5 (patch)
tree660843652ee7236b4db75297ae3ca0c4ce22f868 /audio/muse
parent2a112bea93c36b513301e8f5d8fcb130f45a2bbd (diff)
downloadports-c6f7e8466b8ef77b0aadafc0f5982b8feba35ac5.tar.gz
ports-c6f7e8466b8ef77b0aadafc0f5982b8feba35ac5.zip
Notes
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/Makefile33
-rw-r--r--audio/muse/distinfo1
-rw-r--r--audio/muse/files/patch-Makefile.in22
-rw-r--r--audio/muse/files/patch-outchannels.cpp15
-rw-r--r--audio/muse/pkg-comment1
-rw-r--r--audio/muse/pkg-descr8
-rw-r--r--audio/muse/pkg-plist10
7 files changed, 90 insertions, 0 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
new file mode 100644
index 000000000000..b154d287f1de
--- /dev/null
+++ b/audio/muse/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: muse
+# Date created: Jun 7, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= muse
+PORTVERSION= 0.7.1
+CATEGORIES= audio
+MASTER_SITES= http://freesoftware.fsf.org/download/muse/ \
+ http://muse.dyne.org/releases/
+DISTNAME= MuSE-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame \
+ ogg:${PORTSDIR}/audio/libogg \
+ vorbis:${PORTSDIR}/audio/libvorbis \
+ gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+USE_GTK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,-lgthread,-lgthread12,g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/audio/muse/distinfo b/audio/muse/distinfo
new file mode 100644
index 000000000000..e4ef962da030
--- /dev/null
+++ b/audio/muse/distinfo
@@ -0,0 +1 @@
+MD5 (MuSE-0.7.1.tar.gz) = 98ccc46b79d67ec72391642270888654
diff --git a/audio/muse/files/patch-Makefile.in b/audio/muse/files/patch-Makefile.in
new file mode 100644
index 000000000000..9266bd8a6b97
--- /dev/null
+++ b/audio/muse/files/patch-Makefile.in
@@ -0,0 +1,22 @@
+--- Makefile.in.orig Fri Jun 7 02:45:04 2002
++++ Makefile.in Fri Jun 7 02:46:00 2002
+@@ -98,7 +98,7 @@
+
+
+ docs_DATA = README COPYING USAGE AUTHORS NEWS KNOWN-BUGS ChangeLog TODO
+-docsdir = ${prefix}/doc/MuSE
++docsdir = ${prefix}/share/doc/MuSE
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = config.h
+@@ -197,8 +197,8 @@
+ $(mkinstalldirs) $(DESTDIR)$(bindir)
+ @list='$(bin_PROGRAMS)'; for p in $$list; do \
+ if test -f $$p; then \
+- echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`"; \
+- $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'`; \
++ echo " $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed 's/$$/$(EXEEXT)/'`"; \
++ $(INSTALL_PROGRAM) $$p $(DESTDIR)$(bindir)/`echo $$p|sed 's/$(EXEEXT)$$//'|sed 's/$$/$(EXEEXT)/'`; \
+ else :; fi; \
+ done
+
diff --git a/audio/muse/files/patch-outchannels.cpp b/audio/muse/files/patch-outchannels.cpp
new file mode 100644
index 000000000000..55fd3f4fb561
--- /dev/null
+++ b/audio/muse/files/patch-outchannels.cpp
@@ -0,0 +1,15 @@
+--- outchannels.cpp.orig Fri Jun 7 02:44:42 2002
++++ outchannels.cpp Fri Jun 7 02:44:48 2002
+@@ -20,11 +20,11 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
+-#include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <unistd.h>
diff --git a/audio/muse/pkg-comment b/audio/muse/pkg-comment
new file mode 100644
index 000000000000..128390eaa3ab
--- /dev/null
+++ b/audio/muse/pkg-comment
@@ -0,0 +1 @@
+Multiple Streaming Engine
diff --git a/audio/muse/pkg-descr b/audio/muse/pkg-descr
new file mode 100644
index 000000000000..ae4ab440ce58
--- /dev/null
+++ b/audio/muse/pkg-descr
@@ -0,0 +1,8 @@
+MuSE is an application for the mixing, encoding, and network streaming of
+sound. MuSE can simultaniously mix up to 6 encoded audio bitstreams (from
+files or network) plus a soundcard input signal. The resulting stream can
+be played locally on the sound card and/or encoded as an mp3 bitstream sent
+to a broadcast server. MuSE offers an intuitive interface to be operated
+realtime and can run in "slick" mode from commandline.
+
+WWW: http://muse.dyne.org/
diff --git a/audio/muse/pkg-plist b/audio/muse/pkg-plist
new file mode 100644
index 000000000000..e8180d0fa6cb
--- /dev/null
+++ b/audio/muse/pkg-plist
@@ -0,0 +1,10 @@
+bin/muse
+share/doc/MuSE/AUTHORS
+share/doc/MuSE/COPYING
+share/doc/MuSE/ChangeLog
+share/doc/MuSE/KNOWN-BUGS
+share/doc/MuSE/NEWS
+share/doc/MuSE/README
+share/doc/MuSE/TODO
+share/doc/MuSE/USAGE
+@dirrm share/doc/MuSE