aboutsummaryrefslogtreecommitdiff
path: root/audio/muse
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-07 03:34:42 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-07 03:34:42 +0000
commit14427e99f64c5ce8be7aeee9d02aa243a992f701 (patch)
tree430543784965da71a789c5a40eb72b3fa26c2e61 /audio/muse
parentb4c807a674a233809880acb6b496f6708838a540 (diff)
downloadports-14427e99f64c5ce8be7aeee9d02aa243a992f701.tar.gz
ports-14427e99f64c5ce8be7aeee9d02aa243a992f701.zip
Notes
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/Makefile59
-rw-r--r--audio/muse/distinfo6
-rw-r--r--audio/muse/files/patch-Makefile.in11
-rw-r--r--audio/muse/files/patch-configure58
-rw-r--r--audio/muse/files/patch-src::Makefile.in12
-rw-r--r--audio/muse/files/patch-src::jmixer.cpp22
-rw-r--r--audio/muse/files/patch-src::pipe.cpp125
7 files changed, 108 insertions, 185 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index c6d8dcfa530c..9c8db8098621 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -7,51 +7,62 @@
#
PORTNAME= MuSE
-PORTVERSION= 0.9
-PORTREVISION= 3
+PORTVERSION= 0.9.2
+PORTREVISION= 0
CATEGORIES= audio
MASTER_SITES= ftp://ftp.dyne.org/muse/releases/ \
http://www.ljudmila.org/~jaromil/muse/releases/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= Multiple Streaming Engine
-LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
- vorbis.3:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
+ ogg.5:${PORTSDIR}/audio/libogg
-USE_GETOPT_LONG= yes
+USE_GETOPT_LONG=yes
+USE_GETTEXT= yes
USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --disable-debug --disable-lubrify
-
-MAN1= muse.1
-PORTDOCS= ${DOCSFILES:S,doc/,,g}
-PLIST_FILES= bin/muse
-
+CONFIGURE_ARGS= --disable-debug --disable-lubrify --disable-rpath
CPPFLAGS= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT -DHAVE_SYS_UIO_H \
${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl
-DOCFILES= AUTHORS ChangeLog KNOWN-BUGS NEWS README TODO doc/USAGE
+OPTIONS= X11 "Build with X11 support" on \
+ MP3 "Build with MP3 support" on \
+ SNDFILE "Build with sndfile support" on
+
+.include <bsd.port.pre.mk>
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
-CONFIGURE_ARGS+= --without-x --with-rubik
+CONFIGURE_ARGS+=--without-x --with-rubik
.else
USE_GNOME+= gtk20
.endif
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/muse ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/muse.1 ${MANPREFIX}/man/man1
+.if !defined(WITHOUT_MP3) || exists(${LOCALBASE}/lib/libmp3lame.so.0)
+LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+.endif
+
+.if !defined(WITHOUT_SNDFILE) || exists(${LOCALBASE}/lib/libsndfile.so.1)
+LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+.endif
+
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for file in ${DOCFILES}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+PORTDOCS= *
+.endif
+PLIST_FILES= bin/muse \
+ share/locale/es/LC_MESSAGES/muse.mo \
+ share/locale/it/LC_MESSAGES/muse.mo
+MAN1= muse.1
+
+post-patch:
+.if exists(/usr/include/sys/soundcard.h)
+ ${REINPLACE_CMD} -e "s,machine/soundcard.h,sys/soundcard.h,g" \
+ ${WRKSRC}/src/portaudio/pa_unix_oss.c
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/muse/distinfo b/audio/muse/distinfo
index ba5603f271d7..1f745746f38d 100644
--- a/audio/muse/distinfo
+++ b/audio/muse/distinfo
@@ -1,3 +1,3 @@
-MD5 (MuSE-0.9.tar.gz) = 0c2075c9f62ba1d08459f669498b6bcf
-SHA256 (MuSE-0.9.tar.gz) = 5bb1b12f9bc9d5b6b1671aab2fa00ff0eae06305f5014771b9c1caed9abcca85
-SIZE (MuSE-0.9.tar.gz) = 1363091
+MD5 (MuSE-0.9.2.tar.gz) = 7b3b01a35af79b8852ee6b0f033ff46c
+SHA256 (MuSE-0.9.2.tar.gz) = 270f95b3a4f9d11bea04d5db4b3868aee1fa78177da0b5d9a74f26c4cfa5e197
+SIZE (MuSE-0.9.2.tar.gz) = 1420411
diff --git a/audio/muse/files/patch-Makefile.in b/audio/muse/files/patch-Makefile.in
new file mode 100644
index 000000000000..af9559da02d0
--- /dev/null
+++ b/audio/muse/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Fri Aug 4 12:11:20 2006
++++ Makefile.in Fri Aug 4 12:11:27 2006
+@@ -240,7 +240,7 @@
+ target_vendor = @target_vendor@
+ SUBDIRS = po intl src
+ docs_DATA = README COPYING AUTHORS NEWS KNOWN-BUGS ChangeLog TODO USAGE
+-docsdir = ${prefix}/doc/MuSE
++docsdir = ${prefix}/share/doc/MuSE
+ man_MANS = muse.1
+ ACLOCAL_AMFLAGS = -I . -I m4
+ EXTRA_DIST = autogen.sh config.rpath
diff --git a/audio/muse/files/patch-configure b/audio/muse/files/patch-configure
index 32f2729ded91..d620c9b0a075 100644
--- a/audio/muse/files/patch-configure
+++ b/audio/muse/files/patch-configure
@@ -1,38 +1,58 @@
---- configure.orig Sun Apr 18 00:33:26 2004
-+++ configure Mon Apr 19 22:34:18 2004
-@@ -3427,7 +3427,7 @@
+--- configure.orig Tue Dec 27 16:03:15 2005
++++ configure Fri Aug 4 11:51:41 2006
+@@ -1894,7 +1894,7 @@
+ echo "$as_me:$LINENO: checking for which platform we are compiling" >&5
+ echo $ECHO_N "checking for which platform we are compiling... $ECHO_C" >&6
+ case $uname in
+- Linux)
++ Linux|FreeBSD)
+ echo "$as_me:$LINENO: result: Linux" >&5
+ echo "${ECHO_T}Linux" >&6
+
+@@ -2613,16 +2613,12 @@
+ CFLAGS=$ac_save_CFLAGS
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++ CFLAGS="-g ${CFLAGS}"
+ else
+- CFLAGS="-g"
++ CFLAGS="-g ${CFLAGS}"
+ fi
+ else
+- if test "$GCC" = yes; then
+- CFLAGS="-O2"
+- else
+- CFLAGS=
+- fi
++ CFLAGS="${CFLAGS}"
+ fi
+ echo "$as_me:$LINENO: checking for $CC option to accept ANSI C" >&5
+ echo $ECHO_N "checking for $CC option to accept ANSI C... $ECHO_C" >&6
+@@ -3738,7 +3734,7 @@
#AM_DEFINE_UNQUOTED(HOST_CPU, "${host_cpu}")
#CFLAGS="-O4 -D_REENTRANT -fomit-frame-pointer -march=${host_cpu} -ffast-math -malign-double -funroll-loops -pipe"
-CFLAGS="-pipe -D_REENTRANT"
-+CFLAGS="$CFLAGS -D_REENTRANT"
++#CFLAGS="-pipe -D_REENTRANT"
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
-@@ -11182,7 +11182,7 @@
+@@ -14588,7 +14584,7 @@
else
lrint_save_CFLAGS=$CFLAGS
-CFLAGS="-O2 -lm"
-+CFLAGS="$CFLAGS -lm"
++CFLAGS="${CFLAGS} -lm"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
/* confdefs.h. */
-@@ -11249,7 +11249,7 @@
+ _ACEOF
+@@ -14665,7 +14661,7 @@
else
lrintf_save_CFLAGS=$CFLAGS
-CFLAGS="-O2 -lm"
-+CFLAGS="$CFLAGS -lm"
++CFLAGS="${CFLAGS} -lm"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
/* confdefs.h. */
-@@ -11836,8 +11836,6 @@
- else
- CFLAGS="$CFLAGS -O3 -fomit-frame-pointer -march=${host_cpu} -ffast-math"
- fi
--else
-- CFLAGS="$CFLAGS -O2 -ffast-math"
- fi
-
-
+ _ACEOF
diff --git a/audio/muse/files/patch-src::Makefile.in b/audio/muse/files/patch-src::Makefile.in
index d51c82fb6830..abd4d08a05b1 100644
--- a/audio/muse/files/patch-src::Makefile.in
+++ b/audio/muse/files/patch-src::Makefile.in
@@ -1,10 +1,10 @@
---- src/Makefile.in.orig Sun Apr 18 00:33:24 2004
-+++ src/Makefile.in Mon Apr 19 22:28:56 2004
-@@ -207,7 +207,6 @@
- muse_LDADD = \
- $(top_srcdir)/src/resample/libresample.a \
+--- src/Makefile.in.orig Fri Aug 4 11:43:41 2006
++++ src/Makefile.in Fri Aug 4 11:43:46 2006
+@@ -268,7 +268,6 @@
$(top_srcdir)/src/libmpeg/libmpeg.a \
+ $(top_srcdir)/src/shout/libshout.a \
+ $(top_srcdir)/src/portaudio/libportaudio.a \
- -lpthread \
- @LIBSHOUT_LIB@ \
@M_LIBS@ \
@LAME_LIBS@ \
+ @OGG_LIBS@ \
diff --git a/audio/muse/files/patch-src::jmixer.cpp b/audio/muse/files/patch-src::jmixer.cpp
index 17e95ed2b42d..3a4c6ab41341 100644
--- a/audio/muse/files/patch-src::jmixer.cpp
+++ b/audio/muse/files/patch-src::jmixer.cpp
@@ -1,5 +1,5 @@
---- src/jmixer.cpp.orig Sat Apr 10 02:50:43 2004
-+++ src/jmixer.cpp Mon Apr 19 22:49:59 2004
+--- src/jmixer.cpp.orig Fri Aug 4 11:44:33 2006
++++ src/jmixer.cpp Fri Aug 4 11:46:02 2006
@@ -20,18 +20,18 @@
*/
@@ -17,7 +17,7 @@
-#include <errno.h>
+#include <cerrno>
#include <fcntl.h>
- #include <sys/soundcard.h>
+
-#include <string.h>
-#include <signal.h>
+#include <cstring>
@@ -25,18 +25,12 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <termios.h>
-@@ -624,10 +624,11 @@
- return true;
- }
-
--/* this is the function selecting files for the scandir
-- on freebsd systems you should change the following line to:
-- int selector(struct dirent *dir) { */
-+#if defined(__FreeBSD__)
+@@ -640,7 +640,7 @@
+ /* this is the function selecting files for the scandir
+ on freebsd systems you should change the following line to:
+ int selector(struct dirent *dir) { */
+-int selector(const struct dirent *dir) {
+int selector(struct dirent *dir) {
-+#else
- int selector(const struct dirent *dir) {
-+#endif
if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
#ifdef HAVE_VORBIS
|| strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0
diff --git a/audio/muse/files/patch-src::pipe.cpp b/audio/muse/files/patch-src::pipe.cpp
index f006ea670474..aac653714a64 100644
--- a/audio/muse/files/patch-src::pipe.cpp
+++ b/audio/muse/files/patch-src::pipe.cpp
@@ -1,127 +1,14 @@
---- src/pipe.cpp.orig Mon Dec 8 17:20:33 2003
-+++ src/pipe.cpp Fri Jun 3 16:58:02 2005
-@@ -25,7 +25,8 @@
+--- src/pipe.cpp.orig Sat Dec 24 18:19:31 2005
++++ src/pipe.cpp Fri Aug 4 11:48:06 2006
+@@ -25,9 +25,9 @@
*/
#include <iostream>
-#include <stdlib.h>
+#include <cstdlib>
+ #include <math.h>
+-#include <errno.h>
+#include <cerrno>
+
#include <audioproc.h>
#include <pipe.h>
- #include <jutils.h>
-@@ -118,9 +119,9 @@
- }
- /* --- */
-
-- (char*)start += currentBlockSize;
-+ start = (char*)start + currentBlockSize;
- len -= currentBlockSize;
-- (char*)pp += currentBlockSize;
-+ pp = (float*)pp + currentBlockSize;
- length -= currentBlockSize;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -146,8 +147,8 @@
- }
- /* --- */
-
-- (char*)pp += len;
-- (char*)start += len;
-+ pp = (float*)pp + len;
-+ start = (char*)start + len;
- length -= len;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -224,9 +225,9 @@
- }
- /* --- */
-
-- (char*)start += currentBlockSize;
-+ start = (char*)start + currentBlockSize;
- len -= currentBlockSize;
-- (char*)pp += currentBlockSize;
-+ pp = (float**)pp + currentBlockSize;
- length -= currentBlockSize;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -253,8 +254,8 @@
- }
- /* --- */
-
-- (char*)pp += len;
-- (char*)start += len;
-+ pp = (float**)pp + len;
-+ start = (char*)start + len;
- length -= len;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -309,9 +310,9 @@
- pp[c] += (int32_t) ((IN_DATATYPE*)start)[c];
- /* --- */
-
-- (char*)start += currentBlockSize;
-+ start = (char*)start + currentBlockSize;
- len -= currentBlockSize;
-- (char*)pp += currentBlockSize;
-+ pp = (int32_t*)pp + currentBlockSize;
- length -= currentBlockSize;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -324,8 +325,8 @@
- pp[c] += (int) ((IN_DATATYPE*)start)[c];
- /* --- */
-
-- (char*)pp += len;
-- (char*)start += len;
-+ pp = (int32_t*)pp + len;
-+ start = (char*)start + len;
- length -= len;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -372,17 +373,17 @@
- /* fill */
- memcpy(data, start, currentBlockSize);
-
-- (char*)start += currentBlockSize;
-+ start = (char*)start + currentBlockSize;
- len -= currentBlockSize;
-- (char*)data += currentBlockSize;
-+ data = (char*)data + currentBlockSize;
- length -= currentBlockSize;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-
- if (len) { /* short circuit */
- memcpy(data, start, len);
-- (char*)data += len;
-- (char*)start += len;
-+ data = (char*)data + len;
-+ start = (char*)start + len;
- length -= len;
- if ((end!=buffer) && (start==bufferEnd))
- start = buffer;
-@@ -418,19 +419,19 @@
- currentBlockSize=MIN(currentBlockSize, len);
- ::memcpy(end, data, currentBlockSize);
-
-- (char*)end += currentBlockSize;
-+ end = (char*)end + currentBlockSize;
-
- len -= currentBlockSize;
-
-- (char*)data += currentBlockSize;
-+ data = (char*)data + currentBlockSize;
- length -= currentBlockSize;
- if ((start!=buffer) && (end==bufferEnd))
- end = buffer;
-
- if (len) { // short circuit
- ::memcpy(end, data, len);
-- (char*)data += len;
-- (char*)end += len;
-+ data = (char*)data + len;
-+ end = (char*)end + len;
- length -= len;
-
- if ((start!=buffer) && (end==bufferEnd))