aboutsummaryrefslogtreecommitdiff
path: root/audio/muse
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-04-11 06:45:51 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-04-11 06:45:51 +0000
commit5ac7ca806839a0b4fb8bd1e3fc548cafb2202b5b (patch)
treeb6fb42992318bb648bd00c7b01a906d50a8d9c09 /audio/muse
parent6b4999bf8f4e0bc4a78166c29a3e69ca102fb105 (diff)
downloadports-5ac7ca806839a0b4fb8bd1e3fc548cafb2202b5b.tar.gz
ports-5ac7ca806839a0b4fb8bd1e3fc548cafb2202b5b.zip
Notes
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/Makefile4
-rw-r--r--audio/muse/files/patch-src::jmixer.cpp9
2 files changed, 0 insertions, 13 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index dcc629b6e566..915a6afa30d3 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -35,10 +35,6 @@ OPTIONS= X11 "Build with X11 support" on \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800501
-BROKEN= does not build
-.endif
-
.if defined(WITHOUT_X11)
PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+=--without-x --with-rubik
diff --git a/audio/muse/files/patch-src::jmixer.cpp b/audio/muse/files/patch-src::jmixer.cpp
index 3a4c6ab41341..bd8ef1fd8ff0 100644
--- a/audio/muse/files/patch-src::jmixer.cpp
+++ b/audio/muse/files/patch-src::jmixer.cpp
@@ -25,12 +25,3 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <termios.h>
-@@ -640,7 +640,7 @@
- /* this is the function selecting files for the scandir
- on freebsd systems you should change the following line to:
- int selector(struct dirent *dir) { */
--int selector(const struct dirent *dir) {
-+int selector(struct dirent *dir) {
- if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
- #ifdef HAVE_VORBIS
- || strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0