aboutsummaryrefslogtreecommitdiff
path: root/audio/muse
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-08 10:22:14 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-08 10:22:14 +0000
commit31154892b641cd15adf68371929358d08862d264 (patch)
tree04c60b5eee34ac32bb4e64c7f467d3bf71838892 /audio/muse
parent9b646e86c33d57c3d495a4a0218969df75dcbd63 (diff)
downloadports-31154892b641cd15adf68371929358d08862d264.tar.gz
ports-31154892b641cd15adf68371929358d08862d264.zip
Notes
Diffstat (limited to 'audio/muse')
-rw-r--r--audio/muse/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/audio/muse/Makefile b/audio/muse/Makefile
index feebca38d557..e16ee6a1a00a 100644
--- a/audio/muse/Makefile
+++ b/audio/muse/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
vorbis.1:${PORTSDIR}/audio/libvorbis \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+USE_REINPLACE= yes
USE_GTK= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -29,11 +30,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ARGS= --disable-debug
post-patch:
- @${PERL} -pi -e 's|-O3|\$$CFLAGS|g ; \
+ @${REINPLACE_CMD} -e 's|-O3|\$$CFLAGS|g ; \
s|\$$GTK_LIBS -lgthread|\$$GTK_LIBS \$$GLIB_LIBS|g ; \
s|\$$GTK_FLAGS|\$$GTK_CFLAGS \$$GLIB_CFLAGS|g' \
${WRKSRC}/configure
- @${PERL} -pi -e 's|-lpthread||g' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lpthread||g' ${WRKSRC}/Makefile.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/muse ${PREFIX}/bin