aboutsummaryrefslogtreecommitdiff
path: root/audio/musescore
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2019-02-11 11:23:46 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2019-02-11 11:23:46 +0000
commit1128c264561a16a5a47b8c3788d5f5965a8470c9 (patch)
tree0eaaf3da81a866202e06c26cc6e356dc44fd6f06 /audio/musescore
parentdbc248bb75fb058663d4235c7145684ff1d3e4a4 (diff)
downloadports-1128c264561a16a5a47b8c3788d5f5965a8470c9.tar.gz
ports-1128c264561a16a5a47b8c3788d5f5965a8470c9.zip
Notes
Diffstat (limited to 'audio/musescore')
-rw-r--r--audio/musescore/Makefile12
-rw-r--r--audio/musescore/distinfo6
-rw-r--r--audio/musescore/files/patch-git_bb0c1a9b155
-rw-r--r--audio/musescore/pkg-plist4
4 files changed, 165 insertions, 12 deletions
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
index 4c79f6ffbdbe..f3dcca3bc64c 100644
--- a/audio/musescore/Makefile
+++ b/audio/musescore/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= musescore
-DISTVERSION= 3.0.0
-PORTREVISION= 2
+DISTVERSION= 3.0.2
CATEGORIES= audio
MASTER_SITES= http://ftp.osuosl.org/pub/musescore/releases/MuseScore-${DISTVERSION}/
DISTNAME= MuseScore-${DISTVERSION}
@@ -15,9 +14,6 @@ COMMENT= Free music composition & notation software
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
-# Because of webengine
-ONLY_FOR_ARCHS= i386 amd64
-
LIB_DEPENDS= libmp3lame.so:audio/lame \
libsndfile.so:audio/libsndfile \
libvorbis.so:audio/libvorbis \
@@ -38,12 +34,13 @@ CMAKE_ARGS+= -DUSE_SYSTEM_FREETYPE="ON" \
DATADIR= ${PREFIX}/share/mscore-${PORTVERSION:R}
-OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO OCR WEBENGINE
+# WebEngine is only available on i386/amd64; defaults to ON there.
+# If enabled on arches that don't have WebEngine, the build breaks.
+OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO WEBENGINE
OPTIONS_DEFAULT= PORTAUDIO
OPTIONS_DEFAULT_amd64= WEBENGINE
OPTIONS_DEFAULT_i386= WEBENGINE
-OCR_DESC= Optical Character Recognition
WEBENGINE_DESC= Use WebEngine in the welcome panel
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
@@ -54,7 +51,6 @@ PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio
PORTAUDIO_CMAKE_BOOL= BUILD_PORTAUDIO
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CMAKE_BOOL= BUILD_PULSEAUDIO
-OCR_CMAKE_BOOL= OCR
WEBENGINE_USE= qt=webengine
WEBENGINE_CMAKE_BOOL= BUILD_WEBENGINE
diff --git a/audio/musescore/distinfo b/audio/musescore/distinfo
index 17a8f1587a95..6401f2219746 100644
--- a/audio/musescore/distinfo
+++ b/audio/musescore/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1547127510
-SHA256 (MuseScore-3.0.0.zip) = 8a764a1f8911502cb9887c84cde4a8dda193a766337b8e477e89185cbf3722c6
-SIZE (MuseScore-3.0.0.zip) = 116183004
+TIMESTAMP = 1549439898
+SHA256 (MuseScore-3.0.2.zip) = 620ba2a56d80528c6654f4f59dcfe968b5667ac49fecfd63742ceb92aad5e0b1
+SIZE (MuseScore-3.0.2.zip) = 116531283
diff --git a/audio/musescore/files/patch-git_bb0c1a9b b/audio/musescore/files/patch-git_bb0c1a9b
new file mode 100644
index 000000000000..9a80a34a96a6
--- /dev/null
+++ b/audio/musescore/files/patch-git_bb0c1a9b
@@ -0,0 +1,155 @@
+Upstream commit to fix non-WebEngine builds.
+
+https://github.com/musescore/MuseScore/commit/bb0c1a9b4940f3f6b52c0df535289ec8a3bc9e03
+
+diff --git a/mscore/logindialog.h b/mscore/logindialog.h
+index 4e86ae7985..f44511d8c0 100644
+--- mscore/logindialog.h
++++ mscore/logindialog.h
+@@ -21,6 +21,8 @@ class LoginManager;
+
+ //---------------------------------------------------------
+ // LoginDialog
++// Old-style login dialog in case QtWebEngine is
++// unavailable.
+ //---------------------------------------------------------
+
+ class LoginDialog : public QDialog, public Ui::LoginDialog
+diff --git a/mscore/musescore.cpp b/mscore/musescore.cpp
+index 80c712aea9..5bb8354992 100644
+--- mscore/musescore.cpp
++++ mscore/musescore.cpp
+@@ -7572,12 +7572,14 @@ bool MuseScore::exportPartsPdfsToJSON(const QString& inFilePath, const QString&
+ }
+
+ //---------------------------------------------------------
+-// getQmlEngine
++// getPluginEngine
+ //---------------------------------------------------------
+
++#ifdef SCRIPT_INTERFACE
+ QmlPluginEngine* MuseScore::getPluginEngine()
+ {
+ if (!_qmlEngine)
+ _qmlEngine = new QmlPluginEngine(this);
+ return _qmlEngine;
+ }
++#endif
+diff --git a/mscore/network/loginmanager.cpp b/mscore/network/loginmanager.cpp
+index a53d7fe811..664786ccc8 100644
+--- mscore/network/loginmanager.cpp
++++ mscore/network/loginmanager.cpp
+@@ -18,7 +18,9 @@
+ #include "kQOAuth/kqoauthrequest.h"
+ #include "kQOAuth/kqoauthrequest_xauth.h"
+
++#ifdef USE_WEBENGINE
+ #include <QWebEngineCookieStore>
++#endif
+
+ namespace Ms {
+
+@@ -286,8 +288,11 @@ void LoginManager::onTryLoginError(const QString& error)
+ disconnect(this, SIGNAL(getUserError(QString)), this, SLOT(onTryLoginError(QString)));
+ connect(this, SIGNAL(loginSuccess()), this, SLOT(tryLogin()));
+ logout();
++#ifdef USE_WEBENGINE
+ loginInteractive();
+-// mscore->showLoginDialog(); // TODO: switch depending on USE_WEBENGINE
++#else
++ mscore->showLoginDialog();
++#endif
+ }
+ /*------- END - TRY LOGIN ROUTINES ----------------------------*/
+
+@@ -295,6 +300,7 @@ void LoginManager::onTryLoginError(const QString& error)
+ // loginInteractive
+ //---------------------------------------------------------
+
++#ifdef USE_WEBENGINE
+ void LoginManager::loginInteractive()
+ {
+ QWebEngineView* webView = new QWebEngineView;
+@@ -326,6 +332,7 @@ void LoginManager::loginInteractive()
+ webView->load(ApiInfo::loginUrl);
+ webView->show();
+ }
++#endif
+
+ //---------------------------------------------------------
+ // login
+@@ -346,7 +353,7 @@ void LoginManager::login(QString login, QString password)
+ connect(reply, &QNetworkReply::finished, this, [this, reply] {
+ onReplyFinished(reply, RequestType::LOGIN);
+ });
+- }
++ }
+
+ //---------------------------------------------------------
+ // onLoginSuccessReply
+@@ -874,6 +881,7 @@ ApiRequest ApiRequestBuilder::build() const
+ // musescore.com
+ //---------------------------------------------------------
+
++#ifdef USE_WEBENGINE
+ void ApiWebEngineRequestInterceptor::interceptRequest(QWebEngineUrlRequestInfo& request)
+ {
+ const ApiInfo& apiInfo = ApiInfo::instance();
+@@ -881,4 +889,5 @@ void ApiWebEngineRequestInterceptor::interceptRequest(QWebEngineUrlRequestInfo&
+ request.setHttpHeader(apiInfo.clientIdHeader, apiInfo.clientId);
+ request.setHttpHeader(apiInfo.apiKeyHeader, apiInfo.apiKey);
+ }
++#endif
+ }
+diff --git a/mscore/network/loginmanager.h b/mscore/network/loginmanager.h
+index 584eeea30d..327d9fc966 100644
+--- mscore/network/loginmanager.h
++++ mscore/network/loginmanager.h
+@@ -13,6 +13,8 @@
+ #ifndef __LOGINMANAGER_H__
+ #define __LOGINMANAGER_H__
+
++#include "config.h"
++
+ namespace Ms {
+
+ //---------------------------------------------------------
+@@ -83,7 +85,9 @@ class LoginManager : public QObject
+ public:
+ LoginManager(QAction* uploadAudioMenuAction, QObject* parent = 0);
+ void login(QString login, QString password);
++#ifdef USE_WEBENGINE
+ void loginInteractive();
++#endif
+ void upload(const QString& path, int nid, const QString& title, const QString& description, const QString& priv, const QString& license, const QString& tags, const QString& changes);
+ bool hasAccessToken();
+ void getUser();
+diff --git a/mscore/network/loginmanager_p.h b/mscore/network/loginmanager_p.h
+index 88228a3958..2848dde35a 100644
+--- mscore/network/loginmanager_p.h
++++ mscore/network/loginmanager_p.h
+@@ -20,6 +20,8 @@
+ #ifndef __LOGINMANAGER_P_H__
+ #define __LOGINMANAGER_P_H__
+
++#include "config.h"
++
+ namespace Ms {
+
+ //---------------------------------------------------------
+@@ -102,6 +104,7 @@ class ApiRequestBuilder
+ // ApiWebEngineRequestInterceptor
+ //---------------------------------------------------------
+
++#ifdef USE_WEBENGINE
+ class ApiWebEngineRequestInterceptor : public QWebEngineUrlRequestInterceptor
+ {
+ Q_OBJECT
+@@ -109,6 +112,7 @@ class ApiWebEngineRequestInterceptor : public QWebEngineUrlRequestInterceptor
+ ApiWebEngineRequestInterceptor(QObject* parent) : QWebEngineUrlRequestInterceptor(parent) {}
+ void interceptRequest(QWebEngineUrlRequestInfo& info) override;
+ };
++#endif
+
+ //---------------------------------------------------------
+ // HttpStatus
diff --git a/audio/musescore/pkg-plist b/audio/musescore/pkg-plist
index 9c13e33cdd60..34c32c7b03d5 100644
--- a/audio/musescore/pkg-plist
+++ b/audio/musescore/pkg-plist
@@ -62,6 +62,7 @@ share/mime/packages/musescore.xml
%%DATADIR%%/locale/instruments_eu.qm
%%DATADIR%%/locale/instruments_fa.qm
%%DATADIR%%/locale/instruments_fi.qm
+%%DATADIR%%/locale/instruments_fil.qm
%%DATADIR%%/locale/instruments_fo.qm
%%DATADIR%%/locale/instruments_fr.qm
%%DATADIR%%/locale/instruments_ga.qm
@@ -127,6 +128,7 @@ share/mime/packages/musescore.xml
%%DATADIR%%/locale/mscore_eu.qm
%%DATADIR%%/locale/mscore_fa.qm
%%DATADIR%%/locale/mscore_fi.qm
+%%DATADIR%%/locale/mscore_fil.qm
%%DATADIR%%/locale/mscore_fo.qm
%%DATADIR%%/locale/mscore_fr.qm
%%DATADIR%%/locale/mscore_ga.qm
@@ -192,6 +194,7 @@ share/mime/packages/musescore.xml
%%DATADIR%%/locale/tours_eu.qm
%%DATADIR%%/locale/tours_fa.qm
%%DATADIR%%/locale/tours_fi.qm
+%%DATADIR%%/locale/tours_fil.qm
%%DATADIR%%/locale/tours_fo.qm
%%DATADIR%%/locale/tours_ga.qm
%%DATADIR%%/locale/tours_gd.qm
@@ -251,7 +254,6 @@ share/mime/packages/musescore.xml
%%DATADIR%%/manual/plugins/connectorinfo.html
%%DATADIR%%/manual/plugins/connectorinforeader.html
%%DATADIR%%/manual/plugins/connectorinfowriter.html
-%%DATADIR%%/manual/plugins/cursor.html
%%DATADIR%%/manual/plugins/durationelement.html
%%DATADIR%%/manual/plugins/dynamic.html
%%DATADIR%%/manual/plugins/element.html