aboutsummaryrefslogtreecommitdiff
path: root/audio/musiccontrol
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-06-10 14:57:12 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-06-10 14:57:12 +0000
commit14c7b7f835e3449f4e01f83b79e640e9dfe84107 (patch)
tree388a2425038a63f4b97c0bdb8620e3ca3a49ad6a /audio/musiccontrol
parent1cf930b9cc211aa20984abf7e5ded57d9b05f113 (diff)
Add musiccontrol
MusicControl is designed to put YOU in control of the music that gets played from your computer. It supports MP3, OGG and various module formats. Submitted by: Christian Laursen <xi@borderworlds.dk>
Notes
Notes: svn path=/head/; revision=82686
Diffstat (limited to 'audio/musiccontrol')
-rw-r--r--audio/musiccontrol/Makefile32
-rw-r--r--audio/musiccontrol/distinfo1
-rw-r--r--audio/musiccontrol/files/musiccontrol3
-rw-r--r--audio/musiccontrol/pkg-descr9
-rw-r--r--audio/musiccontrol/pkg-plist2
5 files changed, 47 insertions, 0 deletions
diff --git a/audio/musiccontrol/Makefile b/audio/musiccontrol/Makefile
new file mode 100644
index 000000000000..109b62d60231
--- /dev/null
+++ b/audio/musiccontrol/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: musiccontrol
+# Date created: 9 june 2003
+# Whom: Christian Laursen <xi@borderworlds.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= musiccontrol
+PORTVERSION= 0.1
+CATEGORIES= audio java
+MASTER_SITES= http://borderworlds.dk/projects/mc/
+DISTNAME= MusicControl-0.1
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= xi@borderworlds.dk
+COMMENT= An advanced music player
+
+RUN_DEPENDS= ${LOCALBASE}/bin/mpg123:${PORTSDIR}/audio/mpg123 \
+ ${LOCALBASE}/bin/ogg123:${PORTSDIR}/audio/vorbis-tools \
+ ${LOCALBASE}/bin/simplemod:${PORTSDIR}/audio/simplemod
+
+USE_JAVA= 1.3+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/java/classes
+ ${INSTALL} -o 0 -g 0 -m 0644 ${DISTDIR}/MusicControl-${PORTVERSION}.jar ${PREFIX}/share/java/classes
+ ${SED} 's,%%PREFIX%%,${PREFIX},g' ${FILESDIR}/musiccontrol > ${WRKDIR}/musiccontrol
+ ${INSTALL} -o 0 -g 0 ${WRKDIR}/musiccontrol ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/audio/musiccontrol/distinfo b/audio/musiccontrol/distinfo
new file mode 100644
index 000000000000..8e86a0080c51
--- /dev/null
+++ b/audio/musiccontrol/distinfo
@@ -0,0 +1 @@
+MD5 (MusicControl-0.1.jar) = 2a95fd37235a4f16327a3cfa5ce8df60
diff --git a/audio/musiccontrol/files/musiccontrol b/audio/musiccontrol/files/musiccontrol
new file mode 100644
index 000000000000..c489fa75d782
--- /dev/null
+++ b/audio/musiccontrol/files/musiccontrol
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+%%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/classes/MusicControl-0.1.jar $*
diff --git a/audio/musiccontrol/pkg-descr b/audio/musiccontrol/pkg-descr
new file mode 100644
index 000000000000..e2d6a82d6e8c
--- /dev/null
+++ b/audio/musiccontrol/pkg-descr
@@ -0,0 +1,9 @@
+MusicControl is designed to put YOU in control of the music that gets played
+from your computer.
+
+It supports MP3, OGG and various module formats.
+
+WWW: http://borderworlds.dk/projects/#mc
+
+- Christian
+xi@borderworlds.dk
diff --git a/audio/musiccontrol/pkg-plist b/audio/musiccontrol/pkg-plist
new file mode 100644
index 000000000000..95190d8745a5
--- /dev/null
+++ b/audio/musiccontrol/pkg-plist
@@ -0,0 +1,2 @@
+share/java/classes/MusicControl-0.1.jar
+bin/musiccontrol