aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-27 18:52:22 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-27 18:52:22 +0000
commit118efc65cd2e3bab0a2461279039cd394e3e2e0f (patch)
tree4f6f84ac8d2a8475ec5e750f9b2623a5052f777f /audio/musicpc
parent746617409c17622533687c109036a3ecb0355a78 (diff)
downloadports-118efc65cd2e3bab0a2461279039cd394e3e2e0f.tar.gz
ports-118efc65cd2e3bab0a2461279039cd394e3e2e0f.zip
Notes
Diffstat (limited to 'audio/musicpc')
-rw-r--r--audio/musicpc/Makefile37
-rw-r--r--audio/musicpc/distinfo6
-rw-r--r--audio/musicpc/files/patch-doc_meson.build43
-rw-r--r--audio/musicpc/files/patch-meson.build24
-rw-r--r--audio/musicpc/files/patch-meson__options.txt14
5 files changed, 98 insertions, 26 deletions
diff --git a/audio/musicpc/Makefile b/audio/musicpc/Makefile
index 8bb39f60423c..80466b873729 100644
--- a/audio/musicpc/Makefile
+++ b/audio/musicpc/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= musicpc
-PORTVERSION= 0.28
-PORTREVISION= 1
+DISTVERSION= 0.29
CATEGORIES= audio ipv6
MASTER_SITES= http://www.musicpd.org/download/mpc/0/
DISTNAME= mpc-${PORTVERSION}
@@ -16,32 +15,24 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libmpdclient.so:audio/libmpdclient
-USES= pkgconfig tar:xz
-GNU_CONFIGURE= yes
+USES= meson pkgconfig python tar:xz
+MESON_ARGS+= --mandir=${MANPREFIX}
-PLIST_FILES= bin/mpc man/man1/mpc.1.gz
+PLIST_FILES= bin/mpc
-PORTDOCS= AUTHORS README NEWS
-PORTEXAMPLES= *
+OPTIONS_DEFINE= DOCS EXAMPLES MANPAGES ICONV
+OPTIONS_DEFAULT= MANPAGES ICONV
-OPTIONS_DEFINE= EXAMPLES DOCS ICONV
-OPTIONS_DEFAULT= ICONV
+MANPAGES_USES= python
+MANPAGES_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
+MANPAGES_MESON_TRUE= use_sphinx
+MANPAGES_PLIST_FILES= man/man1/mpc.1.gz
ICONV_USES= iconv
-ICONV_LDFLAGS= -L${LOCALBASE}/lib ${ICONV_LIB}
-ICONV_CONFIGURE_ENABLE= iconv
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/mpc ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/mpc.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ICONV_LDFLAGS= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
+ICONV_MESON_TRUE= iconv
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
-do-install-EXAMPLES-on:
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/mpc-completion.bash \
- ${STAGEDIR}${EXAMPLESDIR}
+PORTDOCS= AUTHORS README.rst NEWS
+PORTEXAMPLES= *
.include <bsd.port.mk>
diff --git a/audio/musicpc/distinfo b/audio/musicpc/distinfo
index dfe415b8932a..1b74d7884c60 100644
--- a/audio/musicpc/distinfo
+++ b/audio/musicpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1471583230
-SHA256 (mpc-0.28.tar.xz) = a4337d06c85dc81a638821d30fce8a137a58d13d510be34a11c1cce95cabc547
-SIZE (mpc-0.28.tar.xz) = 109172
+TIMESTAMP = 1519656312
+SHA256 (mpc-0.29.tar.xz) = 02f1daec902cb48f8cdaa6fe21c7219f6231b091dddbe437a3a4fb12cb07b9d3
+SIZE (mpc-0.29.tar.xz) = 41872
diff --git a/audio/musicpc/files/patch-doc_meson.build b/audio/musicpc/files/patch-doc_meson.build
new file mode 100644
index 000000000000..021d62f230c0
--- /dev/null
+++ b/audio/musicpc/files/patch-doc_meson.build
@@ -0,0 +1,43 @@
+--- doc/meson.build.orig 2018-02-11 12:01:23 UTC
++++ doc/meson.build
+@@ -1,23 +1,27 @@
+-sphinx = find_program('sphinx-build', required:false)
+
+-if sphinx.found()
+- custom_target(
+- 'HTML documentation',
+- output: 'html',
+- input: ['index.rst', 'conf.py'],
+- command: [sphinx, '-q', '-b', 'html', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@'],
+- build_by_default: true,
+- install: true,
+- install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name()),
+- )
++use_sphinx = get_option('use_sphinx')
++
++if use_sphinx == 'false'
++ use_sphinx = false
++elif use_sphinx == 'true'
++ sphinx = find_program('sphinx-build', required:false)
++ if not sphinx.found()
++ error('can\'t find sphinx')
++ endif
++ use_sphinx = true
++else
++ sphinx = find_program('sphinx-build', required:false)
++ use_sphinx = sphinx.found()
++endif
+
++if use_sphinx
+ custom_target(
+ 'Manpage documentation',
+ output: 'man',
+ input: ['index.rst', 'conf.py'],
+- command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@'],
++ command: [sphinx, '-q', '-b', 'man', '-d', '@OUTDIR@/doctrees', meson.current_source_dir(), '@OUTPUT@/man1'],
+ build_by_default: true,
+ install: true,
+- install_dir: join_paths(get_option('datadir'), 'man', 'man1'),
++ install_dir: join_paths(get_option('mandir')),
+ )
+ endif
diff --git a/audio/musicpc/files/patch-meson.build b/audio/musicpc/files/patch-meson.build
new file mode 100644
index 000000000000..aa5908356968
--- /dev/null
+++ b/audio/musicpc/files/patch-meson.build
@@ -0,0 +1,24 @@
+--- meson.build.orig 2018-02-26 15:35:16 UTC
++++ meson.build
+@@ -1,4 +1,4 @@
+-project('mpc', 'c',
++project('musicpc', 'c',
+ version: '0.29',
+ default_options: [
+ 'c_std=c99',
+@@ -113,13 +113,13 @@ executable('mpc',
+ install: true
+ )
+
+-install_data('AUTHORS', 'COPYING', 'NEWS', 'README.rst',
++install_data('AUTHORS', 'NEWS', 'README.rst',
+ install_dir : join_paths(get_option('datadir'), 'doc', meson.project_name()))
+
+ install_data(
+ 'contrib/mpd-m3u-handler.sh', 'contrib/mpd-pls-handler.sh',
+ 'contrib/mpc-completion.bash',
+- install_dir: join_paths(get_option('datadir'), 'doc', meson.project_name(), 'contrib'))
++ install_dir: join_paths(get_option('datadir'), 'examples', meson.project_name() ))
+
+ if get_option('test')
+ check_dep = dependency('check')
diff --git a/audio/musicpc/files/patch-meson__options.txt b/audio/musicpc/files/patch-meson__options.txt
new file mode 100644
index 000000000000..3c7fa5076539
--- /dev/null
+++ b/audio/musicpc/files/patch-meson__options.txt
@@ -0,0 +1,14 @@
+--- meson_options.txt.orig 2018-02-27 07:50:47 UTC
++++ meson_options.txt
+@@ -3,6 +3,11 @@ option('iconv', type: 'combo',
+ value: 'auto',
+ description: 'Enable iconv() support')
+
++option('use_sphinx', type: 'combo',
++ choices: ['true', 'false', 'auto'],
++ value: 'auto',
++ description: 'Enable sphinx support for building documentation')
++
+ option('test', type: 'boolean',
+ value: false,
+ description: 'Enable unit tests')