aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2015-07-03 18:05:41 +0000
committerChris Rees <crees@FreeBSD.org>2015-07-03 18:05:41 +0000
commit42cb389661d1f9aa7f9d03117b307be398ddcca5 (patch)
treef564466e586717ad0cd6b66a91444288c1020e50 /audio/musicpd/Makefile
parentb5874857559c18316969f344146dd0941aa65ec1 (diff)
Notes
Diffstat (limited to 'audio/musicpd/Makefile')
-rw-r--r--audio/musicpd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 54d1c8f69085..f2b6d560c7e8 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -38,12 +38,13 @@ OPTIONS_MULTI_FILE_FORMAT= AAC ADPLUG FFMPEG FLAC FLUIDSYNTH \
VORBIS WAV WAVPACK WILDMIDI
OPTIONS_GROUP= PLAYBACK
-OPTIONS_GROUP_PLAYBACK= AO CURL HTTPD JACK OPENAL OSS PULSEAUDIO SHOUTCAST
+OPTIONS_GROUP_PLAYBACK= AO CURL HTTPD JACK OPENAL OSS PIPE PULSEAUDIO SHOUTCAST
ADPLUG_DESC= AdPlug support
FLUIDSYNTH_DESC=FludSynth support (MIDI files)
GME_DESC= GME support (video game music files)
LAME_DESC= Support for MP3 Icecast Streams
+PIPE_DESC= Support for writing PCM audio to a pipe
SIDPLAY2_DESC= Sidplay support (C64 mono and stereo files)
TREMOR_DESC= Tremor decoder (not with SHOUTCAST; use VORBIS)
TWOLAME_DESC= TwoLAME support (mp2)
@@ -97,6 +98,7 @@ OPENAL_LIB_DEPENDS=libopenal.so:${PORTSDIR}/audio/openal
OPUS_CONFIGURE_ENABLE=opus
OPUS_LIB_DEPENDS=libopus.so:${PORTSDIR}/audio/opus
OSS_CONFIGURE_ENABLE=oss
+PIPE_CONFIGURE_ENABLE=pipe-output
PULSEAUDIO_CONFIGURE_ENABLE=pulse
PULSEAUDIO_LIB_DEPENDS=libpulse.so:${PORTSDIR}/audio/pulseaudio
SAMPLERATE_CONFIGURE_ENABLE=lsr