aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd/Makefile
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-08-09 12:21:41 +0000
committerChris Rees <crees@FreeBSD.org>2013-08-09 12:21:41 +0000
commit0ec3c755891e2d0fc1465c24e4d4f3b2d59a9cac (patch)
tree45ac287d65f9bb3cf13ac9d10220cd33c780d5dd /audio/musicpd/Makefile
parenta0a7af1b5ef0b885fa3fe147adb90a84bb940192 (diff)
downloadports-0ec3c755891e2d0fc1465c24e4d4f3b2d59a9cac.tar.gz
ports-0ec3c755891e2d0fc1465c24e4d4f3b2d59a9cac.zip
Improve TREMOR description to make it explicit that it may not be used with
SHOUTCAST PR: ports/180412
Notes
Notes: svn path=/head/; revision=324431
Diffstat (limited to 'audio/musicpd/Makefile')
-rw-r--r--audio/musicpd/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 716b815a4c47..19f3f7aedc45 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= SF/${PORTNAME}/mpd/${PORTVERSION}
DISTNAME= mpd-${PORTVERSION}
MAINTAINER= crees@FreeBSD.org
-COMMENT= A remote-controllable music daemon
+COMMENT= Remote-controllable music daemon
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad \
curl:${PORTSDIR}/ftp/curl
@@ -41,6 +41,8 @@ OPTIONS_DEFINE= ID3TAG IPV6 FLAC VORBIS WAV FFMPEG TREMOR AAC \
OPTIONS_RADIO= ZEROCONF
OPTIONS_RADIO_ZEROCONF= AVAHI MDNSRESPONDER
+TREMOR_DESC= Tremor decoder (not with SHOUTCAST; use VORBIS)
+
OPTIONS_DEFAULT=ID3TAG IPV6 FLAC VORBIS WAV FFMPEG SNDFILE
LAME_DESC= Support for MP3 Icecast Streams
@@ -171,7 +173,9 @@ LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
CONFIGURE_ARGS+=--disable-id3
.endif
-.if empty(PORT_OPTIONS:MIPV6)
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+=--enable-ipv6
+.else
CONFIGURE_ARGS+=--disable-ipv6
.endif