aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 10:05:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 10:05:32 +0000
commite42c627abd370aa272fe5ed8ae83260d2352abe5 (patch)
treeed3d326f216bca91fe5ece1f95b95f8af7b69e37 /audio/musicpd/Makefile
parentbb92c2de7393c3ab4f0a1adb6dfd43b8005fd2b3 (diff)
downloadports-e42c627abd370aa272fe5ed8ae83260d2352abe5.tar.gz
ports-e42c627abd370aa272fe5ed8ae83260d2352abe5.zip
Notes
Diffstat (limited to 'audio/musicpd/Makefile')
-rw-r--r--audio/musicpd/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index ea73372d08e0..df40bf224787 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= musicpd
PORTVERSION= 0.13.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio ipv6
MASTER_SITES= http://musicpd.org/uploads/files/ \
http://redundancy.redundancy.org/mirror/
@@ -34,10 +34,10 @@ OPTIONS= FLAC "Support for FLAC Audio" on \
ID3TAG "Support for id3v1 tag encoding" off \
IPV6 "Support for IPV6" on \
AO "Support for libao" off \
- PULSE "Support for PulseAudio" off
+ PULSE "Support for PulseAudio" off \
+ SHOUT "Support for Icecast and Shoutcast" on
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --disable-shout
.include <bsd.port.pre.mk>
@@ -104,6 +104,10 @@ CONFIGURE_ARGS+=--disable-pulse
LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
.endif
+.ifdef(WITHOUT_SHOUT)
+CONFIGURE_ARGS+=--disable-shout
+.endif
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"