aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-07-17 19:35:48 +0000
committerChris Rees <crees@FreeBSD.org>2011-07-17 19:35:48 +0000
commitb2db9733bcc97d9effd5cbf265e9e29040b5212d (patch)
tree380a797bfad5995311e90120b5e47ea9fd94f023 /audio/musicpd
parent372fb6002910bf86bb34bbaaf196d9fd52ef1667 (diff)
downloadports-b2db9733bcc97d9effd5cbf265e9e29040b5212d.tar.gz
ports-b2db9733bcc97d9effd5cbf265e9e29040b5212d.zip
Notes
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 46c04ad5bc3f..e3d11281df53 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= musicpd
PORTVERSION= 0.16.3
+PORTREVISION= 1
CATEGORIES= audio ipv6
MASTER_SITES= SF/${PORTNAME}/mpd/${PORTVERSION}
DISTNAME= mpd-${PORTVERSION}
@@ -57,6 +58,7 @@ OPTIONS= ID3TAG "Support ID3 v1/v2 tags" on \
PULSEAUDIO "Support PulseAudio sound server" off \
JACK "Support JACK audio server" off \
SHOUTCAST "Support for OGG Icecast and Shoutcast" off \
+ SNDFILE "Adds support for libsndfile" on \
LAME "Support for MP3 Icecast Streams" off \
HTTPD "Support for httpd output streaming" off \
SAMPLERATE "Support sample rate conversion" off
@@ -223,6 +225,13 @@ CONFIGURE_ARGS+=--enable-vorbis-encoder \
CONFIGURE_ARGS+=--disable-shout
.endif
+.if defined(WITH_SNDFILE)
+LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+CONFIGURE_ARGS+= --enable-sndfile
+.else
+CONFIGURE_ARGS+= --disable-sndfile
+.endif
+
.if defined(WITHOUT_SAMPLERATE)
CONFIGURE_ARGS+=--disable-lsr
.else