aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 13:16:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 13:16:39 +0000
commitbc46c79e9471ec9fa8bfb86248a2e8750bb0f891 (patch)
treec495b47447a54dae44c09523702d4239c9473e6f /audio/musicpd
parent7c4f49a42b6b00e63a2a75dd838e0f39c754e132 (diff)
downloadports-bc46c79e9471ec9fa8bfb86248a2e8750bb0f891.tar.gz
ports-bc46c79e9471ec9fa8bfb86248a2e8750bb0f891.zip
Notes
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile54
-rw-r--r--audio/musicpd/files/pkg-message.in (renamed from audio/musicpd/pkg-message)2
2 files changed, 34 insertions, 22 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 5101c923243e..4f212fde3be0 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= musicpd
PORTVERSION= 0.13.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio ipv6
MASTER_SITES= http://musicpd.org/uploads/files/ \
http://redundancy.redundancy.org/mirror/
@@ -23,6 +23,17 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_RC_SUBR= musicpd.sh
PKGMESSAGE= ${WRKDIR}/pkg-message
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+CFLAGS+= -I${PREFIX}/include
+
+MAN1= mpd.1
+MAN5= mpd.conf.5
+
+DOCSDIR= ${PREFIX}/share/doc/mpd
+
+SUB_FILES= pkg-message
OPTIONS= FLAC "Support for FLAC Audio" on \
VORBIS "Support for OGG Vorbis Audio" on \
@@ -35,7 +46,9 @@ OPTIONS= FLAC "Support for FLAC Audio" on \
IPV6 "Support for IPV6" on \
AO "Support for libao" off \
PULSE "Support for PulseAudio" off \
- SHOUT "Support for Icecast and Shoutcast" on
+ JACK "Support for JACK" off \
+ SHOUT "Support for Icecast and Shoutcast" on \
+ SAMPLERATE "Support for ibsamplerate" on
.include <bsd.port.pre.mk>
@@ -96,34 +109,33 @@ CONFIGURE_ARGS+=--enable-ao
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
.endif
-.ifdef(WITHOUT_PULSE)
+.ifdef(WITH_PULSE)
+LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+.else
CONFIGURE_ARGS+=--disable-pulse
+.endif
+
+.ifdef(WITH_JACK)
+LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
.else
-LIB_DEPENDS+= pulse.0:${PORTSDIR}/audio/pulseaudio
+CONFIGURE_ARGS+=--disable-jack
.endif
.ifdef(WITHOUT_SHOUT)
CONFIGURE_ARGS+=--disable-shout
.endif
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-CFLAGS+= -I${PREFIX}/include
-
-MAN1= mpd.1
-MAN5= mpd.conf.5
-
-DOCSDIR= ${PREFIX}/share/doc/mpd
-DOCS= COMMANDS \
- mpdconf.example \
- README \
- UPGRADING
-
-SED_SCRIPT+= -e 's,%%PREFIX%%,${PREFIX},g'
+.ifdef(WITHOUT_SAMPLERATE)
+CONFIGURE_ARGS+=--disable-lsr
+.else
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+.endif
-post-build:
- @${SED} ${SED_SCRIPT} ${MASTERDIR}/pkg-message >${PKGMESSAGE}
+.if defined(NOPORTDOCS)
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-docDATA||' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/doc/Makefile.in
+.endif
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/audio/musicpd/pkg-message b/audio/musicpd/files/pkg-message.in
index 6159a0375d45..ee89e3e0e154 100644
--- a/audio/musicpd/pkg-message
+++ b/audio/musicpd/files/pkg-message.in
@@ -14,7 +14,7 @@ or reboot.
NOTE: The musicpd server is pretty useless without a
client. You might want to install one of the following
- ports, too: mpc, glurp, gmpc, kmp or phpmp
+ ports, too: mpc, ncmpc, glurp, gmpc, kmp or phpmp
************************************************************