aboutsummaryrefslogtreecommitdiff
path: root/audio/musicpd
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-02-03 23:20:50 +0000
committerChris Rees <crees@FreeBSD.org>2012-02-03 23:20:50 +0000
commitf361e53c26a44e945f2fe7c398d4a2ebf4843e59 (patch)
tree7f348668626814eeac7ece99954bb985caf977e3 /audio/musicpd
parent5b53efb91e7884ab74cebd0c86cf21375081253c (diff)
Notes
Diffstat (limited to 'audio/musicpd')
-rw-r--r--audio/musicpd/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index e7c24c07b807..2c6495b03137 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -61,7 +61,8 @@ OPTIONS= ID3TAG "Support ID3 v1/v2 tags" on \
SNDFILE "Adds support for libsndfile" on \
LAME "Support for MP3 Icecast Streams" off \
HTTPD "Support for httpd output streaming" off \
- SAMPLERATE "Support sample rate conversion" off
+ SAMPLERATE "Support sample rate conversion" off \
+ CUE "Support embedded cue sheets" off
MPDDIR?= /var/mpd
MPDUSER?= mpd
@@ -229,6 +230,13 @@ LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+=--enable-lsr
.endif
+.if defined(WITH_CUE)
+CONFIGURE_ARGS+=--enable-cue
+LIB_DEPENDS+= cue:${PORTSDIR}/textproc/libcue
+.else
+CONFIGURE_ARGS+=--disable-cue
+.endif
+
post-patch:
# Replace ~/ with MPDDIR and make musicpd run as mpd by default
@${REINPLACE_CMD} -e 's,^#\([^"]*"\)~/,\1${MPDDIR}/,g' \