aboutsummaryrefslogtreecommitdiff
path: root/audio/mxv/Makefile
diff options
context:
space:
mode:
authorDavid Nugent <davidn@FreeBSD.org>1997-04-17 07:05:40 +0000
committerDavid Nugent <davidn@FreeBSD.org>1997-04-17 07:05:40 +0000
commitb63958f2e9f5d0d696eaef941d1a75beb0c9a6a9 (patch)
tree2a0d6fccc6c33cebc18a68f5dd9a238f44228da7 /audio/mxv/Makefile
parent476add97263f64cc20813bdc6868eddb8b3d7132 (diff)
downloadports-b63958f2e9f5d0d696eaef941d1a75beb0c9a6a9.tar.gz
ports-b63958f2e9f5d0d696eaef941d1a75beb0c9a6a9.zip
Notes
Diffstat (limited to 'audio/mxv/Makefile')
-rw-r--r--audio/mxv/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/audio/mxv/Makefile b/audio/mxv/Makefile
new file mode 100644
index 000000000000..b19f36ad64a3
--- /dev/null
+++ b/audio/mxv/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: mxv
+# Version required: 1.10
+# Date created: 17 March 1997
+# Whom: davidn@blaze.net.au
+#
+# $Id$
+#
+
+DISTNAME= mxv-v1.10-source
+PKGNAME= mxv-1.10
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.ccmrc.ucsb.edu/pub/MixViews/source/
+
+#PATCH_SITES= ftp://ftp.ccmrc.ucsb.edu/pub/MixViews/source/
+#PATCHFILES= mxv-v1.10-patch01
+#Unfortunately, the above vendor patch does not apply cleanly,
+#and and a hand-edited version is supplied in the patches subdir
+
+MAINTAINER= davidn@blaze.net.au
+#From InterViews 3.1
+BUILD_DEPENDS= ivmkmf
+
+USE_IMAKE= yes
+WRKSRC= $(WRKDIR)
+#ivmkmf -a (with makedepend) not recommended by documentation
+XMKMF= env CPU=FREEBSD ivmkmf;make Makefiles
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/FREEBSD/mxv ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/MiXViews.res ${PREFIX}/lib/X11/app-defaults/MiXViews
+
+.include <bsd.port.mk>