aboutsummaryrefslogtreecommitdiff
path: root/audio/mythplugin-mythmusic/Makefile
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-03-25 17:09:05 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-03-25 17:09:05 +0000
commitdb032688dfff0df0cd92849f13033b28a8b1b1f2 (patch)
tree798b5fbd8a866689a9e7a6acdefbbe97f5e7555e /audio/mythplugin-mythmusic/Makefile
parentfc45dfb12d11b24987ff3be41c61912625e7f7df (diff)
downloadports-db032688dfff0df0cd92849f13033b28a8b1b1f2.tar.gz
ports-db032688dfff0df0cd92849f13033b28a8b1b1f2.zip
Notes
Diffstat (limited to 'audio/mythplugin-mythmusic/Makefile')
-rw-r--r--audio/mythplugin-mythmusic/Makefile36
1 files changed, 21 insertions, 15 deletions
diff --git a/audio/mythplugin-mythmusic/Makefile b/audio/mythplugin-mythmusic/Makefile
index 245bdba8d820..e594ba18bb68 100644
--- a/audio/mythplugin-mythmusic/Makefile
+++ b/audio/mythplugin-mythmusic/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= mythmusic
-PORTVERSION= 0.27.5
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+DISTVERSION= 29.1
CATEGORIES= audio
PKGNAMEPREFIX= mythplugin-
@@ -14,30 +13,34 @@ COMMENT= Music playing plugin for MythTV
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libcdio.so:sysutils/libcdio \
- libFLAC.so:audio/flac \
+LIB_DEPENDS= libFLAC.so:audio/flac \
+ libmp3lame.so:audio/lame \
+ libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
- libtag.so:audio/taglib \
- libfftw3f.so:math/fftw3-float
-BUILD_DEPENDS= mythfrontend:multimedia/mythtv
+ libmyth-29.so:multimedia/mythtv
USE_GITHUB= yes
GH_ACCOUNT= MythTV
GH_PROJECT= mythtv
+USE_LDCONFIG= yes
+USE_QT5= buildtools_build core gui qmake_build sql xml
-WRKSRC_SUBDIR= mythplugins
-
-USE_QT4= linguist_build moc_build qmake_build rcc_build uic_build
HAS_CONFIGURE= yes
-USE_LDCONFIG= ${PREFIX}/lib/mythtv/plugins
+CONFIGURE_ARGS= --prefix="${PREFIX}" --disable-all \
+ --enable-mythmusic
DESTDIRNAME= INSTALL_ROOT
-
PLIST_SUB= MYTHSHARE="share/mythtv"
+WRKSRC_SUBDIR= mythplugins
-QMAKESPEC?= ${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
+OPTIONS_DEFINE= CDIO FFTW
-CONFIGURE_ARGS= --prefix="${PREFIX}" --disable-all \
- --enable-mythmusic --enable-fftw --enable-opengl
+CDIO_LIB_DEPENDS= libcdio.so:sysutils/libcdio \
+ libcdio_paranoia.so:sysutils/libcdio-paranoia
+CDIO_CONFIGURE_ENABLE= cdio
+
+FFTW_DESC= FFTW3-based visualizations
+FFTW_LIB_DEPENDS= libfftw3.so:math/fftw3
+FFTW_CONFIGURE_ENABLE= fftw
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
@@ -46,4 +49,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/include|${LOCALBASE}/include|g' \
${WRKSRC}/configure
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/mythtv/plugins/libmythmusic.so
+
.include <bsd.port.mk>