aboutsummaryrefslogtreecommitdiff
path: root/audio/mziq
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-24 18:08:50 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-24 18:08:50 +0000
commite55c389437eaec7208d9eb5e81eb41a546c5d09f (patch)
treefb90bd412c506058d237024cbb6b22c30fdc41c6 /audio/mziq
parentfdd17161b1aaeabc8702125bd6364ba92a9ed9f2 (diff)
downloadports-e55c389437eaec7208d9eb5e81eb41a546c5d09f.tar.gz
ports-e55c389437eaec7208d9eb5e81eb41a546c5d09f.zip
Notes
Diffstat (limited to 'audio/mziq')
-rw-r--r--audio/mziq/Makefile39
-rw-r--r--audio/mziq/distinfo1
-rw-r--r--audio/mziq/files/patch-mziq11
-rw-r--r--audio/mziq/pkg-comment1
-rw-r--r--audio/mziq/pkg-descr7
-rw-r--r--audio/mziq/pkg-plist8
6 files changed, 67 insertions, 0 deletions
diff --git a/audio/mziq/Makefile b/audio/mziq/Makefile
new file mode 100644
index 000000000000..f896e69012b5
--- /dev/null
+++ b/audio/mziq/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mziq
+# Date created: 24 August 2001
+# Whom: Gea-Suan Lin <gslin@ccca.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mziq
+PORTVERSION= 0.2.44
+CATEGORIES= audio
+MASTER_SITES= http://cseg.lucidx.com/mziq/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= gslin@ccca.nctu.edu.tw
+
+RUN_DEPENDS= ${LOCALBASE}/bin/mpg123:${PORTSDIR}/audio/mpg123
+
+WRKSRC= ${WRKDIR}/MZiq
+
+BINS= gmziq jukebox mziq
+DOCS= LASTLOG README TODO rcfile
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+do-install:
+.for FILE in ${BINS}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${FILE} ${PREFIX}/bin
+.endfor
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/mziq/distinfo b/audio/mziq/distinfo
new file mode 100644
index 000000000000..039c74f9192b
--- /dev/null
+++ b/audio/mziq/distinfo
@@ -0,0 +1 @@
+MD5 (mziq.tar.gz) = 9ded5a0e9d94435d4db2f816aa0ee271
diff --git a/audio/mziq/files/patch-mziq b/audio/mziq/files/patch-mziq
new file mode 100644
index 000000000000..29caf2ff2146
--- /dev/null
+++ b/audio/mziq/files/patch-mziq
@@ -0,0 +1,11 @@
+--- mziq.orig Sat Aug 25 01:42:16 2001
++++ mziq Sat Aug 25 01:42:33 2001
+@@ -52,7 +52,7 @@
+ #
+ # This is the only option you really need to modify. It defines the top-level
+ # directories where the program will search for files.
+-@basedir = ("/storage/mp3");
++@basedir = ("$ENV{'HOME'}");
+
+ # These options might work for most people.
+ #
diff --git a/audio/mziq/pkg-comment b/audio/mziq/pkg-comment
new file mode 100644
index 000000000000..dd618e2d232a
--- /dev/null
+++ b/audio/mziq/pkg-comment
@@ -0,0 +1 @@
+A Perl frontend to mpg123
diff --git a/audio/mziq/pkg-descr b/audio/mziq/pkg-descr
new file mode 100644
index 000000000000..926d134e2490
--- /dev/null
+++ b/audio/mziq/pkg-descr
@@ -0,0 +1,7 @@
+MZiq is a Perl frontend for mpg123. Its main feature is the deployment of
+Perl's regular expressions for ease of playlist creation.
+
+WWW: http://cseg.lucidx.com/mziq/
+
+- Gea-Suan Lin
+ gslin@ccca.nctu.edu.tw
diff --git a/audio/mziq/pkg-plist b/audio/mziq/pkg-plist
new file mode 100644
index 000000000000..09000fa9c511
--- /dev/null
+++ b/audio/mziq/pkg-plist
@@ -0,0 +1,8 @@
+bin/gmziq
+bin/jukebox
+bin/mziq
+%%PORTDOCS%%share/doc/mziq/LASTLOG
+%%PORTDOCS%%share/doc/mziq/README
+%%PORTDOCS%%share/doc/mziq/TODO
+%%PORTDOCS%%share/doc/mziq/rcfile
+%%PORTDOCS%%@dirrm share/doc/mziq