aboutsummaryrefslogtreecommitdiff
path: root/audio/nas/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-03-30 03:28:07 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-03-30 03:28:07 +0000
commite3bbb3138e127f742a0fba92d12a6c376dddb231 (patch)
treed05dc7e87869f0a9f5d1f0b1667fbeec5f45abff /audio/nas/Makefile
parentc34aa86301ac44efe7279159bbee660bdee5445d (diff)
downloadports-e3bbb3138e127f742a0fba92d12a6c376dddb231.tar.gz
ports-e3bbb3138e127f742a0fba92d12a6c376dddb231.zip
Notes
Diffstat (limited to 'audio/nas/Makefile')
-rw-r--r--audio/nas/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index e4ae9fe683a8..41899d5d78bb 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -1,16 +1,17 @@
# New ports collection makefile for: nas (formerly netaudio)
-# Version required: 1.2p1
+# Version required: 1.4
# Date created: 03 Nov 1994
# Whom: jkh
#
# $FreeBSD$
#
-DISTNAME= nas-1.2p5
-PKGNAME= nas-1.2.5
+DISTNAME= nas-1.4
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
+MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
+ http://radscan.com/nas/
MASTER_SITE_SUBDIR= audio/nas
+EXTRACT_SUFX= .src.tar.gz
MAINTAINER= ports@FreeBSD.org
@@ -19,10 +20,9 @@ ALL_TARGET= World
# no need to "xmkmf -a" and create the Makefiles twice -- see above
XMKMF= xmkmf
-MAN1= AUVoxConfig.1 auconvert.1 auctl.1 audemo.1 audial.1 auedit.1 auinfo.1 \
- aupanel.1 auphone.1 auplay.1 aurecord.1 auscope.1 auserver.1 autool.1 \
- auvoxware.1 auwave.1 checkmail.1 issndfile.1 nas.1 playbucket.1 \
- soundtoh.1
+MAN1= auconvert.1 auctl.1 audemo.1 audial.1 auedit.1 auinfo.1 aupanel.1 \
+ auphone.1 auplay.1 aurecord.1 auscope.1 autool.1 auvoxware.1 auwave.1 \
+ checkmail.1 issndfile.1 nas.1 playbucket.1 soundtoh.1
MAN3= AuAnyEvent.3 AuBucketAttributes.3 AuCloseServer.3 \
AuConvertDataToShort.3 AuConvertShortToData.3 AuCreateBucket.3 \
AuCreateFlow.3 AuDataFormats.3 AuDataTypes.3 AuDefineToFormat.3 \
@@ -69,4 +69,12 @@ MAN3= AuAnyEvent.3 AuBucketAttributes.3 AuCloseServer.3 \
SoundReadFile.3 SoundRewindFile.3 SoundSeekFile.3 \
SoundStringToFileFormat.3 SoundTellFile.3 SoundWriteFile.3
+post-patch:
+ @find ${WRKSRC} -name '*.[ch]' | xargs \
+ ${PERL} -pi -e "s|<malloc.h>|<stdlib.h>|g"
+
+post-install:
+ ${LDCONFIG} -m ${PREFIX}/lib
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>