aboutsummaryrefslogtreecommitdiff
path: root/audio/nas
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-15 23:46:29 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-15 23:46:29 +0000
commitb101c12f7e7dc933a5ea692b74d7e98b0ff3d54b (patch)
tree55a465112a6d2eee7c86974fd7101d9947faa80a /audio/nas
parent888deba6846add87a38a7b337d65f06b7379944e (diff)
downloadports-b101c12f7e7dc933a5ea692b74d7e98b0ff3d54b.tar.gz
ports-b101c12f7e7dc933a5ea692b74d7e98b0ff3d54b.zip
Notes
Diffstat (limited to 'audio/nas')
-rw-r--r--audio/nas/Makefile2
-rw-r--r--audio/nas/distinfo6
-rw-r--r--audio/nas/files/patch-ab47
-rw-r--r--audio/nas/files/patch-ad11
-rw-r--r--audio/nas/files/patch-ae26
-rw-r--r--audio/nas/pkg-plist1
6 files changed, 28 insertions, 65 deletions
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index c217a6aa7502..cdfe6e7eeb89 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nas
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= audio
MASTER_SITES= http://nas.codebrilliance.com/nas/
EXTRACT_SUFX= .src.tar.gz
diff --git a/audio/nas/distinfo b/audio/nas/distinfo
index 25432141afb6..b13a02757a9b 100644
--- a/audio/nas/distinfo
+++ b/audio/nas/distinfo
@@ -1,2 +1,4 @@
-MD5 (nas-1.6.src.tar.gz) = 08b54fbf3af8c2ffab39f6f84f2ab337
-SIZE (nas-1.6.src.tar.gz) = 1099385
+SHA1 (nas-1.7.src.tar.gz) = a41adef84d0bf4c8e02b14d77bec0d284e7c9317
+RMD160 (nas-1.7.src.tar.gz) = 227ddc4f5f9d264c97066dc461bad138776d1dfd
+MD5 (nas-1.7.src.tar.gz) = c9918e9c9c95d587a95b455bbabe3b49
+SIZE (nas-1.7.src.tar.gz) = 1288569
diff --git a/audio/nas/files/patch-ab b/audio/nas/files/patch-ab
index c112f5c66d83..125151b9b510 100644
--- a/audio/nas/files/patch-ab
+++ b/audio/nas/files/patch-ab
@@ -1,5 +1,5 @@
---- server/dda/voxware/auvoxware.c.orig Thu Jul 25 09:42:28 2002
-+++ server/dda/voxware/auvoxware.c Sat Oct 26 02:54:26 2002
+--- server/dda/voxware/auvoxware.c.orig Sat Oct 23 08:44:47 2004
++++ server/dda/voxware/auvoxware.c Mon Nov 15 21:13:49 2004
@@ -133,7 +133,7 @@
#include <stdio.h>
@@ -9,40 +9,19 @@
#include <getopt.h>
#endif
#include <sys/types.h>
-@@ -171,16 +171,11 @@
- #include <sys/param.h>
- #include <assert.h>
-
--#ifdef __FreeBSD__
--# include <machine/soundcard.h>
--# include <machine/pcaudioio.h>
-+#ifdef __NetBSD__
-+# include <sys/ioctl.h>
-+# include <soundcard.h>
- #else
--# ifdef __NetBSD__
--# include <sys/ioctl.h>
--# include <soundcard.h>
--# else
--# include <sys/soundcard.h>
--# endif
-+# include <sys/soundcard.h>
- #endif
-
- #include <audio/audio.h>
-@@ -659,7 +654,11 @@
- if(sndStatOut.fd == -1)
+@@ -670,7 +670,11 @@
+ if(sndStatOut.fd == -1)
{
- while ((sndStatOut.fd = open(sndStatOut.device,
+ while ((sndStatOut.fd = open(sndStatOut.device,
+#if defined(__FreeBSD__)
-+ sndStatOut.howToOpen|extramode,
++ sndStatOut.howToOpen|extramode,
+#else
- sndStatOut.howToOpen|O_SYNC|extramode,
+ sndStatOut.howToOpen|O_SYNC|extramode,
+#endif
- 0666)) == -1 && wait)
- {
- osLogMsg("openDevice: waiting on output device\n");
-@@ -1310,6 +1309,11 @@
+ 0666)) == -1 && wait)
+ {
+ osLogMsg("openDevice: waiting on output device\n");
+@@ -1330,6 +1334,11 @@
/*
* Setup soundcard at maximum audio quality.
*/
@@ -54,7 +33,7 @@
static void setupSoundcard(sndStatPtr)
SndStat* sndStatPtr;
{
-@@ -1472,7 +1476,11 @@
+@@ -1571,7 +1580,11 @@
sndStatOut.device, sndStatOut.howToOpen);
if ((fd = open(sndStatOut.device,
@@ -65,4 +44,4 @@
+#endif
{
UNIDENTMSG;
- return AuFalse;
+ osLogMsg("Output open(%s) failed: %s\n",
diff --git a/audio/nas/files/patch-ad b/audio/nas/files/patch-ad
deleted file mode 100644
index 36336b371ef2..000000000000
--- a/audio/nas/files/patch-ad
+++ /dev/null
@@ -1,11 +0,0 @@
---- clients/audio/auedit/Graph.c.orig Mon Oct 25 02:24:08 1999
-+++ clients/audio/auedit/Graph.c Sat Mar 25 14:56:23 2000
-@@ -28,7 +28,7 @@
- */
-
- #ifndef WIN32
--# ifdef __NetBSD__
-+# if defined(__NetBSD__) || defined(__FreeBSD__)
- # include <limits.h>
- # define MAXSHORT SHRT_MAX
- # define MINSHORT SHRT_MIN
diff --git a/audio/nas/files/patch-ae b/audio/nas/files/patch-ae
index 585fdc620126..edb04bb2207b 100644
--- a/audio/nas/files/patch-ae
+++ b/audio/nas/files/patch-ae
@@ -1,19 +1,11 @@
---- lib/audio/Imakefile.orig Sat Jan 1 18:28:13 2000
-+++ lib/audio/Imakefile Sat Mar 25 14:56:19 2000
-@@ -64,10 +64,15 @@
- COMPAT_OBJS = AuGetBest.o
- #endif /* ProjectX < 5 */
+--- lib/audio/Imakefile.orig Sun Sep 12 06:23:33 2004
++++ lib/audio/Imakefile Mon Nov 15 21:42:49 2004
+@@ -60,7 +60,7 @@
-+#if HasBSD44Sockets
-+ SOCK_DEFINES = -DBSD44SOCKETS
-+#endif
-+
-+
- EDB_DEFINES = -DERRORDB=\"$(LIBDIR)/AuErrorDB\"
+ XCOMM JET - hmmm.
+ #if (defined(FreeBSDArchitecture) || defined(BSDArchitecture)) && defined(HasBSD44Sockets)
+- EXTRA_DEFINES = -DBSD44SOCKETS
++ EXTRA_DEFINES = -DBSD44SOCKETS
+ #endif
- DEFINES = $(MALLOC_DEFINES) $(SYSV_DEFINES)
-- CONN_DEFINES = ConnectionFlags
-+ CONN_DEFINES = ConnectionFlags $(SOCK_DEFINES)
-
- HEADERS = Alibint.h Alibnet.h Xtutil.h audiolib.h audioutil.h snd.h wave.h \
- voc.h aiff.h sound.h soundlib.h fileutil.h 8svx.h Astreams.h \
+ XCOMM JET - see if we should avoid streams
diff --git a/audio/nas/pkg-plist b/audio/nas/pkg-plist
index 79429f86c768..87df1c8da5aa 100644
--- a/audio/nas/pkg-plist
+++ b/audio/nas/pkg-plist
@@ -34,6 +34,7 @@ include/audio/audiolib.h
include/audio/audioutil.h
include/audio/fileutil.h
include/audio/mutex.h
+include/audio/release.h
include/audio/snd.h
include/audio/sound.h
include/audio/soundlib.h