aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpcpp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-16 15:30:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-16 15:30:39 +0000
commit1e9d58396efd0c3433e29482436f217169a74919 (patch)
treeaf0cdfda774e6ed96d9772e498a3b0ee8066c115 /audio/ncmpcpp
parent2ab8bf6757a4559645da086c229c404e1db02aad (diff)
downloadports-1e9d58396efd0c3433e29482436f217169a74919.tar.gz
ports-1e9d58396efd0c3433e29482436f217169a74919.zip
Notes
Diffstat (limited to 'audio/ncmpcpp')
-rw-r--r--audio/ncmpcpp/Makefile7
-rw-r--r--audio/ncmpcpp/files/patch-src__visualizer.h11
2 files changed, 14 insertions, 4 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index d5d8cf28022d..03c169700585 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ncmpcpp
PORTVERSION= 0.5.10
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://unkart.ovh.org/ncmpcpp/ \
http://mirror.mcx2.org/
@@ -14,12 +14,11 @@ COMMENT= ncurses mpd client, clone of ncmpc with some new features
LIB_DEPENDS= libmpdclient.so:${PORTSDIR}/audio/libmpdclient \
libfftw3.so:${PORTSDIR}/math/fftw3
-USES= iconv ncurses pkgconfig
-USE_BZIP2= yes
+USES= iconv libtool ncurses pkgconfig tar:bzip2
USE_GCC= any
GNU_CONFIGURE= yes
USE_GNOME= glib20
-USE_AUTOTOOLS= automake aclocal libtool
+USE_AUTOTOOLS= automake aclocal
AUTOMAKE_ARGS= --add-missing
ACLOCAL_ARGS= --automake-acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/audio/ncmpcpp/files/patch-src__visualizer.h b/audio/ncmpcpp/files/patch-src__visualizer.h
new file mode 100644
index 000000000000..8114ee6e1f53
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src__visualizer.h
@@ -0,0 +1,11 @@
+--- src/visualizer.h.orig 2012-04-01 20:49:09.000000000 +0400
++++ src/visualizer.h 2014-06-16 19:07:34.000000000 +0400
+@@ -34,6 +34,8 @@
+ # include <fftw3.h>
+ #endif
+
++#include <sys/time.h>
++
+ class Visualizer : public Screen<Window>
+ {
+ public: