aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpcpp
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2009-03-19 21:31:35 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2009-03-19 21:31:35 +0000
commitaadcb0f7cf8120c1acb4e8bb9133f70fbbf54708 (patch)
tree6b2bb6c775926104c824123e0d64666225db5398 /audio/ncmpcpp
parent53ddf32575ab1d2050dbf32533eb6a2bab6ff489 (diff)
downloadports-aadcb0f7cf8120c1acb4e8bb9133f70fbbf54708.tar.gz
ports-aadcb0f7cf8120c1acb4e8bb9133f70fbbf54708.zip
Notes
Diffstat (limited to 'audio/ncmpcpp')
-rw-r--r--audio/ncmpcpp/Makefile4
-rw-r--r--audio/ncmpcpp/distinfo6
-rw-r--r--audio/ncmpcpp/files/patch-src_charset.h38
3 files changed, 44 insertions, 4 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
index c108da396d4a..d089b9c25eab 100644
--- a/audio/ncmpcpp/Makefile
+++ b/audio/ncmpcpp/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ncmpcpp
-PORTVERSION= 0.3.1
+PORTVERSION= 0.3.2
CATEGORIES= audio
MASTER_SITES= http://unkart.ovh.org/ncmpcpp/ \
http://mirror.mcx2.org/
@@ -23,6 +23,8 @@ ACLOCAL_ARGS= --acdir=${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lpthread"
+MAN1= ncmpcpp.1
+
OPTIONS= CURL "Enable fetching lyrics from the Internet" on \
CLOCK "Enable clock-screen support" on \
UTF8 "Enable UTF8 support" on \
diff --git a/audio/ncmpcpp/distinfo b/audio/ncmpcpp/distinfo
index 7bc43f192416..8fcf5d079068 100644
--- a/audio/ncmpcpp/distinfo
+++ b/audio/ncmpcpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (ncmpcpp-0.3.1.tar.bz2) = 0ac67665faece8d7a193f3dcfa28e398
-SHA256 (ncmpcpp-0.3.1.tar.bz2) = 330c68cfc26afd7cf163170720e17099b6647c63242995deaeb97c9a16618733
-SIZE (ncmpcpp-0.3.1.tar.bz2) = 318651
+MD5 (ncmpcpp-0.3.2.tar.bz2) = e2159a391b21d3fcf9a4613f589fb213
+SHA256 (ncmpcpp-0.3.2.tar.bz2) = 332a44835c399cca09254e1dd2fbd5342733a7b92d56379506d039fbbc4b40ae
+SIZE (ncmpcpp-0.3.2.tar.bz2) = 323371
diff --git a/audio/ncmpcpp/files/patch-src_charset.h b/audio/ncmpcpp/files/patch-src_charset.h
new file mode 100644
index 000000000000..11bc75a1cefd
--- /dev/null
+++ b/audio/ncmpcpp/files/patch-src_charset.h
@@ -0,0 +1,38 @@
+--- src/charset.h.orig
++++ src/charset.h
+@@ -25,10 +25,10 @@
+ #include <config.h>
+ #endif
+
+-#include <string>
+-
+ #if defined(SUPPORTED_LOCALES) && defined(HAVE_ICONV_H)
+
++#include <string>
++
+ void init_current_locale();
+
+ void utf_to_locale(std::string &);
+@@ -42,16 +42,16 @@ void str_pool_locale_to_utf(char *&);
+
+ #else
+
+-void init_current_locale() { }
++#define init_current_locale();
+
+-void utf_to_locale(std::string &) { }
+-void locale_to_utf(std::string &) { }
++#define utf_to_locale(x);
++#define locale_to_utf(x);
+
+-std::string &utf_to_locale_cpy(const std::string &s) { return s; }
+-std::string &locale_to_utf_cpy(const std::string &s) { return s; }
++#define utf_to_locale_cpy(x) (x)
++#define locale_to_utf_cpy(x) (x)
+
+-void str_pool_utf_to_locale(char *&) { }
+-void str_pool_locale_to_utf(char *&) { }
++#define str_pool_utf_to_locale(x);
++#define str_pool_locale_to_utf(x);
+
+ #endif // SUPPORTED_LOCALES && HAVE_ICONV_H