aboutsummaryrefslogtreecommitdiff
path: root/audio/ncmpcpp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-30 12:12:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-30 12:12:07 +0000
commit208683d9e5171045b013ec77e3c22addb0e1f7e0 (patch)
tree5a95be0a4c2caeb22a99a4fa37c19afcb39c853d /audio/ncmpcpp
parent5d8d6cd1376711cd63e2d589c1ea1c810c74303c (diff)
Notes
Diffstat (limited to 'audio/ncmpcpp')
-rw-r--r--audio/ncmpcpp/Makefile59
-rw-r--r--audio/ncmpcpp/distinfo3
-rw-r--r--audio/ncmpcpp/pkg-descr5
-rw-r--r--audio/ncmpcpp/pkg-message9
4 files changed, 76 insertions, 0 deletions
diff --git a/audio/ncmpcpp/Makefile b/audio/ncmpcpp/Makefile
new file mode 100644
index 000000000000..9ca313a1ec4e
--- /dev/null
+++ b/audio/ncmpcpp/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: ncmpcpp
+# Date created: August 25 2008
+# Whom: Dennis Herrmann <adox@mcx2.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ncmpcpp
+PORTVERSION= 0.2
+CATEGORIES= audio
+MASTER_SITES= http://unkart.ovh.org/ncmpcpp/ \
+ http://mirror.mcx2.org/
+
+MAINTAINER= adox@mcx2.org
+COMMENT= A ncurses mpd client, clone of ncmpc with some new features
+
+LIB_DEPENDS= ncursesw.5:${PORTSDIR}/devel/ncurses
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_ICONV= yes
+USE_GNOME= glib20
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --disable-unicode
+
+OPTIONS= CURL "Enable fetching lyrics from the Internet" on \
+ TAGLIB "Enable taglib support" off
+
+.include <bsd.port.pre.mk>
+
+PLIST_FILES= bin/ncmpcpp \
+ %%EXAMPLESDIR%%/ncmpcpprc.sample
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+.if !defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl.4:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+= --with-curl
+.else
+CONFIGURE_ARGS+= --with-curl=no
+.endif
+
+.if !defined(WITH_TAGLIB)
+LIB_DEPENDS+= tag:${PORTSDIR}/audio/taglib
+CONFIGURE_ARGS+= --with-taglib
+.else
+CONFIGURE_ARGS+= --with-taglib=no
+.endif
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/ncmpcpp ${PREFIX}/bin/
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/ncmpcpprc ${EXAMPLESDIR}/ncmpcpprc.sample
+
+ @${ECHO_MSG} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} ""
+
+.include <bsd.port.post.mk>
diff --git a/audio/ncmpcpp/distinfo b/audio/ncmpcpp/distinfo
new file mode 100644
index 000000000000..226e4df38861
--- /dev/null
+++ b/audio/ncmpcpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ncmpcpp-0.2.tar.bz2) = d2f67e5c2dccc0fcaac13b67a5011ed9
+SHA256 (ncmpcpp-0.2.tar.bz2) = 77aa8bb89ea72e98d90e010f7c3075fd1b3660dd40706c69597463182990b19c
+SIZE (ncmpcpp-0.2.tar.bz2) = 283557
diff --git a/audio/ncmpcpp/pkg-descr b/audio/ncmpcpp/pkg-descr
new file mode 100644
index 000000000000..18609adf91e8
--- /dev/null
+++ b/audio/ncmpcpp/pkg-descr
@@ -0,0 +1,5 @@
+Ncmpcpp is almost exact clone of ncmpc but it contains some
+new features ncmpc doesn't have. It's been also rewritten
+from scratch in C++.
+
+WWW: http://unkart.ovh.org/ncmpcpp/
diff --git a/audio/ncmpcpp/pkg-message b/audio/ncmpcpp/pkg-message
new file mode 100644
index 000000000000..da25bf43c5fd
--- /dev/null
+++ b/audio/ncmpcpp/pkg-message
@@ -0,0 +1,9 @@
+###########################################################################
+ncmpcpp has been installed.
+
+A default ncmpcpprc config has been installed to:
+PREFIX/share/examples/ncmpcpprc.sample
+
+For more information about ncmpcpp visit:
+http://unkart.ovh.org/ncmpcpp
+###########################################################################