aboutsummaryrefslogtreecommitdiff
path: root/audio/net-rhythmbox/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-18 17:20:19 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-05-18 17:20:19 +0000
commitb879855e145107516c9e3b104432b15797f8e53b (patch)
tree2d3a12dfe0285c4acafeaeedd24aa7d2b187dd0f /audio/net-rhythmbox/Makefile
parenta7ebc6b6af894137049859619789b9d49f53d4cd (diff)
Notes
Diffstat (limited to 'audio/net-rhythmbox/Makefile')
-rw-r--r--audio/net-rhythmbox/Makefile60
1 files changed, 60 insertions, 0 deletions
diff --git a/audio/net-rhythmbox/Makefile b/audio/net-rhythmbox/Makefile
new file mode 100644
index 000000000000..8c2e17caf9e3
--- /dev/null
+++ b/audio/net-rhythmbox/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: net-rhythmbox
+# Date created: 14 February 2003
+# Whom: Hendrik Scholz <hendrik@scholz.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= net-rhythmbox
+PORTVERSION= 0.4.8
+CATEGORIES= audio gnome
+MASTER_SITES= http://web.verbum.org/net-rhythmbox/
+
+MAINTAINER= hendrik@scholz.net
+COMMENT= Audio player for the Gnome 2 desktop environment
+
+LIB_DEPENDS= musicbrainz.2:${PORTSDIR}/audio/libmusicbrainz \
+ gstplay-0.6.0:${PORTSDIR}/multimedia/gstreamer-plugins \
+ FLAC.5:${PORTSDIR}/audio/flac
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_LIBTOOL= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+CONFIGURE_ARGS= --disable-lirc
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/lib/libxosd.so)
+WITH_XOSD= yes
+.endif
+.if exists(${LOCALBASE}/lib/libogg.so)
+WITH_OGG= yes
+.endif
+
+.ifdef (WITH_XOSD)
+LIB_DEPENDS+= xosd.4:${PORTSDIR}/misc/xosd
+.else
+CONFIGURE_ARGS+= --disable-xosd
+.endif
+.ifdef (WITH_OGG)
+LIB_DEPENDS+= ogg.4:${PORTSDIR}/audio/libogg
+.else
+CONFIGURE_ARGS+= --disable-oggtest
+.endif
+
+pre-everything::
+.if !defined(WITH_XOSD)
+ @${ECHO_CMD}
+ @${ECHO_CMD} "define WITH_XOSD to enable On-Screen-Display support"
+ @${ECHO_CMD}
+.endif
+.if !defined(WITH_OGG)
+ @${ECHO_CMD}
+ @${ECHO_CMD} "define WITH_OGG to enable Ogg support"
+ @${ECHO_CMD}
+.endif
+
+.include <bsd.port.post.mk>