aboutsummaryrefslogtreecommitdiff
path: root/audio/ocp
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
commit8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f (patch)
tree82565381028ebd8b5a674bafdecce3a45c5c2e6d /audio/ocp
parent0a59b351f616abe849539bc2afbc8eba4abe8004 (diff)
downloadports-8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f.tar.gz
ports-8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f.zip
Notes
Diffstat (limited to 'audio/ocp')
-rw-r--r--audio/ocp/Makefile17
1 files changed, 2 insertions, 15 deletions
diff --git a/audio/ocp/Makefile b/audio/ocp/Makefile
index 1e5817972649..4bbd86026d16 100644
--- a/audio/ocp/Makefile
+++ b/audio/ocp/Makefile
@@ -25,6 +25,7 @@ ONLY_FOR_ARCHS= i386 amd64
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_NCURSES= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
MAKE_JOBS_UNSAFE= yes
@@ -42,7 +43,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${CPPFLAGS}" \
CONFIGURE_ARGS= --with-dir-suffix="" \
--without-alsa \
- --libdir=${LOCALBASE}/lib
+ --libdir=${PREFIX}/lib
LICENSE= GPLv2
INFO= ocp
@@ -119,10 +120,6 @@ CONFIGURE_ARGS+= --without-flac
MAKE_ENV+= DOCS="\#"
.endif
-.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
-LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/etc/.*\.cfg|${TIMIDITY_CFG}|' \
${WRKSRC}/playgmi/gmitimidity.c
@@ -131,14 +128,4 @@ post-patch:
${WRKSRC}/filesel/adb.c \
${WRKSRC}/filesel/pfilesel.c
-.if ${OSVERSION} < 602107 || (${OSVERSION} > 700000 && ${OSVERSION} < 700033)
-# use ncursesw from ports
- @${REINPLACE_CMD} -e 's|-l\(curses\)|-ln\1w|' ${WRKSRC}/stuff/Makefile
-.for f in ${PFILES}
- @${REINPLACE_CMD} -e \
- 's|#include.*<curses\.h.*|#include <ncurses/ncurses.h>|' \
- ${WRKSRC}/${f}
-.endfor
-.endif
-
.include <bsd.port.post.mk>