aboutsummaryrefslogtreecommitdiff
path: root/audio/ogg2mp3/Makefile
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2005-07-13 13:42:26 +0000
committerMichael Landin <mich@FreeBSD.org>2005-07-13 13:42:26 +0000
commitd251df41e307f153cbadb301c72a5b60aa67bdec (patch)
tree4ef521c071c8d0491d9160530ce3d51269ee4f01 /audio/ogg2mp3/Makefile
parentb46341740c149f21158eb563c14bae6f8c83c83d (diff)
downloadports-d251df41e307f153cbadb301c72a5b60aa67bdec.tar.gz
ports-d251df41e307f153cbadb301c72a5b60aa67bdec.zip
Notes
Diffstat (limited to 'audio/ogg2mp3/Makefile')
-rw-r--r--audio/ogg2mp3/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/audio/ogg2mp3/Makefile b/audio/ogg2mp3/Makefile
new file mode 100644
index 000000000000..939d4abdddac
--- /dev/null
+++ b/audio/ogg2mp3/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ogg2mp3
+# Date created: 26 Jun 2005
+# Whom: Aleksander Fafula <alex@bsdguru.org>
+#
+# $FreeBSD$
+
+PORTNAME= ogg2mp3
+PORTVERSION= 0.5
+CATEGORIES= audio
+MASTER_SITES= http://amor.cms.hu-berlin.de/~h0444y2j/pub/
+
+MAINTAINER= alex@bsdguru.org
+COMMENT= Perl script that converts Ogg Vorbis files to MP3 format
+
+RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
+ ${SITE_PERL}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote \
+ ogginfo:${PORTSDIR}/audio/vorbis-tools
+
+NO_BUILD= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/ogg2mp3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin|/usr/local/bin|g' \
+ ${WRKSRC}/ogg2mp3
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/ogg2mp3 ${PREFIX}/bin
+
+.include <bsd.port.mk>