aboutsummaryrefslogtreecommitdiff
path: root/audio/openal-soft
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-11-20 13:56:36 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-11-20 13:56:36 +0000
commitb6025180665327262ba18b4a6ef31fde0caa9868 (patch)
treede967def478fa222acd2b79e5e9dabf8141a2ecb /audio/openal-soft
parent2a3f317913bd65127f03ee26c2cee0144faf5baa (diff)
downloadports-b6025180665327262ba18b4a6ef31fde0caa9868.tar.gz
ports-b6025180665327262ba18b4a6ef31fde0caa9868.zip
audio/openal-soft: Drop workaround from r492771
The problem is no longer reproducible on the latest 12-STABLE snapshot and it breaks the build on powerpc64 elfv2. PR: 235603, 242107
Notes
Notes: svn path=/head/; revision=518012
Diffstat (limited to 'audio/openal-soft')
-rw-r--r--audio/openal-soft/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/audio/openal-soft/Makefile b/audio/openal-soft/Makefile
index 53ea14b97465..76c218205c7a 100644
--- a/audio/openal-soft/Makefile
+++ b/audio/openal-soft/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= openal-200[0-9]*
USES= cmake compiler:c11 tar:bzip2
-USE_BINUTILS= yes
+LLD_UNSAFE= yes
USE_LDCONFIG= yes
CMAKE_ARGS= -DCMAKE_INSTALL_DATADIR:STRING="${PREFIX}/etc"
@@ -27,11 +27,8 @@ CMAKE_OFF= ALSOFT_BACKEND_ALSA \
CMAKE_ON= ALSOFT_BACKEND_WAVE \
ALSOFT_UTILS
-# use gold linker due to some problems with ld.bfd on 12-STABLE,
-# cf. PR 235603
# do not link with librt and libdl.
-LDFLAGS+= -fuse-ld=gold \
- -Wl,--as-needed
+LDFLAGS+= -Wl,--as-needed
OPTIONS_DEFINE= EXAMPLES CONFIG JACK OSS PORTAUDIO PULSEAUDIO SDL SNDIO
OPTIONS_DEFAULT= OSS