aboutsummaryrefslogtreecommitdiff
path: root/audio/openal/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-24 06:49:56 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-11-24 06:49:56 +0000
commit80d0833c0e8505587a40dc0961202f6f4c87f494 (patch)
treebfda2a6316c523f5da7a30630c8fbda39fbd9fc6 /audio/openal/Makefile
parent5cda33769cc80803a0719cc70c2a83dddc6777c9 (diff)
downloadports-80d0833c0e8505587a40dc0961202f6f4c87f494.tar.gz
ports-80d0833c0e8505587a40dc0961202f6f4c87f494.zip
Notes
Diffstat (limited to 'audio/openal/Makefile')
-rw-r--r--audio/openal/Makefile54
1 files changed, 49 insertions, 5 deletions
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
index f3d7f75e836d..a2c4fb2706e5 100644
--- a/audio/openal/Makefile
+++ b/audio/openal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openal
PORTVERSION= 20050401
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://math.missouristate.edu/~erik/files/fbsd/\
http://www.smluc.org/~erik/files/fbsd/
@@ -19,16 +20,59 @@ INFO= openal
WRKSRC= ${WRKDIR}/${DISTNAME}/linux
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --enable-capture
USE_GMAKE= yes
USE_GNOME= pkgconfig
+WANT_SDL= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
+OPTIONS= ARTS "aRts backend" off \
+ ESD "esd backend" off \
+ SDL "SDL backend" off \
+ VORBIS "vorbis support" off \
+ SMPEG "smpeg support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SMPEG)
+WITH_SDL= yes # smpeg requires SDL
+.endif
+
+.if defined(WITH_ARTS)
+LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+CONFIGURE_ARGS+=--enable-arts
+.endif
+
+.if defined(WITH_ESD)
+USE_GNOME+= esound
+CONFIGURE_ARGS+=--enable-esd
+.endif
+
+.if defined(WITH_SDL)
+USE_SDL+= sdl
+CONFIGURE_ENV+= HAVESDL="${SDL_CONFIG}"
+CONFIGURE_ARGS+=--enable-sdl
+.endif
+
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbisfile.4:${PORTSDIR}/audio/libvorbis
+CONFIGURE_ARGS+=--enable-vorbis
+.endif
+
+.if defined(WITH_SMPEG)
+LIB_DEPENDS+= smpeg.1:${PORTSDIR}/multimedia/smpeg
+CONFIGURE_ARGS+=--enable-smpeg
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e "s/-pthread/${PTHREAD_LIBS}/" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/; \
+ /CPPFLAGS=/ d' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/#include/ s|SDL/||' \
+ ${WRKSRC}/src/extensions/al_ext_mp3.c
-pre-install:
- @${INSTALL_DATA} ${WRKSRC}/doc/openal.info ${PREFIX}/info
- @install-info ${PREFIX}/info/openal.info ${PREFIX}/info/dir
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/doc/openal.info ${PREFIX}/info
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>