aboutsummaryrefslogtreecommitdiff
path: root/audio/openal
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-25 21:37:39 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-25 21:37:39 +0000
commit112f62e6b9a1ec43ddc94a4694095f410e4b643e (patch)
tree277ac2758fc47caca6c3e00663bc52d197085558 /audio/openal
parent33ac97e0314d5998c3111bd87d8bcece3e1978b2 (diff)
downloadports-112f62e6b9a1ec43ddc94a4694095f410e4b643e.tar.gz
ports-112f62e6b9a1ec43ddc94a4694095f410e4b643e.zip
Notes
Diffstat (limited to 'audio/openal')
-rw-r--r--audio/openal/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/audio/openal/Makefile b/audio/openal/Makefile
index 314e8dc2b8d8..445615e2c978 100644
--- a/audio/openal/Makefile
+++ b/audio/openal/Makefile
@@ -47,16 +47,13 @@ NOT_FOR_ARCHS_REASON_ia64= does not compile
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/; \
- s/x86_64\*/amd64\* | \*ia64\*/g; \
+ @${REINPLACE_CMD} -e 's/x86_64\*/amd64\* | \*ia64\*/g; \
/CPPFLAGS=/ d; s/ \*linux\*)/ \*bsd\*)/' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/#include/ s|SDL/||' \
${WRKSRC}/src/extensions/al_ext_mp3.c
@${REINPLACE_CMD} -e 's|"mixaudio16_mmx_prk.h"|"arch/i386/mixaudio16_mmx_prk.h"|' \
${WRKSRC}/src/mixaudio16.h
- @${REINPLACE_CMD} -e 's|@requirements@||; \
- s|Libs: |&${PTHREAD_LIBS} |;\
- s|Cflags: |&${PTHREAD_CFLAGS} |' \
+ @${REINPLACE_CMD} -e 's|@requirements@||' \
${WRKSRC}/admin/pkgconfig/openal.pc.in
.if ! ${PORT_OPTIONS:MASM}
@${REINPLACE_CMD} -e '/^NASM=/ s|=.*|=no|' ${WRKSRC}/configure