aboutsummaryrefslogtreecommitdiff
path: root/audio/oss
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-06-04 18:09:14 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-06-04 18:09:14 +0000
commitdd39ca93f4f4a15eb54e18c2e53a23ab8a369c0d (patch)
treeefa16dfb8a39a6aab310621a8101532f2ad4853b /audio/oss
parentbf5f3c5f83d4fad763a9aa7d20bcac849556cb91 (diff)
downloadports-dd39ca93f4f4a15eb54e18c2e53a23ab8a369c0d.tar.gz
ports-dd39ca93f4f4a15eb54e18c2e53a23ab8a369c0d.zip
Notes
Diffstat (limited to 'audio/oss')
-rw-r--r--audio/oss/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/audio/oss/Makefile b/audio/oss/Makefile
index a1b63bb9634a..76a8b60bf148 100644
--- a/audio/oss/Makefile
+++ b/audio/oss/Makefile
@@ -55,17 +55,18 @@ PROTO_SBINDIR= ${PROTO_DIR}/usr/sbin
PROTO_MANDIR= ${PROTO_DIR}/usr/share/man
PROTO_OSSLIBDIR=${PROTO_DIR}${PREFIX}/lib/oss
-OPTIONS= VORBIS "OGG/Vorbis audio support" on
-
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source to be installed
.endif
-.include <bsd.port.pre.mk>
+CONFIGURE_ENV= HOSTCC="${CC}"
+
+OPTIONS_DEFINE= VORBIS
+OPTIONS_DEFAULT=VORBIS
-CONFIGURE_ENV+= HOSTCC="${CC}"
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_VORBIS)
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
CONFIGURE_ENV+= OGG_SUPPORT=YES
.endif
@@ -124,4 +125,4 @@ do-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>