aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Audio-Mixer
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-13 13:56:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-06-13 13:56:44 +0000
commite59c463b04fe88ba6124da5808cb7ac633f74903 (patch)
treee48de60ae6af3c570b18c5b70fcaf0a110896436 /audio/p5-Audio-Mixer
parent2553b4aaceb19f80e5134ed8f2a86854a3ae89bb (diff)
downloadports-e59c463b04fe88ba6124da5808cb7ac633f74903.tar.gz
ports-e59c463b04fe88ba6124da5808cb7ac633f74903.zip
Notes
Diffstat (limited to 'audio/p5-Audio-Mixer')
-rw-r--r--audio/p5-Audio-Mixer/Makefile14
-rw-r--r--audio/p5-Audio-Mixer/files/patch-Mix.c6
-rw-r--r--audio/p5-Audio-Mixer/pkg-plist2
3 files changed, 15 insertions, 7 deletions
diff --git a/audio/p5-Audio-Mixer/Makefile b/audio/p5-Audio-Mixer/Makefile
index bf3145b39479..7586ae62c96d 100644
--- a/audio/p5-Audio-Mixer/Makefile
+++ b/audio/p5-Audio-Mixer/Makefile
@@ -3,16 +3,24 @@
PORTNAME= Audio-Mixer
PORTVERSION= 0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for Sound Mixer control
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+USE_PERL5= configure
USES= perl5 shebangfix
SHEBANG_FILES= volume.pl
-USE_PERL5= configure
+
+post-install:
+ ${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/Mixer/Mixer.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/Mixer/Mixer.so
+ ${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/Mixer/Mixer.so
.include <bsd.port.mk>
diff --git a/audio/p5-Audio-Mixer/files/patch-Mix.c b/audio/p5-Audio-Mixer/files/patch-Mix.c
index 27a478aaa751..0daee9faf3f8 100644
--- a/audio/p5-Audio-Mixer/files/patch-Mix.c
+++ b/audio/p5-Audio-Mixer/files/patch-Mix.c
@@ -1,6 +1,6 @@
---- ./Mix.c.orig 2011-06-21 21:06:03.000000000 +0200
-+++ ./Mix.c 2011-06-21 21:06:53.000000000 +0200
-@@ -78,7 +78,7 @@
+--- Mix.c.orig 2003-03-27 05:43:11 UTC
++++ Mix.c
+@@ -78,7 +78,7 @@ close_mixer() {
#ifdef DEBUG
fprintf(stderr, "close_mixer()\n");
#endif
diff --git a/audio/p5-Audio-Mixer/pkg-plist b/audio/p5-Audio-Mixer/pkg-plist
index 211a3c374486..31b14d564132 100644
--- a/audio/p5-Audio-Mixer/pkg-plist
+++ b/audio/p5-Audio-Mixer/pkg-plist
@@ -1,5 +1,5 @@
-%%SITE_ARCH%%/Audio/volume.pl
%%SITE_ARCH%%/Audio/Mixer.pm
+%%SITE_ARCH%%/Audio/volume.pl
%%SITE_ARCH%%/auto/Audio/Mixer/Mixer.so
%%SITE_ARCH%%/auto/Audio/Mixer/autosplit.ix
%%PERL5_MAN3%%/Audio::Mixer.3.gz