aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Net-DAAP-Client/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-08-08 23:42:13 +0000
committerLars Thegler <lth@FreeBSD.org>2004-08-08 23:42:13 +0000
commit1468bfb06dd1b7f0ed74f74109f97ceb7839492e (patch)
tree8e8c599dd141b45eeb3dec93dbc89faea5a2c826 /audio/p5-Net-DAAP-Client/Makefile
parent60d48380d46e0495ee073c9a34f919dbcb9c5fd1 (diff)
downloadports-1468bfb06dd1b7f0ed74f74109f97ceb7839492e.tar.gz
ports-1468bfb06dd1b7f0ed74f74109f97ceb7839492e.zip
Notes
Diffstat (limited to 'audio/p5-Net-DAAP-Client/Makefile')
-rw-r--r--audio/p5-Net-DAAP-Client/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/audio/p5-Net-DAAP-Client/Makefile b/audio/p5-Net-DAAP-Client/Makefile
index 064bb52e44d4..25e804b89dc3 100644
--- a/audio/p5-Net-DAAP-Client/Makefile
+++ b/audio/p5-Net-DAAP-Client/Makefile
@@ -1,36 +1,34 @@
-# New ports collection makefile for: p5-dapple
+# New ports collection makefile for: p5-Net-DAAP-Client (formerly p5-dapple)
# Date created: 27 June 2004
# Whom: Lars Thegler <lth@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= dapple
-PORTVERSION= 0.21
+PORTNAME= Net-DAAP-Client
+PORTVERSION= 0.41
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
-MASTER_SITE_SUBDIR= ../by-authors/id/G/GN/GNAT
+MASTER_SITE_SUBDIR= Net
PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
-COMMENT= DAAP library for Perl
+COMMENT= Client for Apple iTunes DAAP service
-BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5/M4p.pm:${PORTSDIR}/security/p5-Digest-MD5-M4p \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Net/DAAP/DMAP.pm:${PORTSDIR}/audio/p5-Net-DAAP-DMAP
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
-MAN3= Net::DAAP::Client.3 \
- Net::DAAP::DMAP.3
+MAN3= Net::DAAP::Client.3
.include <bsd.port.pre.mk>
-post-patch:
- @ ${PERL} -pi -e 's/Term::Readline/Term::ReadLine/;' \
- ${WRKSRC}/examples/itshell
-.if ${PERL_LEVEL} <= 500503
- @ ${PERL} -pi -e 's/^our ([@%]\w+)/use vars qw($$1); $$1/;' \
- ${WRKSRC}/lib/Net/DAAP/DMAP.pm
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
.endif
.include <bsd.port.post.mk>