aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Shout/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-14 15:10:39 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-14 15:10:39 +0000
commit123e52fddad22dcc43b30d930cf1d37d66f155fe (patch)
treeeba931909eb27cf784763cd68ea7a3d342e3f9d0 /audio/p5-Shout/Makefile
parent978782db68eebc7df1df050a589fb9fdc7453f48 (diff)
downloadports-123e52fddad22dcc43b30d930cf1d37d66f155fe.tar.gz
ports-123e52fddad22dcc43b30d930cf1d37d66f155fe.zip
Notes
Diffstat (limited to 'audio/p5-Shout/Makefile')
-rw-r--r--audio/p5-Shout/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
index 542a24b0a662..2d089369f753 100644
--- a/audio/p5-Shout/Makefile
+++ b/audio/p5-Shout/Makefile
@@ -6,29 +6,32 @@
#
PORTNAME= Shout
-PORTVERSION= 1.0
+PORTVERSION= 2.0.1
CATEGORIES= audio perl5
-MASTER_SITES= # http://www.icecast.org/files/libshout/
+MASTER_SITES= http://www.icecast.org/files/libshout/
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mat@FreeBSD.org
COMMENT= Perl glue for libshout MP3 streaming source library
-LIB_DEPENDS= shout.2:${PORTSDIR}/audio/libshout
+LIB_DEPENDS= shout.3:${PORTSDIR}/audio/libshout2
PERL_CONFIGURE= yes
MAN3= Shout.3
-pre-configure:
- ${MKDIR} ${WRKSRC}/examples
- ${MV} ${WRKSRC}/example.pl ${WRKSRC}/example2.pl ${WRKSRC}/examples
+DOCSDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+post-patch:
+ @${PERL} -i -pe 's/CCFLAGS/INC/;' ${WRKSRC}/Makefile.PL
+
+post-configure:
+ @${PERL} -i -pe '$$_ .= " ${PTHREAD_LIBS}" if /^LDDLFLAGS/;' ${WRKSRC}/Makefile
post-install:
.ifndef(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* \
- ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/example*.pl ${DOCSDIR}
.endif
.include <bsd.port.mk>