aboutsummaryrefslogtreecommitdiff
path: root/audio/p5-Shout/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-09 11:01:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-09 11:01:36 +0000
commit6922448ef18fb1ee5857118039550ccfa41b613f (patch)
treedfb2031df58d7b7036aa0f8a5d990323ecd69e89 /audio/p5-Shout/Makefile
parent3747e4d309114346aeb75439e2380dcffc058eba (diff)
downloadports-6922448ef18fb1ee5857118039550ccfa41b613f.tar.gz
ports-6922448ef18fb1ee5857118039550ccfa41b613f.zip
Notes
Diffstat (limited to 'audio/p5-Shout/Makefile')
-rw-r--r--audio/p5-Shout/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
index d8b01f0fe836..2c22c9f8d01a 100644
--- a/audio/p5-Shout/Makefile
+++ b/audio/p5-Shout/Makefile
@@ -12,13 +12,13 @@ COMMENT= Perl glue for libshout MP3 streaming source library
LIB_DEPENDS= libshout.so:${PORTSDIR}/audio/libshout2
-USES= perl5 pkgconfig
-NO_STAGE= yes
+USES= perl5 pkgconfig shebangfix
USE_PERL5= configure
-MAN3= Shout.3
-
DOCSDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+SHEBANG_FILES= *.pl
+
+MAKE_ENV+= DESTDIR="${STAGEDIR}"
post-patch:
${REINPLACE_CMD} -i '' -e 's/CCFLAGS/INC/' ${WRKSRC}/Makefile.PL
@@ -26,10 +26,13 @@ post-patch:
post-configure:
@${PERL} -i -pe '$$_ .= " ${PTHREAD_LIBS}" if /^LDDLFLAGS/;' ${WRKSRC}/Makefile
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/example*.pl ${DOCSDIR}
-.endif
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Shout/Shout.so
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/example*.pl ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>